[Request] BIOS mod to disable ME on MSI Godlike Z390

Hello @dsanke or anyone else who can help me.

I would like to request you again for another BIOS mod. This time, it’s for only disabling Intel ME for a MSI Godlike Z390 board. Mostly setting up the HAP bit.

Here is the BIOS .bin file from the board dumped using SPI flasher.

Many thanks in advance.

don’t disable ME fw,.,because you will get an unstable system

try MSI “NB” hotkey in bios F2+ L alt + Rshift + Rctrl “in bios keycombo - full advanced”
or is possible send variable offset for disable

if works hotkey ADVANCED/ME-FW - ME disable

but not recommenced this !!!

why do you even want to disable ME FW ? :grinning:

Thank for trying to help. The hotkeys not working in my desktop motherboard.

I have tried the PR from here Adding soft-disable support for IFWI/ME12 by dt-zero · Pull Request #282 · corna/me_cleaner · GitHub and the system goes into continuous bootloop from POST code “A2”.

Tried many times in the past few days and today I blew up my SPI flasher :sweat_smile:

I can flash back the original OEM BIOS version to make the system boot though.

Any help from anyone would be appreciated.

the offset for shutdown exists in the bios, … but you have a broken ME FW -
CMOS RESET ,.,or ME FW tools “from EFI or DOS”.,.or try last bios

flash with HWflasher can also break the system “impossible flashing MSI official files !!!”

best to start with ME system toolMEManuf .,.in EFI” find more info.
it is possible that your problem is not related to ME FW at all “or have HWdefect on this chip”

,.,. ME system tool 300series for debug info ,.,.no flash !

1 Like

or any bios screen is possible “system info” ??
.,also try CMOS RESET


ME State 0x2
One Of Option: Disabled, Value (8 bit): 0x0
One Of Option: Enabled, Value (8 bit): 0x1 (default)

try your bios backup !!!
…,bios is possitible get on backup ?? ,.here is visible ME -12…x…x.x or ?

if still get boot-loop
verify storage’s is visible and you using UEFI + GPT or any special NVME ? /CMOS RESET / verify SATA controller vs device .,.etc

or when you have the option to flash the original files for repair
try this + variable offset “in GRUB / RU.EFI”

but disable ME - broken ME FW “it usually freezes in this position !!!
.,recommend find ME FW change-log here is this problem visible for older version - MSI using only old FW”
try disable ME - only on newer versions “for functional control on/off state”

MEcleaner -this is more aggressive way :confused:
.,.easy way for corruption in ME FW not must works re-flash for repair

,.,but i not recommended disabled ME !
it is better to try the update or ignore all about “ME FW” when all works :smiley:

.,.if your ME FW stuck -
“must try contact @svet on msi forum” but most time is this error forever !!!
also device SN and some next ID missing in bios “for msi sw” this not must works / also device not must works normal “this is how it was with MSI laptops”

maybe the MOBO is better off :sweat_smile:

good luck



  • Security update.

  • Mitigated the following security vulnerabilities: INTEL-TA-00575 (IPU 2021.2) - CVE-2021-33107 INTEL-TA-00539 (IPU 2021.2) - CVE-2021-0161, CVE-2021-0164, CVE-2021-0165, CVE-2021-0166,CVE-2021-0168, CVE-2021-0170, CVE-2021-0174, CVE-2021-0175.
  • Added support of Microsoft Windows 11 OS

  • Security update.

  • Security update.
  • Resolved an issue with RCO power cycle commands.
  • Fixed a web encryption issue.
  • Resolved a system hang after rebooting when upgrading from ME FW or older.
  • Fixed a system hang during warm reset.

  • Security update.
  • Update the PMC FW to version 300.2.11.1025.

  • Security update.
  • Update the PMC FW to version 300.2.11.1024.
  • Resolved a Blue Screen after resuming from standby with device guard enabled.

  • Security update.
  • Update the PMC FW to version 300.2.11.1021.
  • Resolves a FWUpdLcl tool issue that would result in Error 0x3.
  • MEInfo now correctly reports CSME version information.

  • Security update.
  • Resolves Wake On Lan issues from Sleep, Hibernate, and Powered Off states.

  • Security update.
  • Fixes an issue where the system will fall into a reboot loop after disabling AMT.
  • Fixes an issue where CSME no longer responds after a BIOS Capsule Update while AMT is disabled.
  • Fixes an issue with MEInfo not being able to identify the Intel ME device.
  • Fixes an MEInfo issue where the wrong PCH data is reported.
  • Fixes a system hang during power transitions.
  • Fixes an issue where the WebUI is not accessible after resuming from standby/sleep.
  • Fixes a KVM black screen issue after resuming from S3.
  • Fixes an MEInfo crash when using special characters in the command line arguments.
  • Fixes yellow bang (device manager) on LAN devices after a reboot.
  • Fixes yellow bang (device manager) on the Management Engine Interface device after resuming from S3.
  • Fixes an “auto wake” issue from hibernate.
  • Fixes PKI provisioning.
  • Fixes KVM mouse movement does not wake remote screen.
  • Fixes an MEInfo issue where the wrong MAC address is being reported.
  • Fixes an issue with Intel PTT going into failure mode after a FW update.
  • Fixes AMT provisioning issues.
  • Fixes a global reset issue after enabling or disabling Intel ME in BIOS setup.
  • Update the PMC FW to version 300.2.11.1020.

  • Resolved an AMT timeout issue which would cause a long delay during BIOS POST prior to booting to the OS.

  • Security update.
  • Implemented a workaround for PMC to clear USB2 PHY core wake upon entering warm reset cycle.
  • After performing FW Update and trying to open a session to an Intel® DAL applet, a wrong error message is shown for failed verification of the HMAC
  • Fix an issue when the System comes out of S3, Intel® KVM connectivity is lost.
  • Fix an issue when performing an update on the FW, system reboot after shutdown.
  • Intel® Ethernet connection I219 goes to high power in modern standby with LAN cable connected to an isolated router without internet.
  • Fix an issue the CPU residency is too low during plug in LAN cable.
  • Fix an issue when Deep Sx is enabled, changing the CPU to vPro will not change AMT type.
  • Update PMC FW to 300.2.11.1014