[REQUEST] Dell Latitude E7270 recover from BIOS problem

My Latitude E7270 would not run from or charge the battery (worked on AC power) and showed pre-boot error “(A7) ME FW Downgrade - Request MeSpiLock Failed” every time on boot.
Regular Dell BIOS upgrade (from the DOS executable) would not work with same failure.

I dumped the BIOS chip (Gigadevice GD25B128CSi6) with a CH341A/SOC8 clip (file attached) and tried to clean it as per instructions here, but without success (computer would not boot)
At step 7 there was no “Platform Integrity” section so I skipped to step 8. But there is a “Hash key configuration for Bootguard/ISH” section with just one entry for OEM Public Key Hash.
But I could not see how to enter a SMIP Signing Key entry to continue through Step 7 with the generation of a dummy key and later replacement.

I would appreciate some help - instructions or actual repair - to recover a working BIOS image I can flash back to the chip with the CH341 programmer. If I can get to a stage where I can run Windows I’ll be happy. If I can get to upgrade the latest Dell BIOS by official/software means I will be even happier.

I tried BIOS recovery by renaming a freshly downloaded Dell BIOS exe to BIOS_IMG.rcv, write to USB, connect power cable while holding CTRL-ESC but nothing happened.
I also found another dumped BIOS image (on the internet) but apart from checking it is similar (using ME Analyzer) I would prefer to keep my MAC addresses, Service tag and associated info.
Many thanks
Damaged BIOS file https://1drv.ms/u/s!AiOAm8yGqGZexGLmTPKYGM5ltWxL?e=XP8SAR

Dell Latitude E7270 Intel Core i5-6300U 2.4GHz, 3MB L3 cache, 8GB DDR4, Touchscreen=NO, Fingerprint=NO, WWLAN=NO, LAN=YES, WLAN=YES, Bluetooth=YES
I have a CPU-Z report with Service tag, UUID, MAC address etc if this is useful

@regsoft - What software/version did you dump the chip with?
For Write to this chip >> GD25B128C use 1.34 and BIOS ID GD25Q128 Or Colibri with this same ID - or ASProgrammer 1.41 and exact chip ID - software/versions mentioned here
As for the ME FW guide, when you see no Platform Integrity at step #7, you move on to next step (ie not much to do when running this BIOS/ME through the guide)

Boot Guard may be enabled at PCH on this system, so you may not be able to program back a fixed dump, but we shall try!
Here, this is your BIOS dump, with fixed latest ME FW only, program in as mentioned above and lets see how it goes before we attempt touching the rest of the BIOS.
If this fails, before we touch BIOS region, I will redo with same old version ME FW that was in there originally, in case due to it being old 2016 BIOS region needs old ME FW too

@Lost_N_BIOS Great news! It works. Booted first time to Dell logo and restart, flash keyboard illumination, to Dell logo and a message that I should run SETUP and set date and time. The BIOS GUI is active, trackpad OK. I set the date and time and exited. Windows then loaded, So far so good.

Before I go further should I run Flash Programming Tool with command ftp -greset as mentioned at Step 15?

I guess the next step can be to run the latest Dell BIOS update - Latitude_E7x70_1.24.3.exe (currently at 1.6.3). While ME is now at (thank you!) I guess I should update the BIOS.
The battery reports Health as “communication error” and although reporting 43% charge the system dies without AC power. But that may be the battery getting old. The fan has not yet come on but I don’t think it’s hot enough to activate.

So thank you bvery much for the BIOS image, you’ve saved another computer from recycling (maybe) or landfill (more likely, unfortunately).

Previously I had used CH341Programmer 1.13 from the Chinese company because it was provided and had a “Chip detect” function to make sure I had the clip on correctly. But I also used AsProgrammer 1.4.1.
At this stage I’m not sure if the problem was the programmer or the image.bin that I created. But I flashed your image with CH341Programmer 1.34 that I downloaded from your link. It is clearly the best and more informative than the other two. So thanks for that too.