[Request]ECC Support for MSI X99A Gaming Pro Carbon

Was looking for someone who could add a support for DDR4 ECC Modules for the MSI X99A Gaming Pro Carbon.

Officially, MSI did not write about ECC support on the product page,

yet on LTT forums some people said that THEIR models does work with ECC Memory.

Current installed CPU: Intel Xeon E5-2640 v4
Currently installed memory: GOODRAM IRDM X DDR4 IR-X2666D464L16S/8G

Modules that i was trying to use: Samsung 8GB 1Rx4 PC4-2400T-RC1-11-DC0 M393A1G40DB1-CRC0Q

Tested on my motherboard with all bios versions: 1.0, 1.1, 1.2, 1.3, 1.4 and 1.5(beta)

Currently, running bios version 1.3

You can download that motherboard bios files here.

Thanks for the help :slight_smile:

So go there to our good old friend Linus forums and ask how or if the user you stated this can do this for you, simple humm.
Have you done any research yourself? If so you should share it here with users, in order to get further tips on the path to follow…
Have you at least, checked the available options on the bios hidden/blocked etc… have you used any of the tools from AMI and from other projects here on the forum/linked in forum?

Look i just mentioned LTT only because there was a topic on forums where people compilated which x99 worked with ECC, and there was only 1 guy who said that ECC worked, thats all - it is just an mention.

I looked all over the bios settings searching for anything that might need to be changed / switched or anything, yet it did not work.

I used AMI AFU For Aptio 5 from the files that Fernando uploaded for [Guide] How to flash a modded AMI UEFI BIOS to export .ROM.

Loaded that .ROM file with AMIBCP 5.02.0023 and under /Setup/IntelRCSetup/Memory Configfuration I found THAT

If I understand correctly… I should change “Access / Use” from “Default” to “Supervisor” and “Optimal” & “Failsafe” from “Auto” to “Enable” ?

And next I should just save file with amibpcs, open back AFU and… flash right?

Or am I missing something?

Sorry if you took me wrong @MeatWar - I am just new here and trying my best

will improve with time, I promise :slight_smile:

AMIBCP wont work on all modern Aptio V bioses as it was in Aptio IV, thats why you can see a lot of users that must use RU/IFR extract tool and hex edit the variables/strings.
That sub menu only appears if the parent nenu is visible, meaning that if the IntelIRCsetup is not present, thats the one to unhide, if its already visible then its the the Memory Configuration, you can only unhide a string.

1 Like


IntelRCSetup or Memory Configuration cannot be found anywhere - from the bios view itself

And while looking at the AMIBPCS i cannot really find a way of how to unhide IntelRCSetup menu

I decided - just for test to “unhide” IntelRCSetup menu here - and flashed it via AMI AFU For Aptio 5, had no error popup or anything

Tho, could not find that anyway in the bios (I guess I have to somehow… map it??)

Just to be sure, i exported fresh rom right now after it rebooted (after flash completed previously) and checked that new rom with AMIBCP, and settings seems to be saved

but still cannot load ECC memory :confused:

Got any tip where i could start looking next?

You can try User instead of Supervisor…some dont like “Supervisors”, still the tool may not be useful as i stated before.
But again you must not touch single variable, take of the ECC out of user/supervisor, leave it Default as it was

1 Like

Gonna give it a try and i guess will have to sit some time over the forums for more ideas how to touch that thing differently.

Thanks for help :slight_smile:

No… you just need to use the tools i stated before, now if youre looking for an easy 123 done guide, there is none as not all OEM bios are equal, the same regarding its structure, thats why no easy guide/tool, so welcome to the mod world and start seeing what it takes to do some mods and why users can expect that coming here and just pick it up.
The best modders are users with brains (more than me) time and dedication (more than me)…they have a cat, a sofa, usually no girlfriend, do you get a picture of it… later they disappear, life woke them up and they move on.
Im no modder and im getting old, cheers, all the best.

1 Like

Can i ask did you able to install the ecc ram on the Msi gaming pro carbon x99 motherboard with xeon processor (e5-2699 V3). I just install the ecc ram (432gb=128gb) into my motherboard with e5 2699 v3 processor and it did not boot up. it just give an error 19, b0, 55. My motherboard works fine with another ram memory kit that is Kingston hyperx fury (48)=32gb 2133MHz. I flashed my bios with the latest version but it did not work at all. Still same problem I am facing. Any help from the form will be highly appreciated.
The link for the ecc ram given below.