[Request] Fujitsu D3348-B1X BIOS with Broadwell Support

I bought a Fujitsu D3348-B1X thinking that it will support my V4 Xeon but now it’s clear it only officially supports V3 Haswell.

Fujitsu released a newer board D3348-B2X which is very similar but has some differences ( the mention the TPM for instance ).

I’d like to add support for Broadwell to my D3348-B1X as I think the harware is perfectly capable ( has Intel C612 ).
I understand that just adding Broadwell microcodes to it might not be enough ( I’m curious what else is needed ) .
One option would be to use some tools and mod the D3348-B2X BIOS ( seems like AMI BIOS so MMTOOL or UBU ? ).

I’d appreciate any ideas on how to proceed. I’m willing to do the work myself but I could use some pointers.

Attaching latest B1x and B2x BIOS files.
D3348-B2.ROM.zip (3.9 MB)

D3348-B1.ROM.zip (3.5 MB)

Edit by Fernando: Thread title customized

It is not probably that easy as adding microcodes. I have dual processor Fujitsu motherboard. It also did not get updated to Broadwell-EP processors. What I understand Broadwell-EP was supposed to be “drop in”-prosessor. Fujitsu just decided made new edition of the board, which supported Broadwell-EP’s.

I did try my board with Broadwell microcodes. I won’t boot with E5-2660V4-processors installed. It just turns on and nothing happens. But you can try yourself.

You can add microcodes with Fujitsu’s bios update tool(Dos version). So no need to modify with other tools. I don’t know where you find this tool, as Fujitsu has removed bios downloads for these boards.

If your are gonna edit bios, I REALLY suggest to get a bios clip and Raspberry Pi. When modifications go wrong it is easy to restore with Flash Rom.

Hi thanks a lot for the reply.

Yes, Fujitsu just decided to do a new board revision and only support Broadwell on those. I suspect it’s because they wanted to sell a new line and their customers will not go in a pop a new CPU anyway ( at least for the most part ).

I’ve been told before that just inserting the microcode update will not do but I’m really curious as to why this is. Maybe there’s some more code for CPU initialization and that one needs to be changed also. I’ve searched and searched but couldn’t really understand what BIOS mods are needed. It already became personal , haha. I could just pop a V3 Xeon and leave it there I guess but it’s not a challenge to get a V4 working.
For my board at least I could still find the BIOS ( all of them ) on Fujitsu’s website.
Their DOS tool is called EfiFlash.exe from what I can see. To add the microcodes what did you use MMTool ?
Yes, I was thinking the same, that I need some hardware method to back up and then restore the BIOS. I’ve some some cheap programmers on Aliexpress but I didn’t know the the RPI can also do it.

Here’s were I found my BIOS on Fujitsu’s website by the way:

Somehow I was thinking this info about how to add Broadwell support shouldn’t be such a secret. If all else fails I’m just going to look at how Asus, Gigaby and others did it. What changed in their BIOS to add Broadwell support.

No their Efiflash.exe has option to update just microcodes to bios. Just enter efiflash.exe it should tell you commands. Adding microcodes is a nice feature.

I also have been wondering why Broadwell-EP’s won’t start.

Also MMtool is useless, As you need signed bios to flash it and MMTool won’t make signed files.AmiBcp makes broken files also I would avoid those.

Use UefiTool newest one and 0.22 for files and UEFI Editor if you want to research or modify bios values.

But first You have get around Flash Descriptor:

  1. Make backup of your current bios with Efilash.exe or reading chip via clip and backup up it to the cloud. Never ever change backuped file.

  2. Read this disable Intel Flash Descriptor

  3. Read it again.

  4. Make efi-bootable USB-drive and download this, Boot from usb-drive and somewhere there is value HMRFPO or something similar mentioned on Flash Descriptor topic. Set that value disabled and save and boot. Edit. value is in IntelRCSetup somewhere in security settings.

  5. Try safe bios with Intel FPT tools you need version 9.1 and if this doesn’t work if you still have Flash Descriptor on.

But if you don’t get Flash descriptor error. Everything is fine and you can Flash modified bios files using Intel FPT.

I don’t remember if I had jumper set near chipset which disabled Intel Me. But I do recommend this.

Thanks a lot. Sounds promising.

My plan is to try and compare the BIOS from the 2 revisions B1x and B2. They are very similar other than some minor things and, the TPM and I think the maximum RAM speed.
Do you know anything about FlashROM ? It also seems promising and seems to understand this Intel Flash Descriptor.
Overall sounds like this will take quite some time to pull of but hopefully it will also help other people because for now I was unable to find much info about this all.
Also an idea is to try and connect to the COM port on the board and maybe hopefully get some messages during boot up.
I read that Fujitsu also has some boot rom recovery, hopefully I can keep that and in case some stuff happens use it to recover the board.
According to some document I’ve read this recovery procedure takes a .ROM file and either loads uses it to restore the BIOS in the flash. I’ll test to see but if it just loads this .ROM it could be useful for testing.

FlashRom also complains Flash descriptor(You can make a backup with it). I don’t know if Flashrom can be forced to flash modified file(I didn’t try).

Your only choice to disable Flash descriptor will be either my way or using bios chip clip and programming modified bios with any supported program(FlashRom or something else).

I do recommend getting Raspberry Pi. I did try using CH341A and never succeded reading this motherboards bios to rom-image(CH341A has worked with everything else). Changed to RPI and saved my motherboard from my failed experience(Always make a backup).

Yeah I actually have a RPI3 lying around, that should do I think. Just need to get a clip which hopefully will work as I really don’t want to solder/unsolder chips, I’m a software dev and not much into hardware.
I suppose you just used a clip , right ? Did you power the MB or will it just be powered by the clip ?
Somehow I also feel that if these progs complain about flash descriptor maybe that should also be fixed or adjusted somehow before flashing.

Now I have time to answer:

I did use clip. Also I am not that interested about soldering chips. Don’t know if you have 8-pin bios chip installed to board or this awful 16-pin bios chip. Getting connection on 16-pin chip can be sometimes hard.

How I did it:

  1. Tried multiple times with CH341A and nope. Read result was random values or full of FF or 00. Always try reading to rom-file first, compare bios in uefi-tool/hex editor. As a last resort I decided to use RPI.

  2. As my board has self check when power is connected. I connected power plug to powersupply and allowed it to do its self check. After that turns off and waits power button.

  3. Connected bios clip after self check.

  4. Turned on RPI.

  5. RPI started Raspian and used Flashrom to read current bios to file.

  6. Copied bios file to usb drive.

  7. Opened copied file in Uefi-tool(Structure was ok) and also compared in Hex editor(Looked ok). Connection was good to try flashing.

  8. Flashed earlier version of my modified bios.

  9. Removed bios clip and started my motherboard(Computer). It did not get stuck middle of loading bios anymore.

Also clearing cmos, bios recovery mode did not work in my case->I had to try flashing earlier bios.

Thank you a lot for these detailed instructions. I will see what I can do but first I need to wait for my V3 2650 Xeon to arrive.
Bought it cheap on Aliexpress for $5 because I didn’t just want to spend more money on this but now I have to wait.
Also did some reading online , I’ve found some document describing the Intel boot and it seems quite interesting.
It’s called “uefi-firmware-enabling-guide-for-the-intel-atom-processor-e3900-series” , a PDF.

Indeed the microcode doesn’t seem that important. Instead there’s modules that do CPU initialization, they mention CpuDxe but I’ll need to look at the Fujitsu BIOS to see which modules might be responsible for this.