[Request] GA-X58A-UD5 Rev 2.0 mod for NVMe

I have tried following both and neither worked for my Bios editing.

Meanwhile I have downloaded and opened the modded BIOS you have used.
Here is the picture, which shows the inserted NVMe Option ROM modules:
Various inserted NVMe Option ROMs

The missing module named 15B7_5017.BIN is the reason why you were not able to boot off the WD Black SN770.
Before you try to insert yourself the missing Option ROM, you may do a deeper look into the start post of >this< thread.
By the way - it would be a good idea to remove all 14 (not matching ) NVMe modules and to insert just the matching one. Benefit: Less BIOS compression needed and faster access to it by your PC.
Please don’t bother me with additional help requests.
Good luck!

In the tech power up he stopped adding new nvme.

<<Brand/Model completed bios files will not be updated again.
After that, special Bios requests will unfortunately not be answered.
Since I am extremely busy, the bios modding process for each NVMe SSD module takes a lot of time…
Bios requests will not be interrupted and there will be many requests for individual bios modding for the user.
That’s why I don’t have much time.>>

The best is to find a compatible nvme drive that is already patched, you can search them from the ids that provided from fernado.

I have managed to add the missing module named 15B7 5017 by following the liked how-to’s. thanks for that! However, the SSD still wont show up in the bios, which leads me to think something is not compatable. I have tried using the NvmeOpRom.zip and generating the VMware ssd OPRom, that is the result you can see in the picture.

As this didnt work for me, I have tried to extract one of the OPRoms found in the modded Bios from Ismail thread linked in my original message. I have modified that using the configuration tool found in the NvmeOpRom.zip. Inserting this into the BIOS led me nowhere again, as the system would freeze before I am able to even enter BIOS menu. Removing the SSD helped to get back to backup version of BIOS.

Thus, I believe I am forced to use another method, like Clover to make use of the SSD.

Thanks for those who replied and put me on the correct path and helping find the tools to mod the BIOS.

Please open your modded BIOS by using CBROM and attach a picture of its content.
Furthermore I recommend to open the 15B7_5017 module you have inserted by using a tool like HxD and compare its hex code with the attached *.BIN file, which has been modified by me today.
15B7_5017.rar (9.9 KB)

Hereby the requested image. I will compare the files and come back to you shortly. Thank you for the support.

There is something wrong with your inserted NVMe Option Rom. Its original (uncompressed) size should be 17,50 KB.
This is what I got with the same BIOS after having removed all not matching NVMe modules and inserted the matching one:

Indeed the one I had from [Experimental] NVMe Option ROM - BIOS/UEFI Modding / BIOS modules (PCI ROM, EFI and others) - Win-Raid Forum (level1techs.com)

Is different from the one you created, but it is the same as the one I copied from the modded BIOS and modified using the config tool.

I have tried to flash with the bin file you provided, and I had the same stuck black screen with - in left top corner. Had to remove the SSD, then I was able to access BIOS and reverse to my backup.

I guess its just not meant to be.
I managed to get the Clover working, but that is an extremely slow way of booting, as it takes around 5min.

If you are curious, or someone else who faces this similar issue, I am attaching the bin files here.
15B7_5017.rar (23.4 KB)

Thanks for the clarification regarding the size of the inserted NVMe module.
Another mystery: Look into the module LOGO BitMap (No. 19) of your modded BIOS. Its name and size are quite different from the original BIOS. Do you know the reason?

Update: I found it out myself - you have obviously used another original BIOS as source (probably the latest Beta BIOS named X58AUD5.FF1).


That is indeed correct. Once the modded one didnt work, I have tried to use the original latest BIOS file from Gigabyte.

Kind regards,

Thanks for trying to help the thread opener, but I in my eyes it is not a good idea
a) to insert into a BIOS 14 NVMe modules, of which a maximum of 1 can be used by the target system, and
b) to take an 18KB sized module, although a proper working 8KB sized NVMe Option ROM is available >here< (thanks to our BIOS modding expert Ethaniel).

I use the bios from 2022-X58/1366 PIN Motherboards NVME M.2 SSD BIOS MOD Collection | TechPowerUp Forums, it was reported working.But there is not 15b7_5017.bin inside the bios.I extract 15b7_5019.bin and create 15b7_5017.bin, then use it to replace 144d_a804.bin inside the bios.

That is exacly what me, and @Fernando did too. Unfortunately it does not work

It is generally not a good idea to discuss here the possible reason for a problem a user got after having tried to follow an advice/offer, which had been published within another Forum.

Have you tried to flash the BIOS, which had been modified by you following >this< Guide and whose content has been posted by you >here<? If yes, what happened?
According to what I see, you should be able to get Windows installed onto your NVMe SSD after having successfully flashed this self-modded BIOS.

Sorry, can’t give you any help.

never posted before. did a search and found this forum. thanks for the info.

Which info do you mean?

I have indeed tried both, and with the NVMe.zip guide it boots and shows it in the PCIe devices list, but not under boot options, and with extracting the file from modded bios and changing it for my ssd, flashing the bios with it would freeze the PC on boot, would not even let me go to bios unless I remove the SSD card. So in my particular case neither worked. Sorry if I am being unclear, but English is not my native language. Im trying my best :slight_smile:

What boots (the NVMe SSD or your previously used SATA disk drive)?
If you are should be able to boot off the NVMe SSD, everything is fine. Maybe the Master Boot Record (MBR) is missing on the NVMe SSD, but can be created by doing a fresh OS install via USB Flash Drive.