[REQUEST]GIGABYTE MD50-LS0 - C612 unlock all cores

Hi !

I followed the topic dealing with unlocking turbo Freq on all cores, but I can’t manage to write the bios file after modifying it.

Here is the original bios image file :


and the modded file :


What am I missing ?

The FFS driver that I added is dual CPU v3x2_payne_0_0.ffs.
I also removed the 06F2 thing with MMtool.

Any help ?



original.zip (4.13 MB)

turbo.zip (4.08 MB)

@Alictus - I have not looked at your BIOS files, how did you make the "original" and how do you normally flash BIOS on this model, does it have Qflash?
I checked stock BIOS package, and this has several methods to update stock BIOS, and a few different BIOS/BIOS-Region files in there, so it looks like you can do this many ways.
I suggest you dump BIOS region only with FPT, then edit that, then program it back

Here is general method to do this, use files from stock BIOS update package, in SPI_UPD Folder
Copy FPT.exe + fparts.txt to root of DOS Bootable USB disk and do the dump from DOS as outlined below

Do step #1, then test step #2, if all OK and #2 says success, then edit file created at step #1 and then flash back via step #2 -

Remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled.

Step #1
FPT.exe -bios -d biosreg.bin

Step #2
Right after you do #1, try to write back the BIOS Region dump and see if you get any error(s).
FPTw.exe -bios -f biosreg.bin

DO NOT FLASH your currently modified file above with step #2, unless the above is an edited DUMP from your current system and NOT stock edited BIOS
* Edit - Also, I checked your edited "Turbo" file above, this is incorrectly sized BIOS dump, DO NOT Use this for ANYTHING!
This may be due to Gigabyte method/tool you used to dump the BIOS, it has 16bytes added at end, I see GBT tag in there, but maybe that is how the BIOS is on chip, not 100% sure

Thx for reply !

So i tried the steps defined above, but while flashing the modified bios file (modded from the file in step #1), everything goes well, flashing passed. But my comuter won’t start anymore.

So I used the Web interface (this is a server card, we have an embed web service that can allow us to modify some params and recover the bios) to flash the stock rom image.

I join the @step #1 dump file (dump.zip) and my modded file (modified.zip). Are you able to look what goes wrong ?

I did the mod with MMtool V5.2.0.24.
Dump & Flash with fptw64 (win version)



Edit : That worked ! Don’t know why my first attemp was not good. My E5-2620 V3 reach 3.2 on all cores. I’m waiting for my two 2660 V3 ^^

Thx for all.

dump.zip (3.22 MB)

modofied.zip (3.18 MB)

Hi !

I recently changed my CPU with 2 xeon cpu 2660V3. I tried to flash my bios to allow turbo on all cores in the 2 CPUs, but it doesn’t work.

Perhaps I added a driver that is too old and does not include my CPUs IDs.

Which driver should I add to my bios for two E5-2660V3 to allow unlocking turbo on all cores ?