[Request] How to clean NVRAM in BIOS

Hello everyone.
Recently, I got an Alibaba’s server motherboard, two-way LGA4189, and tried to get him to boot up. But every time he gets stuck in the B6 clear up of NVRAM.I’m looking for some tutorials on how to clean NVRAM on a programmer.Thank you.

Dump bios region with Intel FPT, replace NVRAM volume with original from bios update file, with UEFI tool.
Write back with FPT only if bios region is accessible for writing.
Do the same on a full spi dump or in full bios update file, for programmer.

Shorting CMOS pads didn’t work, with ATX unplugged usually works…

1 Like

Try to use BMC admin interface through LAN. From BMC you can reload BIOS with/without saving previous NVRAM variables. Default IP of BMC on LGA4189 is

Thank you very much,I have sove this problem.This BIOS does not support Step 5 processors, adding microcode to the BIOS will cause this problem.

Zhize, can you say what the board do you have? X12DDW, X12DPI, X12DAI? I never hear early that X12 boards can upload modified bios. As I know Whitley platform has very strong checksum checker, which block uploading of modified or unsigned BIOS mod. What software do you using to upload modified BIOS? Can you also upload such modified BIOS?

By the way, I’m interesting how to run x12ddw-a6 motherboard with ES cpus (CPUID 606A5). Now I have no any way to start such system. Then, I’m using ES cpus with x12dpi board, which is running well.

Happy New Year AlexKaz! This is a motherboard customized by Alibaba and designed and manufactured by Inspur, so he doesn’t have a model number and I can’t update the BIOS either. And this is a beta version of the motherboard, the PCH is ES. I found that his BIOS consisted of microcode with CPUID 06A0,0654,0655,0656,0657, I tried to use MMTool to remove a few microcodes, then add 06A5 microcode, boot with stepper 5 processor, and every time it gets stuck at the 0xB6. Booting a processor with step 0 will reboot at 0x60. If I use the original BIOS, the processor with step 0 will boot up smoothly. The BIOS information shows that he compiled it in 2019, so I think it’s because the BIOS is too old and doesn’t support processors with a higher stepper.

Thank you for explanation! Happy New Year!
Can you add, please, 06A0,0654,0655,0656,0657 microcodes to the archive [OFFER] Intel CPU Microcode Archives ?
I think, ucodes 0654,0655,0656,0657 are intended for lga3647 like 50654-50657. But it will be very interesting if ucodes are 60654-60657.