[REQUEST] Intel NUC 9 Extreme Bios


I’ve been able to dump and edit some fields I need to change in my Intel NUC 9 bios, however I cannot reflash the bios due to “Error 167: Protected Range Registers”. I’ve tried s3 sleeping the device but the protection remains. Is there any simple way to remove the protection (preferably without the use of a chip programmer)?




I’ve tried to override the “Me FW Image Re-Flash” and “BIOS Lock” variables that are set to undesirable values via both grub and AmiSetupWriter.efi, but I am getting security violations with both (GRUB_EFI_SECURITY_VIOLATION).

I assume the only viable path left is to write to the chip using a programmer?

Another tool for it: RU.EXE + RU.EFI (ruexe.blogspot.com)

And maybe yes the CH341 as last resource, with Intel hardware was always very few chances of sucess in bios mods and related.

Use the search box in the forum as there’s a lot of similar situations on NUCs from other users.

I have not found anyone else using this board. It seems to be very different from the rest.

I was able to modify the FD descriptor via a SPI programmer to read/write. I can now dump the whole ME from FPT, but I still cannot write due to Error 167 and I cannot change the variables in EFI due to the EFI security violation.

Is there anywhere else in the ME flash that would need to be changed to enable bios flashing from FPT?

Maybe building a new image with Intel FIT from ME package and edit the FD

@ryxnszn Someone on this forum who is very knowledgeable about Intel hardware/firmware is @IntelModder, so I will tag them for you and ask if they might have any ideas to help you.

1 Like

Unfortunately this hardware is a bit too recent for my existing knowledge.

I do have access to a NUC 11 Extreme that I can try and test things on - it might present the same issues. But my time is a bit more limited these days. Let me see what I can find out.


@IntelModder Thanks for responding and taking the time to look into it.

I’m able to flash the device via programmer but the BIOS on it right now has some sort of self repair that runs whenever I do so.

I’d be willing to put up a bounty if anyone has any idea of how to modify the BIOS to not auto repair and allow for easy reflashing from FPT.