Request: Modded ASUS Z87-A Bios

/GAN is not needed only on boards that have no SMI and BIOS locks, which are very rare now.
AFU is not as reliable as Intel FPT or flashrom, but it’s the only flasher that can bypass security verification issues on modern AMI Aptio-based boards.

Hi CodeRush,

I’m really confused.

Is it possible to have the bios that Virtualfred modded (Post #4) to load without security warning? I tried to mod using the command line PMPatch Z87A.CAP Z87APATCHED.C

So it seems that the biggest issue with modding certain .cap files is the Security Verification or Validation failed problem

Well, I hope that someone can get a functionnal tool to fix this.

Please read again, what Florin9doi has written within the post #14. This method should work for your BIOS.
There is an undocumented afudos command " /gan", which bypasses the Security Verification while flashing a modded capsuled BIOSes.

You should just rename the BIOS file to bios.bin.
By the way: This is exactly the BIOS name, when you have let the UBU tool do the modding.

Hi Fernando,

VirtualFred did remod with tool and Security Verification or Validation failed was still showing.

AFAIK he just modded the BIOS, but the procedure to circumvent the Security Verification according to post #14 has to be done by yourself.


He pm’d me and had re moded bios. It did not work.

How did you try to flash it?
How was the BIOS named and which Flash tool did you use with which command?

Hi Fernando,

To be frank with you it doesn’t really matter anymore because bios has been updated to 1707 version, but FYI he had renamed it Z87A.cap. I tried to rename the mofified version but to no avail.

Flashing a BIOS named Z87A.CAP requires the Flashback button, but AFAIK your mainboard doesn’t have it.

You’re confusing me even more.

I have flashed this board with.cap files since the begining. What do you mean?

I am sorry about that. That was not my intention.

Even nodded ones?
I repeat: You cannot flash a modded .CAP file the normal way unless your mainboard supports the USB Flashback feature.

OK, I understand. No I’ve never flashed a moded bios on this board. VirtualFred had run the moded bios with the PMPatch.exe because usually it will recreate a new file and will remove the security feature. That had not worked.

Now I have the new 1707 bios and I wonder if modding is still needed. I’m using latest IME firmware no raid and lates drivers.

Does anyone have a later version of this program? I’m not getting the /gan option to work (error: unknown command).

This is what I show: AMI Firmware Update Utility(APTIO) v2.36

Why no one try backup-mod-flash method with afudos (without /gan option)? It works for me as I mentioned before. It’s a fifteen min. operation.

AFAIK the undocumented command extension " /gan" only works with the tool afudos resp. afuwin.
We probably have to wait until CodeRush publishes his promised guide about how to bypass the "Security Verification".

error-id10t, latest versions of all AFUs can always be found here.

I have no time for writing guides now, sorry. Will do it ASAP.

This is old thread but i am also experiencing a security issue here. I am trying to flash a modded Bios to a Z170 Pro Gaming.
The Link is dead, leads to nowhere. The newser afudos versions don´t support the /AGN option->unknown. How do i bypass security check here ?
Thanks in advance!

AFAIK the correct command is "AFU /GAN".

AFU v5.05.04 supports the /GAN command in Windows and DOS. I tried other versions and they all didn’t support /GAN.