[request] MSI Z77A-G45 nvme mod request

Hello. I tried to mod with mmtool with MSI Z77A-G45 2.C BIOS but it fail to boot after i flash the modded rom with usb mflash in bios. the fan just spin and reboot immediately. I use a cheap CH341A programmer to recover the stock bios.It works again but still lack NVME support.
I have searched the forum but cannot find any working modded bios with this motherboard.Can some one help me out with the mod?thx in advance
the stock bios is msi.com/Motherboard/support/Z77AG45#down-bios

by the way, does any one know how to make mmtool work correctly on windows 10? the ui seems broken and it crash immediately when click the cpu patch tab.


7752v2C.zip (5.47 MB)

actually this post [Request] nvme bios mod for msi Z77MA-G45 shows that i should not use uefitool to mod the bios, it will break the pad file. maybe its the reason why i brick my motherboard.

the Z77MA-G45 board may very similar with my Z77A-G45

MMTool 4 works on windows 10 but you are right,it gives an error with that file
Ubutool works though



you need to install phyton from store in order to use ubu.uefit tool might work aswell

How to flash a modded AMI UEFI BIOS
How to extract/insert/replace EFI BIOS modules by using the UEFITool

Try using MMTool, result for compressed insertion of NVMe dxe looks OK. Since free space is in the beginning of pad-file, UEFItool might not work here.


Edit: MMTool gives 100% identical results and works properly (W10 20H2) for inserting NVMe module.

EDIT2: Since you already bricked your motherboard you have to dump/ backup your old bios with a programmer first before overwriting and recover board specific data.

EDIT3: Microcodes doesn’t work with 4.5 (crash) and 5 (doesn’t do anything), but since the thread is about insertion of NVMe module…

its optio 4
also using windows 10 20H2 but gave me an error,strange
you did try opening cpu patch tab right?


like i said.its optio 4.mmtool 5 wont open it (not all versions at least)
mmtool’s integrity in question here,regarding this file.besides there is no telling right now the crash caused by either user fault or tool’s.and if i was him i would have wanted to update microcodes etc as well while adding nvme support
Which version you have tried in your failed attempt?


Bios is Aptio4, yes, but MMTool 5.0 does work with these. 5.2 is required for Aptio5. See:

Microcodes are located in PEI volume for this bios, there’s a pad file which one seems to lose when updating with UBU, see picture.

Easiest way to keep this pad-file: Update µcodes with UBU, open new bios file in UEFIToolNE, extract µcode ffs ‘as is’, open original bios in MMTool 4.5 or 5.0, replace the volume with the extracted ffs. (But unsure if this pad file is needed?)

yes I do open the cpu patch tab and the program just closed. no error code or anything.
my operating system is windows 10 20H2 19042.746
I just curious how MMTool looks on you guys OSes? does it shows a broken UI?

MSI Z77A-G45 updated microcodes,modules and added nvme

Also you can check out [Guide] NVMe-boot without modding your UEFI/BIOS (Clover-EFI bootloader method) topic as an alternative way

Hi @onuracengiz , can you please re-upload that modded BIOS for the MSI Z77A-G45 board please? I had the same issues as OP and ended up having to desolder the chip since it wasnt responding to the CH341A programmer.

Thanks in advance

Address to a specif user using "@user", else he wont be notified, edit ur post.