[REQUEST] MSM Driver Update ICH10R - is that the right way? What can i do?

Hi there,
i want to build up my NAS with new HDDs and hardware i have.
My disks were not or wrong recognized in the Intel msm.

I read a little about INTEL Storage Problem with old raid controllers and newer HHDs and thought, i’ll give it a try and update the msm module with a new bin as described in your posts
Sry don’t found the BB codes for URL wrapping

How to update PCI ROM modules - [Guide] AMI (non-UEFI) BIOS Modding
Option ROMs for - SATA AHCI and RAID Controllers - AHCI & RAID ROM Modules

worked out well. But nahhh the controller still recognizes the HDDs as 746.5GB instead of 3TB…

Any ideas or hints?
i got from msm




The MoBo i use is the P5q Deluxe

if that is the wrong section sorry.

Andy last but not least. Thank you for your great work with the tutorials

@Lithos :
Welcome to the Win-RAID Forum!
Here is my comment:

  1. To be able to get your 3 TB sized HDDs detected, you will need a system with an UEFI capable BIOS. Contrary to the LEGACY mode Master BOOT Record (MBR) the modern GUIMode Partition Table (GPT) is able to detect and to manage >2 TB sized disk drives.
  2. For Intel chipset RAID systems from ICH7R up I recommend to use
    a) an Intel RST RAID driver resp. the related Intel RST Drivers & Software Set and
    b) an Intel RST RAID ROM BIOS module.
  3. As you can see >here<, the Intel RST RAID ROM v10.1.0.1008 can be inserted into the BIOS of your mainboard (bigger sized modules cannot be loaded while booting).

Good luck!
Dieter (alias Fernando)

Thank You very much @Fernando !
I looked up the List and found megatrons record.

ASUS P5Q Deluxe MB Intel ICH10R Intel RAID ROM v10.1.0.1008++Marv. RAID ROM v1.1.0.L73+LAN ROM v. success no problems megatron

I don’t know why. either i could not figoure out where the JMicron is in my bios rom. Since there is no VendorID for it within the entrys in the MMTOOL. Maybe i am not deep enough in that Tech-hole.
Is the JMicron embedded elsewhere then wiht a PCI Option?

i tryed the RAID ROM v10.1.0.1008, but didn’t worked for me. With the storage setted to RAID, the Post BIOS ctrl+i raid UI didn’t showed up.

But the hint was gold so far =) . After some research, and old posts that included discuss between megatron and you about drivers, try and error i could archive something:
The combination of >Marvell 61xx RAID ROM v1.1.0.L75 for DEV_6121< and >Intel RST RAID ROM v10.5.1.1070< from your AHCI & RAID ROM Modules post did it for now! yay
My drives in Full size firework


I am going to set up my NAS in the next days, and take the installation as a test. afterward i dig some more through the forum and will post the result.

Again thanks for your fast reply.

After flashing my old P5Q several times and try things out. Hitting right timed the pause key to lookup entrys. I notice once again i hate most of that new UEFI BIOS…

lol. Ich sehe gerade dein Profil und wir sprechen beide auch Deutsch >.< !Witzig!

@Lithos :
1. The P5Q and the P5Q Deluxe mainboards are different.
2. The JMicron Option Rom will only be used, if you are booting off an HDD/SSD, which is connected to the JMicron SATA port.

Yes i mean the P5Q Deluxe and wrote only p5q.

Okay, i get some trouble. I hoped that would be the solution already.
With >Marvell 61xx RAID ROM v1.1.0.L75 for DEV_6121< and >Intel RST RAID ROM v10.5.1.1070<
When the RAID is selected as storage option. i can access the msm ui and the hdds are correct recognized, even a RAID can be setted up proberly and is still shown after restart in the msm ui. but i can not get any further.
it seems to freeze after the msm setup ui or if i doesn’t enter the msm ui. if i enter it and leave it nothing happen, just a blinking prompt… i can not enter the bios other selected devices e.g. usb drive etc. nothing work.
only after restoring defaults with a cmos clear. other options (storage config {ide/ahci}) work and boot.

I don’t know what i could do next. i tryed again out ICH10R Intel RAID ROM v10.1.0.1008++Marv. RAID ROM v1.1.0.L73 but in that combination the msm gui won’t show up at all when RAID is selected as Storage option.

@Lithos :

Since the Intel RAID drivers and RAID ROM modules from v9.5 up belong to the much newer "Rapid Storage Technology" (= RST), the Intel RAID Utility (available via CRTL+I while booting) should not show the "Matrix Storage Manager" (= MSM) GUI.
1. Are you sure, that you have set the Intel (and not the Marvell) SATA Controller to "RAID" within the BIOS?
2. Why did you flash a modded BIOS, which contains an updated Marvell RAID ROM, which is neither needed nor used?

Some thoughts fell out onto the page as I passed by, use v10.1.0.1008 TRIM mod + do not update Marvell controller (especially if you are not planning to boot from this controller)