[Request] NVMe Support for Acer Z3761

Hello friends, my name is Adrian and I am new to the forum, I hope someone can help me with the problem of my motherboard, which is somewhat old. It is an Acer Aspire Z3761 – H67H2–AD v:1.0 with an intel core i3 2100 processor. And I bought a 240gb WD Sn350 M.2 Nvme SSD with its pci express adapter, but it only detects it as a storage drive in Windows 10 x64 Ltsc and the bios doesn’t detect it and I can’t use it for bootable installation. I saw out there it can be achieved by injecting a modification in bios, so you can use it as a boot disk. Can someone help me, thank you very much

EDIT by Fernando: Thread moved into the matching Sub-Forum and title translated/customized

Welcome to the Win-Raid Forum!
This is a pure English language Forum. If you want help, please edit your post and translate it. Otherwise it will be deleted.
Dieter (alias Fernando)

Thanks for having translated your request.
The options you have to be able to boot off an NVMe SSD with your old Acer Aspire Z3761 depend on the BIOS architecture (UEFI compatible or not) of its mainboard.
If the BIOS is an AMI UEFI one, you can modify it your own by simply following >this< Guide. If you mainboard BIOS is a Legacy (non-UEFI) one, you will have to use another method. You can find the related guides >here< and >here<.
If you are unsure, please upload/attach the BIOS file als *.ZIP or *.RAR archive.
Good luck!

Sorry for the late response. I have tried with MMTool and UEFITool_v0.28.0 programs. i couldn’t get m.2 ssd to boot with system. Am I missing any other procedure? Or could you give me another alternative? I attach a capture of how it detects it. Thank you

Thanks for having uploaded and attached the BIOS file.
Here are the results of my check:

  1. It is an AMI UEFI BIOS. Advantage for you: You can get full NVMe support by following my above linked Guide.
  2. It is easy to get the NvmExpressDxe_5.ffs module inserted by using the MMTool 4.50.0023 (I have tried it successfully without any Pad-file problem).

The problem may be to get the modded BIOS properly flashed into your Acer mainboard chip. I cannot help you regarding this task, but you may find some useful information within the start post of >this< thread.
Good luck!