[Request] Trying to get an eGPU working on a laptop

OK, I will see if I can do anything with the Whitelist on this system, hopefully it is not like the other one I mentioned previously!

I was able to open your BIOS region dump in one version of EZH2O, but was unable to find unsupported video or PCI (only unsupported video file types, formats etc). I also checked unsupported wireless to see, none found for that either.
I even searched for “halted” because this is shown to be present right before a whitelist (system halted, please remove etc) None found relating to hardware.

So, from what I can see, there is no whitelist, the part may simply be non-compatible.

EDIT by Fernando: Title customized

Oh, that’s bad news. Well, I think I’ll wait for the programmer and see if the hotplug works at the end.

I think it’s good news really, from what I could tell, no Whitelist for wireless or GFX. Did you try different wireless too, if yes do you get “Halted - please remove device” error?

Today I tried with a diferent Wireless device. It works fine. No errors. Then I tried using the eGPU adapter with a GT610, not work. Also tried with another eGPU adapter and a Quadro 2000, not luck. I tried turning on the laptop with the eGPU pluging to the screen, sometimes having unpluged the GPU makes my PC boot using the iGPU instead of the dedicated card, but at this laptop it does not work.

I’m thinking in some posibilities here. 1) Maybe the port is locked to just be used with wireless devices (¿?), or 2) It is not compatible with the eGPU adapter board.

In a normal BIOS sometimes I can just choose the GPU that I want to be used in the settings, but even unlocking the BIOS i know that option will not be there. I think the hot-plug still have good chances to work if there’s not way to figure out what’s locking the eGPU.

Great you could test, see, I didn’t find any wireless whitelist according to that easy guide method of checking, so I don’t think there is PCIE one either. It could be in another module possible, but we check the “setup” text which contains all the possible error messages presented to user, and nothing about halt for PCI/PCIE device or wireless either.
I think there is no whitelist and maybe only issue is what you thought about hot-swap needs enabled. Sometimes those ports are not always wired the same, some PCIE traces may or may not be powered, or have different data traces to each finger etc.

Hopefully once you have programmer the hot-swap unlocked BIOS will help!

About that, the way of the pcie could be wired diferent, I see that one the wireless does not have all the traces, just what it need I guess. But the port have all of them. Maybe it is diferent anyway. I tried again the eGPU adapter in another laptop to see if it works fine, no problems.

Ill wait for the programmer, thats my only hope.

Yes, as you see, some Mini-PCIE are wired differently, even if all the traces are there sometimes they go to different place on certain boards.
Even on big brand desktop boards, sometimes mini_PCIE slot can only be used for certain things, SSD or wireless may/may not be interchangeable sometimes, same for some M.2 slots, some can only use SATA type and others only PCIE type while the slots/pinout is the same.
To me, both of those are poor design flaws, stuff like that should be a set standard or nothing, otherwise it causes customer confusion, frustration and sometimes fried hardware too.

Well, it takes some time but finally the kit is here. I hope I can do this bios mod now haha

I think I managed to make a correct dump, I’m not pretty sure since this is the first time I do it but there’s it

edit: I guess I did it wrong, I’m trying to figure it out. The chip is a winbound 25q64fvsig, do you have some tip?

@idjaker - for W25Q64FV use W25Q64BV as the ID, and use software 1.30 or 1.34
Here is package with main driver, and then all versions of the software - http://s000.tinyupload.com/index.php?fil…257455007472602
I checked your dumps, neither of those are even correct BIOS size, so they are invalid based on that without even looking inside them - but then I looked anyway, all corrupted non-BIOS data, especially the 5.6MB file
Once it’s working, you’ll have an 8MB file, open that in hex and make sure it’s not all FF or 00 (nor looks all similar, like same characters over and over again like the 5.6MB file you uploaded above)

Here is general how to use/set up guide, if you had not seen this already
https://www.bios-mods.com/forum/Thread-G…341A-programmer << Same as one directly below, but with all images expanded/visible at once
[GUIDE] Flash BIOS with CH341A programmer

What are we wanting to do now once you get proper dump? I tried to read back, but couldn’t tell for sure. I know you want FPRR lock removed, and any other lock if I find, so you can flash easier with FPT instead of having to use programmer.
But, where were we at, stopped from doing before/during that discussion that made you get a programmer. Thanks for the catch up, sorry it’s unclear to me right now.

Yes, I did it wrong, I’m was trying to get the correct drivers and use the correct device with not luck, but now I’ll follow your instructions. And the main goal it’s just to enable hot-plug or hot-swap in the mini-pcie port, that’s it, because I think there’s just a chance to make the eGPU work. I’ll be glad if I unlock anything else but the goal it’s just that.

I also feel this is from a long time ago, but, well, I got the stuff. Even if it fails I have to try now Haha.

I have a question, when I plug the cable to the programmer it stop working, the PC says it’s disconnect. What could it be?

edit: I’m guessing now that my programmer is broken. Everytime I connect it to any chip, even in a gpu, it turns off itself.

I’m stock, I set my programmer en programmer mode and try to connect it to the chip but it turns off when it’s connected to bios. I don’t know what’s the problem, maybe something with voltage? I already read the guide and other manuals but I didn’t figure out.

@idjaker - did you get this figured out yet? Sorry for super late reply!
Sounds like you need to connect power to the laptop, if you did not when doing above mentioned testing attempts. What exactly do you mean “It turns off” what turns off?
Be sure you have it all connected correctly - [GUIDE] Flash BIOS with CH341A programmer
https://www.bios-mods.com/forum/Thread-G…341A-programmer << Same as guide directly above, but with all images expanded/visible at once

The programmer turns off. The light stop working and the PC says it’s disconnect when the programmer it’s plugged to the bios. I should turn on the netbook when it’s connected or just plug the power cable? I tried plugged the energy but when I do it the programmer gets hot so quickly and I have to unplugged.

Thanks for clarification. Sounds like it may be connected backwards, double check the guide to be sure you’re setting it up correctly, post some images if you are unsure.
No, don’t power on the other PC you’re connecting it to, but you can try with power cables and battery inserted, sometimes that’s required.

If programmer or BIOS chip is getting super hot instantly then it’s shorted and something is backwards (as my first comment mentioned).
Please show me some images of your cable going into the programmer, a few, and a image of your BIOS chip with nothing attached and then with cable attached so I can see how your connecting to the BIOS.