[Request] Unlocked ASUS X515JP BIOS

The Laptop comes with a Intel 10th gen 1035g1 processor which is locked… But it keeps hitting 90 C and keeps throttling very badly so I need to unlock the undervolting… I’m one version shy from the current bios version… My bios version is 308… Here’s a link to the bios: X515JP - Support

I tried changing the values of overclocking lock 0xDA to 0x00
and cfg lock 0x3E to 0x00 using grub…
Commands used:
setup_var CpuSetup 0xDA 0x00
setup_var CpuSetup 0x3E 0x00

Please help me, I’m gonna unlive myself…
Btw I’m new to this whole modded bios thing

Edit by Fernando: Thread title customized and shortened

If you upload the dump I can set both variables in your dump to 0x00 and you can flash it. That should work

My Intel ME Version is 13.0, Build 2101, Hot Fix 60… I cant find any guides to extract the dump file anywhere

Its all in the forum front page… FPT tool is part of the Intel Management Engine

Get the v13 tools package
As CMD line admin from the tool folder c:\fpt
ftpw64.exe -d spi.bin (Full dump)
ftpw64.exe -bios -d bios_region.bin (Only Bios region dump) this is thedump for moding.

Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15) - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)


[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

There is no ftpw64.exe in the tool I have for my ME version, there is just a fit.exe file in the folder… So the command doesn’t give me any file

And where did you get that package… im sure that’s not the one in the repository linked in the posts above.

Thank you very much, I followed the first guide and was able to get to the " make sure that “FWUpdate Support” is reported as Yes step.
Also here’s the bios dump link:

I also need help on how to open FWUpdate.exe… I tried using .\FWUpdLcl64.exe in cmd but it didn’t do anything and said “Error 37: Invalid command line option(s)”

Was able to flash the FWUpdate.bin too… Now I have FWUpdate support in “Yes” on my firmware

Can you dump with Afuwin? For me the Setup module of your dump looks like this:

So I opened afuwingui and just pressed save on this screen and saved the .rom file… I assume I’m doing it right…

And here’s the file I got :7 MB file on MEGA

Thank you