[Request] Working Intel ME Firmware for Lenovo T480

Have bought two T480 of ebay with locked bios password. I have dumped both bioses and removed password and flashed it back. Thanks to my stupidity I have managed to delete one of the images. So one computer runs fine. I have flashed same file to another computer - which runs however there is no Intel ME Firmware. The field in bios is blank and I cannot force ME firmware update as it is giving several errors. Lenovo utility says that cannot recognise SKU, ME utilities are giving error 8743.

Computer takes 30+40 seconds to boot and there are several things which I noticed so far are not working. Like going to sleep, restart and others.

Anyone any hints please on how to get ME back up working and what to do to get firmware loaded?

Many thanks

Edit by Fernando: Thread title shortened and customized


Machine specific information is noemally located in bios region of firmware.

If both machines do have the 100 % exact configuration a cleaned / re- configured ME (“configured” in MEA, never booted!) this ME region can be used for several machines of this type, there’s not yet machine specific data in the ME region.

Hi, many thanks for your resposne. I have been throught the text but I think it is beyond my abitlities to understand all the details. I am getting lost in what steps I should follow :frowning:

Well, you dumped the firmware and removed a password and flashed the firmware, how hard can it be…

On the other hand: One out of two working properly isn’t too bad, either.

:slight_smile: Thanks … so short summary I broke one of two :slight_smile: For dumping, removing password etc. there are really step by step instructions which I could follow but I guess compiling bios is bit more advanced.

Well, if plutomaniacs guide isn’t a step by step instruction then I don’t know. And I couldn’t explain it any better than he did.

I assume discussing if it’s possible or not costs more time than doing the procedure but anyway, that’s your decision.

Good luck!

1 Like

I would like to thank you for pushing me into this! I am now happy to report that I have managed to clean ME firmware and computer now works as a charm.

I was failing with FIT as it was giving me “Unable to open .bin file” message but luckilly found another version which worked.

It really looks complicated for newbies but if you read properly and follow step by step then it is doable!

Once again, thanks!

1 Like

Good to hear that all worked out :slight_smile: Thanks for the feedback :+1:

Hi, Can you share how to resolve this issue? I’m same boat.

This thread has less than 10 posts and all information needed is covered?

I have followed the guide shared by user LFB6!