[Solution/Guide] Fixing ME on a Dell Latitude e6540

Hey all, just wanted to put this out as a gathering of resources for anyone trying to fix a corrupted or otherwise defective ME on a Dell Latitude e6540 or similar laptop. It may help in other cases as well, and I’ll try to be clear where these resources may be Dell-only. Full disclosure that I eventually had to open up the whole laptop and short pins on the Realtek chip to unlock my FD and flash ME, but I did wind up running into a ton of helpful info and resources throughout in the forums here which may be of use. Massive shoutout to Plutomaniac, who appeared over and over again providing helpful advice and also putting together many of the info and resource threads that I used for this fix. I suppose this is my way of hopefully giving back to the community here after their posts and threads helped me through this issue.

The Problem

I had received a laptop (e6540) from a friend with a couple weird issues, mainly that the i7 in it would only run at 800mhz (lowest speed step) and the built in discrete graphics (AMD 8970m) would not work. After working through the usual suspects (Reinstall of Windows, drivers, AC adapter issues, thermal issues) with no luck, I decided to try flashing the latest bios. This is where I first noticed that the bios update would hang on "Sending Intel Management Engine Update", forcing me to remove the battery to abort the update. Luckily this doesn’t seem to have any lasting effects on the computer; it doesn’t flash all elements of the bios, but everything functioned. With no luck fixing the previous issues, I suspected the ME was the root cause. Attempting to access MEBx through the startup hotkey (Ctrl+P on the e6540) would leave the computer hanging on "Preparing MEBx menu", so I needed to attempt to reset or flash new ME firmware. If you are able to access MEBx, firmware flashing may simply be disabled. The default password is admin, you’ll have to provide a new strong password to change settings (Must have one capital letter, one number, one symbol). Under ME General Settings you will find a Local FW Update option, which should be Enabled. This was not possible for my case, so onward I went.

Working Through the Issue

My goal from that point was to reflash the ME, hopefully with the latest firmware, but this is something I’d never had to deal with before, so I took to google. Coming across Plutomaniac’s excellent thread here provided the basis I needed to get started. I began by downloading the latest tools that were compatible with the e6540, in this case that was Intel ME System Tools 9.1 r7 (MEGA Link from Plutomaniac)

The main tool needed here was Flash Programming Tool, or FPT, which has many useful functions. Most importantly, dumping and flashing firmware to and from the ME chip. Running an exploratory "fptw64.exe -d spi.bin" netted me an Error 26: "The host CPU does not have access to the target flash area. To enable write access for this operation you must modify the descriptor settings to give host access to this region." The FD (Flash Descriptor) was locked, and might be the root cause of my inability to flash new firmware. The rabbithole I entered after this eventually led me to a thread discussing hidden Dell bios options that ostensibly unlocks ME firmware reflashing and temporarily disables the ME:

After doing this and running:

fptw64 -d spi.bin
fptw64 -d fd.bin -desc
fptw64 -d bios.bin -bios
fptw64 -d me.bin -me
fptw64 -d gbe.bin -gbe

It was confirmed I had read access to the ME. Despite hopes that meant I had write access as well, on attempting to flash the latest ME firmware Dell had included in a bios ( with the command "fptw64 -f me.bin -me" (where me.bin was the latest ME firmware .bin, acquire through Plutomaniacs repository thread), I was hit with an Error 25, no write access. Darn!

But I had gotten somewhere, the ME chip was readable, and wasn’t a total write-off as I had dumped complete firmware from it. I had spent about 4 hours noodling around with this problem with only a little success, and decided to pull apart the laptop and try the pinmod technique I had by this point read about. Again, the fantastic Plutomaniac has a thread on the subject here.

The Fix

Using Dell’s own disassembly guide (PDF here, check out page 25: Removing the Keyboard) I gained access to the Realtek chip. On the e6540, this is located underneath the keyboard, near the power button on the top right. This is what you’re looking for. On this laptop model, the pins happen to be clearly labelled on the PCB, with pins 1-12 down the left side of the chip, thanks Dell! I was able to find a rough diagram of the ALC3226 chip on this pdf, sheet 27. As per Plutomaniacs FD unlocking guide, we’re looking for SDATA_OUT (or SDO) and DVDD (3.3V), and as per our chip diagram, those are pins 5 and 9, respectively.

At this point, armed with this knowledge, all of my firmware files and tools collected, a half gutted laptop and a questionably put together tool for shorting these pins, I powered up the laptop. The first attempt failed, but I kept at it and was eventually greeted with a wonderful successful dump of spi.bin. We had read access again, this time without a modified bios! And upon entering once again "fptw64 -f me.bin -me", lo and behold the firmware began to flash. After a successful reboot into MEBx with Ctrl+P, I flashed the latest firmware from Dell, which went off without a hitch. Booting up into Windows, the i7 was clocking up properly again, and the 8970m was again being utilized for games. I learned a lot along the way, and I hope this helps someone else out with a similar issue in the future. If you have any specific questions, please feel free to reply below, and hopefully I or someone else can assist or give more info.

Cheers, and thanks again to Plutomaniac for all of the work they’ve put into these forums.

Edit: updated link to ME System Tools 09/25/2022

Thanks for posting your guide and all this info for others

Hi there,

I do have a dell latitude E6510 … and a “Error sending end of POST to ME” message …

Reading your discussion has been very interesting, however, the problem is still here, with an interesting twist …

I lost the reboot function … so I can’t even try to upgrade or downgrade the BIOS …

Before to send you the complete story, I just wish to say hello and see if you might have some brain time to offer on this matter.


I know this thread is terribly old, and this will probably be unnoticed, but I thought I’d express my thanks anyways.

I bought a Lattitude E6540 off the second hand market, and immediate examination didn’t spur any doubts, unit was in good condition, already booted and ready to go, I bought it, drove home and slowly but surely realized my mistake.
The system was incredibly unstable, randomly locking up, sometimes not starting randomly, BSODing randomly, it was a mess. I thought updating the bios would be a good idea, as I noticed many fixes in the change log, however I could not install an update for the life of me. I tried using the Windows installation, DOS, and BIOS methods to no avail.

I tried every method to try and fix the problem bar this one, as this seemed a fairly involved and mildly scary.
As I had no success with other methods, I decided to bite the bullet and at 3 in the bloody morning I followed your instructions, I managed to get the latest A27 BIOS loaded by fixing ME.

The only problem with the laptop now is its less than ideal current limiting (which triggers even at idle, which I don’t understand, but ah well).
If I’m not willing to deal with the throttling, I can pass this laptop on knowing that it’s not going to cause the user pain (like I did).

Thanks so much for writing about your experience and providing the tools required to fix the problem, honestly, it’s completely solved my issues.

1 Like

Hi Can you please send me [Intel ME System Tools 9.1 r7 ] files or reupload it somewhere? Link is no longer active. Thank You

Tools are here: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

Section C2

Thank you for your effort and fast response. Unfortunatelly in my case even after grub commands “fptw64.exe -d spi.bin ” netted me an Error 26 so I’m now stucked. Will try connecting pins…