[SOLVED] 4TB WD drives not recgonized properly


WS: Dell Studio XPS 8100, W7 Ultimate, SP1, Intel i5, 16 GB RAM
Intel RST: V
Ctrl-I BIOS says:

I am trying to upgrade my 2 TB drives to 4 TB WD drives in RAID 1 by plugging a 4 TB one at a time and letting the RAID 1 rebuild. This time the rebuild wont start and marks the 4 TB drive as available but not rebuildable.
I was able to do this when I went from 1 TB to 2 TB drives.

The Ctrl-I BIOS says the 4 TB drives are only 1.6 TB where the 2 TB are stated as 1.8 TB.

On the forum a member says that an upgrade to BIOS has addressed this problem in the past.
How do I update the BIOS itself to I would think that the Intel RST V would have replaced the BIOS to a more recent version.

Great forum. Hope I am giving enough info to get some assistance.

@MN_Bubba :
Welcome to Win-RAID Forum!

Only Intel RST RAID ROM BIOS modules from v10.5.x.xxxx up are able to detect and handle >2 TB sized HDDs. Unfortunately your currently used BIOS contains an Intel RST RAID ROM v9.5.0.1037.
So if you want to use >2 TB RAID volumes, you will have to flash a modified BIOS, which contains an updated Intel RAID ROM module (e.g. v11.2.0.1527 or v13.2.2.2224).

Please have a look into the related guides.

The installation of a driver, which is required for the Operating System), has no impact on the content of the mainboard BIOS.

Dieter (alias Fernando)

I also have an XPS 8100. I managed to get the 963D1P28.BIN (1024KB) bios file extracted from the S8100-A05.EXE file downloaded from Dell.

However, none of the tools recognize the .BIN (even when I rename them to .ROM). UBU gets me the closest by displaying “Unknow Versiom AMI Aptio” - obvious typo’s in the program itself.

The board is an Intel H57 Chipset with an Intel RST ICH8R RAID controller (also ver v9.5.0.1037 like the OP). I’m running RST on a Windows 10 Pro system.

So, none of the tools on this site let me mod the 963D1P28.BIN to update the related RAID BIOS.



@mhawryl :
Welcome at Win-RAID Forum!

For the detection of >2 TB sized Intel RAID Volumes an Intel RAID ROM v10.5.x.xxxx or higher is required.
It would be a good idea to attach the extracted BIOS file named 963D1P28.BIN as .ZIP or .RAR archive. Then we can try to do a deeper look into the mainboard BIOS.

Dieter (alias Fernando)

Danke, Fernando!

See attached.

963D1P28.rar (694 KB)

The attached BIOS file can easily been opened (and hopefully the desired Intel RAID ROM module updated) by using the AMI MMTool v3.26.
Pre-condition: You have to rename the BIOS file to “963D1P28.ROM”.
Since AMI doesn’t allow us to offer a download link to the AMI MMTool v3.26, you have to do a Google search for it.

Since there is not enough free space within the BIOS for an update of the 83KB sized Intel RAID ROM v9.5.0.1037 to the 119 KB sized TRIM in RAID0 modded Intel RST RAID ROM v11.2.0.1527, I recommend to do the following:
1. Rename the BIOS to “963D1P28.ROM”.
2. Remove the module named “OEM Logo”. Here is it:

BIOS 963D1P28.ROM opened with MMTool.png

3. Save the modded BIOS.
4. Replace the listed Intel RAID ROM module by the TRIM in RAID0 modded Intel RAID ROM v11.2.0.1527.
5. Save the modded BIOS.
6. Reconstruct the modded BIOS to the original manner and try to get it flashed into the BIOS chip of your system.

Found MMTool.

When I load the .ROM file, I get "Error Loading Firmware Image (800000001h)"

You obviously have used the AMI Aptio UEFI MMTool v4.50.
You have to take the non-UEFI MMTool v3.26!

Ok, I feel like I’m close.

I successfully removed the OEM Logo. Saved. Replaced the RAID ROM with the one you listed (from your other thread). Saved.

Then, because Dell packaged their BIOS’s into an .EXE, I was able to grab all of the files originally from the TEMP directory they were extracted to. I don’t think I can put them back into the .EXE so I used the utility within the updater "MEFlashTool."

It looked like it was going to work, but it errors out. It shows:

Current Version:
New Version: 933.57475.2823.35784

Says it’s updating, goes to 100% but then a pop-up says "Update ME failed! Error 8713: Firmware update not initiated due to an invalid FW image"

This happened with the BIOS after removing OEM and with the on that had the RAID ROM replaced.

I feel like there’s another setting or value in the BIN/ROM that needs to be edited so that the updater thinks it has a valid image.


I uploaded my new .BIN for you to look at, along with the utility and log files.

963D1P28-NEW.rar (677 KB)

The new .BIN file doesn’t contain the updated Intel RAID ROM module v11.2.0.1527. It is still the v9.5.0.1037 OROM.

I tried again, selecting ID 20, choosing the “Replace” tab, selecting the file “8086-2822_v11201527_mod-for-TRIM-in-RAID0.bin” and clicked "Replace"

The source size and size in ROM values changed, which led me to believe that the ROM updated successfully. But I get the same error.

Just in case I sent the wrong one to you, here’s the one I just changed.

Thank you so much for your time and patience.

963D1P28.rar (687 KB)

@mhawryl :
The last BIN file is ok. It contains the Intel RAID ROM v11.2.0.1527.

Good. But the result is the same.

Perhaps the MEFlashTool that I extracted from the Dell Package isn’t what I should be using.

Just in case you’re in the mood, I uploaded the S8100-A05.EXE contents in a RAR file so that you can see what I’m working with - including the updated .BIN.

Perhaps a different FlashTool (not from Dell) would work better?

A05.rar (1.87 MB)

@mhawryl :
I only can check the “pure” BIOS file and it seems to be ok.
The other part (to find the usable flashing package and the procedure for your Dell system) is yours.
I don’t have any own experience about how to flash a modded BIOS into the BIOS chip of a Dell system.


I took a break for a while from this effort but started looking into it again, as I was upgrading my drives with 3TB drives. I was on the original v9.5.0.1037 OROM and the drives showed up as ~700GB drives in the BIOS utility (Ctrl-I at bootup), but showed up in Windows 10 with their actual sizes. However the RAID 1 I setup in the BIOS wasn’t visible in the RST utility in Windows.

I found AFUWINx64.exe and was able to successfully flash the modded BIOS into the system.

Once I did that, the Ctrl-I functionality was gone at bootup and I was unable to create a RAID array. The Windows RST Utility identified everything that plugged in correctly.

I tried v10.5.1.1070 and v11.2.0.1527 but still no go.

Also, all the utilities that I’ve used to examine the hardware on my system show it having an ICH8 chipset (Intel ICH8/PCH - SATA RAID 0/1/5 Controller) - NOT an ICH8R, which is all I see listed in the main page of the ROM thread.


After modding the BIOS, in the AFUWIN64 (v4.48) utility, there is a checkbox for "Program All Blocks" that needs to be checked and it worked. By default, only "Main BIOS Image" is checked, which is what resulted in the loss of the "Ctrl-I" functionality and had Windows reporting a ROM version of for the RAID.

I can now see 3TB drives and create a RAID.

Thanks for all you do!

@mhawryl :

Congratulations for having solved your problem and thanks for your final report about how you did it!