[SOLVED] Flashing Asus Z9PE D8 WS for nvme Samsung 960 SSD: won't boot anymore

Hi Guys,

hopefully you can help me. I’m new to this forum and was just reading quite a lot of threads so far but now I’m stuck and need your help.
I was flashing my bios and i hope i didn’t crash my hole systeme now.
What I have done:

- I built a new PC with:
Asus Z9PE D8 WS as Mainboard (Rev. 1.04 / Biosversion 5802)
2x Intel E5 2670 CPUs
64 GB of Ram
PCIe Adapter Card for M.2
nvme Samsung 960 SSD

- I used Afudos to create a copy of my current bios (Version 5802) as a ROM version - so the last release
- I was editing the BIOS with UEFI Tool and just add the codeline “NvmExpressDxE_2” to it
- Saving the new ROM file
- Booting in Dos-Modus and Run Afudos “flashed_bios” /GAN

Everything was sucessfully flashed. So I was rebooting the PC and now I’m getting Error-Code number 06 on the mainboard which means “microcode reading” and he won’t move on anymore.
What can i do now?

Hopefully I have told you all the necessary information and someone is willing me to help - would be awesome

regards,
Ronny

EDIT by Fernando: Title customized to make clear, that the problem has been solved

One thing what I got in my mind was:

When I now open a downloaded version of the current Bios with UEFITool it shows me “AMI Aptio capsule” (CAP file)
When I was editing the original Bios from my motherboard with the UEFITool it has shown me just the “Intel Image” (ROM file)

So maybe I got rid of the AMI Stuff now and thats the reason why he doesn’t boot anymore nor shows me something on screen?

Is there anyway to rest the bios to an older version? The Motherbord hasn’t got a usb flsh back drive…

@3dsmaxer30 :
Hello Ronny,
welcome to the Win-RAID Forum!

How did you “edit the codeline”? Or do you mean, that you have inserted the related module named NvmExpressDxE2 underneath the last listed “DXE Driver”?

Maybe this was not a good idea with your specific Dual-CPU mainboard.

How did you name it?

If you can, I recommend to flash the latest original BIOS, which has been delivered by ASUS for your mainboard.

You can open and modify an AMI UEFI BIOS by using CodeRush’s UEFITool, but you cannot flash a BIOS with this tool. Maybe you have removed the capsule by using the UEFITool.

Regards
Dieter (alias Fernando)

Hi Fernado,
thanks a lot for your fast answere!

Sorry I just forgot to mention the guys where I got the tools from. I was using the UEFITool from CodeRush to place the “NvmExpressDxE_2” underneath the last listed "DXE Driver"
Actually I was following this tutorial: [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS (But as I gonna see now, in a wrong way)

Zitat von Fernando im Beitrag #3

Maybe this was not a good idea with your specific Dual-CPU mainboard.



When I tried to flash the bios in the normal way using the EZ untilities from asus he told me there is a security ploblem (protection) with the bios version. So I was looking for another method to get it done without security permission.
So I used Afudos in Dos-Version to flash it :frowning:
Zitat von Fernando im Beitrag #3

How did you name it?



I was naming it just flash.rom

Is there any chance to implement a new bios? Or is it the only way to buy a new chip for the board?

Oh Sorry, i just mean modifying instead of flashing.

EDIT by Fernando: The quoting codes have been corrected, unneeded blank lines and parts of the fully quoted text have been removed (to save space).

Ok, so I was able to boot my pc again by getting a new bios chip from ebay.
Now I will try to flash the system again in a different way…

Hi Guys,

finally I was able to flash my Bios with a modded version and now, the Asus Z9PED8 WS is working quite well with an NVMe Samsung 960 SSD as Bootdrive!
I used a ch341a Programmer Stick and the last Release (NvmExpressDxE_3) to get it work.

regards,

Ronny

@3dsmaxer30 :
Hello Ronny,
thanks for your final report.
It is fine, that you could successfully flash the NVMe modified BIOS and now are able to boot off the Samsung NVMe SSD as your system drive.
Since you have solved your problem, I have customized the title.
Enjoy the performance of your NVMe SSD!
Dieter (alias Fernando)

Hi 3dsmaxer30,

I am so great that you have successful boot system from Samsung 960 SSD. Respect :slight_smile:

I have a question, how you used a ch341a Programmer Stick and the last Release (NvmExpressDxE_3) to get it work?

Currently I’m using Intel 750 series for win 10 system. I had try to boot from Samsung 960 pro but it’s fail because the bios didn’t show up Samsung 960 pro.

My computer spec:
motherboard: asus Z9PE-D8 ws
Processor: Intel Xeon E5-2650 v2
Display card: Nvidia Quadro K4000

@kenoric :
Welcome to the Win-RAID Forum!

If you want, that 3dsmaxer30 gets a notification about your request, you should better use the @username option.

The UEFI BIOS of older mainboards never shows the name/model of a connected NVMe SSD (what you may see instead is a device named “PATA”). Nevertheless the related SSD may be bootable. It will be listed as “Windows Boot Manager”.

Regards
Dieter (alias Fernando)

@3dsmaxer30 can you kindly help share the working modded bios with NvmExpressDxE_3?

Many Thanks

@keba
Hi mate,
I can send you the modded BIOS today evening. Just write me an pm with your email-adress.

So far it works for me quite well, but be carefull with it, you can destroy your BIOS or even your motherboard. Its on your own risk.

I wasn’t able to install the modded BIOS due some security from asus in a normal way. So i ordered an USB flasher for 10€ on eBay (you could even get it for 2-3 €, but from China, so the shipment takes quite long…

regards,

Ronny

@3dsmaxer30
Dear Ronny,
Thanks so much for your prompt reply!
My email is under your inbox, already :))) Can’t wait for testing your modded BIOS!!!
I will order an USB flasher ch341a and some backup Winbond 25Q64BVAIG.
And last but not least, can you kindly help show which is the correct way (pin up or pin down) for insert the 25Q64BVAIG inside USB flasher? Attached photos pin up and down from youtube for more detail.

1. Pin_UP

pin_up.jpg



2. Pin_DOWN

pin_down.jpg



Thanks again!

@3dsmaxer30
Hope that you might have more spare time during weekend!

Many Thanks.

Dear all,

I would like to confirm Z9PED8WS is OK for NVME.

All stuffs can be find here: using CH341A USB flasher for backup origin BIOS (save as .bin file), then using CodeRush’s UEFITool v0.21.5 for insert the
uncompressed NvmExpressDxE_3 module. Verify then flash to the Winbon W25Q64BVAIG.

https://www.fshare.vn/folder/4R8IK4K7Y37G

Thanks guys for sharing all needed information.

HI,
Does the bios file you upload have the changes already added? If so, is this bios v5802 with the changes?
Do you have to use the usb flasher to update the bios on the chip or can we asus bios update to install the updated bios?
Thanks

@3dsmaxer30 any chance you can share your bios file one more time? I have a 970 and same mobo.

Here you go (original file) :

https://www.mediafire.com/file/qlsqr7a98…_nvme3.rar/file

Regards

Hi Bro.

Im kind of lost deseperated trying to do extactly the same thing you did.

I have a Z9PE D8 WS with a couple of Xeons. And i would like to make work my new NVME as Windows drive.

Could you please help me and refresh me about the steps to follow. What i have to do once i have your …nvme3.rar file

Thanks a lot!

For address to a specif “BRO” must use @username in order to get him notified.
Reading from the start of the thread, seems that besides the use of a CH341A SPI programmer no one has succed in other way.
So buy one as the SPI on the motherboard is a socked SOIC8, so its easy to flash it or u can read more here on other methods:
[Guide] How to flash a modded AMI UEFI BIOS