[Solved] No NVMe Booting with Dell PowerEdge R730

Although I am rather unsure whether it will solve your NVMe boot problem, I recommend to try it.

success!!! replaced the nvme dxe inside bios with the one on your guide and i was able to boot from pcie ssd :slight_smile:
but now i keep getting whea uncorrectable error when tring to install driver, but i think the problem is releated to intel arc gpu giving that bsod, or at least now its the combination ov nvme+intel that give that, because looks like with 2,5inch ssd all is or with older drivers.
to confirm 100% problem is only with nvme+intel, or intel i sould reformat the pc and try reinstall chipset driver and see if i get bsod .

1 Like

Thanks for your feedback! It is fine, that you finally were able to boot off the NVMe SSD.

Which driver for which device do you mean?
Forget the Intel chipset “drivers” - that are no real drivers and a change will not solve the interference problem between the Intel Graphics Adapter and the NVMe Controller.
My advice: If possible, change the slot/port of one of them.

Due to the fact, that the problem has been solved, I have customized the thread title.
This way other affected users may better find the solution.

any driver… chipset, intel vga… if i try install them i got whea bsod. if i remove intel vga i can install any driver just fine. if i put intel vga back and try install vga driver i got bsod, but if i install them from device manager manually they install ok , and after they got installed i can run the driver exe install and installation go just fine.
it’s sokmething related to memory or irq allocation that cause bsod. most specially with pcie bus , memory or irq.

is it possible to unlock bios , so i can flash bios with ftp ? till now when u told me to try flash original bios back, i tried replace hdr with my modified bio. flash went ok, but my modded bios wasnt flashed properly, as if i dump bios i got like it was original from dell exe install bios file.
ps: fpt from shell give enexpected error, while on windows im able to read it with -bios option, but cant flash anything back. fptw -f -bios biosname.bin give me error 280 or similar.
would be cool to unlock bios from writing permission to allow me flash it the easiest way without the need to desolder bios chip each time.
also intel vga is unrecognized in bios. it give unknown specification and so on, so maybe pcie code are not implemented correctly in the bios. maybe some dxe for pcie list or supported card is not like the one on other mainboard that allow people to install any pcie.
to prove that look at the nvme dxe. after replacing the dell one with the generic i was able to boot from nvme.

Since I am not an expert regarding this kind of BIOS modding, I cannot answer your question.

You’re using a modern desktop GPU card/architecture… and on a server class system board, with several years apart, but mainly this is a server efi bios with Dell code handling a modern UEFI GOP gpu card… the issues you have maybe expected due to this class.

Several system boards have a so called “Service” jumper or “ME disable” jumper, it differs across brands, try to search info for it, regarding your system board.

[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

A note: About the EXE’s… the system board hw has, as we know has its on PnP/Bios configuration, some have/had (Manual/AUTO) and all the devices attached matters…but when the OS is loaded, its him that will, on top of it, manages the resources allocation and MS PnP… now is that Intel EXE expecting some specific resources to be available on the system… and they’re not available anymore/used.

tnx for reply. on mainboard there is just one spot called “me FW” but it’s not populated. it’s missing 2 pins and a resistor and one track is going under pcie slot so dont think it’s for flashing.
inspecting the board there is no service mode in it.
interesting ur talk about uefi gop. is there a way to analyze them in the dell bios and maybe update them ?

UBU/UEFI tool will inform you of GOPs on the bios, if theres any on it, its not always there.
That ME FW is indeed the SPI Flash Override for protected range.
Further advance on this and tryouts requires safety measures for recovering the SPI.
Dont remember well, but i think there is a user experience with this unpopulated jumper PINs with success, earlier this year or last ending year, i think also was a Dell server motherboard class.

update: out of curiosity i got an rtx 3080 to try in the server. score passed from 8k-10k with intel arc to 11k with rtx 3080. then i edit fan profile and lowered them from 80% (around 14k rpm) to 15% (around 4900 rpm).
after that score on superposition passed from 11k to 12.5k .
on 4k optimized i got 11k too…
i lowered again fan to 10% and got a score of 13k loool

strange is that i have 2x750 watt in non redundancy, so i sould be able to get almost 1kw of power from both, but looks like it’s not.
while scoring with intel arc im able to get gpu utilization to 99% and a 190watt power draw.
with the rtx 3080, i got average gpu usage of 50% and some spike to 70% with a gpu power drain of 310 watt.
now there can be just 2 possible problem cause.
im sure intel arc has some problem since it score different every run i do.
nvidia score always almost the same score, but or cpu has too low frequency, or psu arent able to make server push more power.
for psu i dont get any warning from server lcd for too much power consumption…

so in the end i dunno if cpus are too slow or psu is too poor in wattage.

hi i bring up this thread, because new bios version come out, and without unprotect the old bios im not able to flash the new one without losing the modification i made for nvme and resizable bar.

anyone in here is able to remove flash firmware protection and maybe give me an hint on what fpt file i need to use ?

hi, I want to know where the R730 bios chip is, I can’t find it on the motherboard. I want to backup and mod it. Hope you can give me a picture of it location, thank you.

hi before backup bios update to latest version 2.17.0.

after that u need to remove completely the mainboard as the bios is in the back of it.
there is an hole, but it has plastic cover around it (not visible) that will melt when heating up the 16 pin bios chip.

1 Like

Hello! Could you share the new bios 2.17.0 which support nvme?I cannot find.

You can publish the bios file to GitHub,I think so many people need it. Thanks!

Usually, users won’t share bios files, from a dump origin, containing their own, specific system info, sn, mac etc… perfectly understandably…
Unless they they have the trouble of wiping it out.

Do your own dump and mod it according the guide, present in the forum.

hi im still with 2.16.0. in a while ill update to 2.17.0 and ill post bios here

1 Like

thanks!please@me when you post :blush:

The Dell BIOS 2.17.0 can be found >here<.

not the official bios…i need the up’s moded bios that support different nvme… the offical one just support a little

keep in mind that for flashing modded bios, u need external programmer as bios flashing is locked.

if u have external programmer, u can flash bios 2.17, then save dump with programmer and i can edit it for u.
after that u flash it back.