Surface Pro 5 UEFI repair

Hello everybody =)

The UEFI ofe the Surface Pro 5 broke due to an automatic firmware update. Thank you MS!
So I did some research and tried everything. In the meantime I desoldered the winbond 25Q128JVPQ UEFI chip and since I don’t have an CH341A adapter I read out the chip with the raspberry pi and flashrom.

I also downloaded the latest UEFI file from microsoft and now i have concerns because of the huge difference in the file size.

Here is the UEFI file from the chip - 16.384KB

Here is the latest UEFI file from microsoft - 4.355KB

Can anybody help me further?

What makes you think that’s a firmware problem?

You’re on firmware 237.3982.768

Bios has a high level of redundancy, everything stativ there you’ll find twice, in your dump all redundant parts identical (which makes an update failure already very unlikely) and in addition all these volumes are identical to the stock volumes you find in the corresponding stock update file.
Identical volumes/ paddings marked in same colour (both arrows for the paddings were supposed to be purple)

There is no bios update failure!

In addition ME unpacks fine in MEA, version correspond to bios update (Feb 28)

In NVRam one finds som records that could indicate other reasons for failure (hardware):

1 Like

Thank you for your work!

The only thing that happens with the surface is that you see the Windows logo every few seconds and it keeps “restarting”. Looks like it is in a boot loop. And that happend right after the firmware update.

I’ve tried an soft reset, hard reset, USB recovery, I can’t enter the BIOS. When it was opend i disconnectet the battery and tried everything again.

So my last thought was that something went wrong with the update.

Never thought about it being a hardware failure. :astonished:

What does Windows logo mean? Is this really Windows starting? This would be OS start after finished bios / firmware routines?

Can you access bios settings?

There are two things one could do with this firmware image:

Empty NVRam will make probably make you loose machine specific data, at least a Windows key is stored there.

Clean ME region won’t hurt, but it’s very unlikely that this is the reason.

Only the blue Windows logo without the loading cirle.

No i can’t access the bios.

Try this one then and report back: (6.4 MB)