T460 Bios flash


I am a newbie when it comes to flashing. I am using TI866 plus and a test clip to connect to the chip MX25L12873F.
I am able to do the following.
Read the chip. Save the bios backup file.
Then open a “t460.bin” file which i downloaded from the internet, did an erasure, then program.
However after that, I could not turn on the laptop.

After which, I tried to open the bios backup file, erase then program.
However, I could still not turn on the laptop.

I tried to do the comparison between “the read bios chip” and the “backup bios file” and found out there are many differences.
Is this because I am using the test clip which is not good?

above is my “t460.bin” file

above is my bios backup file

The file “t460.BIN” has both BIOS & CSME corruption so if you flashed that, then that’s why it doesn’t boot.



You must not take dumps from the internet and flash them directly on your SPI chip because:

a) You lose model specific info (serial numbers etc), part of the BIOS region
b) The CSME firmware is Initialized and needs to be cleaned first via [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization
c) It could have a BIOS which is corrupted, modified in a bad or unwanted way, infected or similar

You have not mentioned why you’re doing all this. What was the original problem?


I have a bios lock on my laptop. I want to unlock it.

So what I will need to do is to first clean the CSME firmware.
After which, get a T460.bin file without any bios or CSME corruption right?

Or is it possible for me to buy a patched file online, and just program it to the eeprom?

Any solution?