[TOOL] Lenovo (H20) Bios Unlocker and Locker

sorry for the very late reply man this legion 5 laptop is a very resilient server it just stays warm and never overheats despite the continuous CPU/GPU loads across two VMs
but one day windows shit itself so i decided to run some diagnostic related commands on livecd just to check the CPU info and specs ill attach the logs here so far no errors found
its a shame generic 3050/3060/3070/ does not work with vgpu_unlock (however 3080/3090 desktop is partially supported not sure about mobile)
kinda wish i got the 1660 or better yet the 2060 variant instead other than that GPU-P does work very smoothly on my underpowered 1650ti but i had to sacrifice the powerful radeon due to a bug on windows ill try the nvidia trial license on spare ssd before wiping windows

did you modify the boot parameters or the bios settings after firmware update

nope the script just still hangs and i dont see any error logs in the mobilepassthrough folder whatsoever
dunno if the some of the values touched by the unlocker got stuck since i left the bios unlocked before reverting to EUCN31WW however i did reset it first but oh well everything still looks the same no bios issues so far though there is that one time one time the screen just froze and went off black and suddenly rebooted without bsod while using vm with igpu disabled though i dont think its related there since i reset it

i looked around that other day and it seems that most of the MUXed laptops in the store uses generic 3050 with dgpu on 0 and igpu 1 ram is 512 mb vram but the other 4600h ideapad gaming had 2gb igpu from the store havent looked at the bios yet but the other iris XE intel laptops have the igpu and dgpu in proper order on task manager weird but i dont think it really matters in the long run
after looking on a different store i noticed that the 4000 series cpus have gimped igpu and the good stuff disabled but on the 5000 series (released on the same year) seems to have enabled everything including pcr7 binding by default not sure about the top of the line 6000 series though since ddr5 is too expensive in my country and they haven’t shipped yet so i cant check

what does PCR7 binding have to do with this

on my other intel ideapad both kernel DMA and pcr7 is enabled by default on linux livecd vmware shows the virtualize iommu option tired the same on my legion but it does not show up indicating that something is disabled or unsupported in the bios (or maybe its intel only)
i dont wanna repeat the same mistake when buying my legion even though it gets the job done ideapad gaming fits my criteria but the cooling is not that good and the best legion with the similar specs has kernel DMA disabled though other than that a bios mod should work but i dont want to risk it this time
TL;DR its definitely possible to make a custom firmware that lets me have the best of both worlds but first we may need to look at the ideapad AMD model BIOSes im pretty sure the code is very similar there

slightly off topic questions but is self healing enabled mode enabled by default? can it be turned off in the bios? do i need to remove the SSD before bios flash
does lenovo legion have firmware verification? i heard that some laptops refuse to boot if the bios image is not signed or tampered
any AMD users have problems with the radeon iGPU bios settings? i could not get the vram to 2gb no matter the settings
is it ok if i make a bios request here if not where should i do it? should i bump the old legion 5 topic or should i stay in this thread?
is there some kind of instruction manual/documentation for the AMD insyde bios? i dunno what the other functions do hopefully i don’t accidentally fry something by flipping the wrong settings
Edit oops messed the text formatting sorry for the long post

igpu is stuck to 1gb

hold on i think figured out the cause but i still coudn’t get it to 2gb it turns out that setting the UMA actually triggers a bug which makes it revert to default settings which is in case 1gb which is why no matter which one i select its still does not work properly this also explains why i get this 77hz monitor bug on linux and the ubuntu display settings keep popping up whenever i press FN brightness keys but works normally with the default bios settings oddly when i plug hdmi dongle the monitor disappears for a slight second and the 1650 is now at GPU 2 task manager (not sure if this is a bug)

legion also the mobilepassthough script no longer works after i unlocked my bios

hold on a second after testing it on my other laptops without modifications it still does not work its not me turns out they updated something on the github that broke it unfortunately i forgot to save the earlier revisions of the script (the git releases empty and i just left it on the liveCD ramdisk)

does anyone gets this error when booting ubuntu livecd before using the unlocker it seems lenovo specific [integrity problem loading x.509 certificate (-65)] after that the xfce desktop loads just fine but after i used setup_vars_cv ubuntu no longer boots
after poking a bit the iommu device shows on lspci indicating that it works but the BIOS is not perfect the manjaro livecd also never starts at all on my system even if the bios is in the default settings idk why
for those who already have linux installed try this GitHub - antony-jr/lenovo-legion5-15arh05-scripts: Simple scripts and guides to work around with issues on running linux in Lenovo Legion 5 15ARH05 version. it might come handy later on (not sure if the newer amd 5000 variant uses the same mechanism)
also after booting ubuntu on ideapad without touching anything in the bios fnlock became stuck ON and the webcam no longer works with usb descriptor failed resetting bios did not help im screwed how do i fix this (i heard on some secure surface laptop models the webcam is shut off when tampered with)

@withinboredom
for me i would rather use an external usb ssd for temporary dual booting the second drive will be used for storing large VM related data since im not ready to wipe windows yet

@Coconut_Cube @Call-Me-Conference77

how do i get the older bios version

hold on i think i figured something out lenovo laptops BIOS Update for Windows 10 (64-bit) - Legion 5-15ARH05 - Lenovo Support PH
here is the official download page for my legion BIOS and the file link itself https://download.lenovo.com/consumer/mobiles/eucn37ww.txt
now replace eucnXXww (28 is oldest in this particular model) with the version you are looking for and then add .exe for the installer file itself or .txt for the readME im sure there is something similar for your model

Edit: added the files not sure if these would be relevant turns out left the logs on cloud storage when i first used it (on the zipped txt files i had to type the commands manually)
82B5 without integrated gpu.zip (53.4 KB)
EUCN33WW before biosiommu patch.zip (52.6 KB)
manual logs for winraid.zip (75.5 KB)

You need this one:

https://download.lenovo.com/consumer/mobiles/h1cn44ww.exe

Honestly forgot to check back here until now, but it worked. Thank you!

hi, tell me, is it safe after all these manipulations to update bios, which is not supported by an unlocker(54ww)? will all the settings fly off. or will the system start at no all?

Has anyone tested the Lenovo Legion Y540-15IRH with product number 81SX012TUS and BIOS version BHCN45WW?

If not, can someone point me to the appropriate instructions for executing the appropriate “!cE search via UEFITool (I assume 0.28 is good)?

I’m sure I can muddle through this, but I’d like to go into it with some more experienced input in this area.

Guy if you want a method for the 2022 model, or the newest locker Bios, head over to my GH:
https://github.com/SmokelessCPUv2/SmokelessRuntimeEFIPatcher#lenovo-bios-unlock

2 Likes

can someone test if this exploit still works hope its not patched yet [Guide] Unlock Insyde H2O BIOS with Checksum Control - #21 by B83C i want to flash a custom BIOS entirely without the checksum verification taking this laptop apart might void my warranty
also where is the appropriate subforum for BIOS modding requests? im asking for a small favor here
ill be getting an extra 32gb teamgroup stick to fully utilize my cpu soon

Hey guys, do you know in what tab I can find options like Gear Down Mode,Down Mode and Bank Group Swap? I unlocked bios on legion 5 2021 bios version gkcn49ww and I cant find these options anywhere

Amd cbs-umc common options-dram memory pamming-bank group swap alt mode
Amd cbs-umc common options-dram controller configuration-gear down mo disabled
Amd cbs-umc common options-dram controller configuration-dram power option-power down enabled disabled

1 Like

Forgive me if it’s already been posted, the post has grown rather long, has anyone figured out how to change ram settings in the AMD version 2021 legions? I have upgraded the ram in my 5800h/3070 legion 5 17. The results aren’t all that impressive and I know others have unlocked a lot of potential with custom ram timings, but I’m not especially sure where to start in this advanced bios. All the guides I’ve found have been for intel versions.

cannot change timings in bios (5800h) only RAM SPD Rewrite

Hello! I can’t find CPU voltage control or anything like that. The fact is that I want to undervolt the CPU and video card. By the way, maybe someone knows how to limit the GPU, because in Msi Afterburner all settings are locked, and I don’t know how to unlock them. My laptop: Lenovo ideapad gaming 3 15arh05 with r7 4800h

Hello
I stupidly change my ram speed higher than normal and my laptop won’t boot no matter what. The things that I tried: (all with and without ssd)
1-Removed battery and cmos battery for 15 minutes.
2-Testing with 3 different rams.
3-i made a fat32 flash drive with bios file as it was said it winraid, put flash drive in and pressed fn+r then connected power cable and booted it up but it wont beep and just keeps restarting after a minute or two.

Tried this with different names, flash, port, with battery and no battery.
My bios is h1cn and its intel legion 5 11800h

Can anyone help me please?

I tried everything but it doesn’t work for me. I’m on a Lenovo Legion Tower.

Pls unlock bios for lenovo ideapad gaming 3 15ach6 82k2 . i have the oldest bios files of this model till the latest one and all are official ones :persevere: