uefi menu for intel rapid storage not visible in gigabyte aptio 4 bios

hi, first time poster here. i’ve made a few successful bios mods using UBU, me_cleaner.py, etc., and recently was able to get the nvme module inserted to boot natively from that.

however, i’m now trying to get intel rapid storage working for my old sata ssd drives without csm mode enabled, and i can’t seem to access any of the menus in the uefi interface.

i’m using a gigabyte g1.sniper m3 z77 based motherboard with an i7-3770k cpu. i’ve got pure uefi boot going since i flashed my nvidia 650 ti card with a new uefi-compatible vbios provided by the vendor, evga. uefi booting to linux/grub natively on my samsung 960 evo 1tb is working fine since i added the nvme module yesterday, as described here on these forums.

anyhow, afaik the vendor provided bios doesn’t have support for uefi configuration of intel rst in the menus. it does have the legacy option rom, but of course that doesn’t work with csm disabled.

using UBU, i updated to the newest recommended roms for the 7-series chipsets, v13.1.0.2126, but am not able to see any new menu options. scrolling all the way to the right, as described by someone here for asus bios, just brings you back in a circle. i looked very carefully in all of the menus/submenus as well and didn’t see anything. i’ve also played with the settings a bit, too (going from win8 to other os, toggling uefi option rom and uefi storage rom, etc.).

i did a bit of searching through the forums and couldn’t find anyone that was using uefi rst on the 7-series gigabyte motherboards. is this possible? thanks!

please see attached bios. it is the “stock” gigabyte F10f bios (latest from their website) modded with UBU v1.69.5 / RST 13.1.0.2126 and me_cleaner.py (latest as of today).

thanks!

g1sniperm3_10f.rom.zip (2.69 MB)

@tofurky :
Welcome to the Win-RAID Forum!

Thanks for the attached BIOS. After having opened it I found the Intel EFI RAID module named “RaidDriver” v13.1.0.2126. Since the UBU tool doesn’t insert any previously not present BIOS module, but just updates already existing ones, I suspected, that there was already an Intel EFI RAID module within the stock BIOS. So I downloaded the original BIOS named SNIPERM3.10f from the Gigabyte Support pages, did a look into it and found it: It was the “SataDriver” v11.6.0.1702.

Since even the stock BIOS definitively contains an Intel RAID EFI module, you should be able to get access to the BIOS in-box “Intel(R) Rapid Storage Technology” utility. It is sometimes not easy to see this BIOS option. I personally had to power off completely the computer for ca. 1 minute and then to restart it and to enter the BIOS again. Another option may be to clear CMOS.
Questions:
1. Why do you want to run your SATA SSD in “RAID” mode? Do you want to create a RAID array?
2. Are you sure, that the RAID mode of the Intel SATA Controller is enabled within the BIOS?

Regards
Dieter (alias Fernando)

thanks! i appreciate you taking the time to look at the bios i posted and find the original one at gigabyte’s website.

about SataDriver, yes that’s correct, sorry i didn’t mention it. i saw this last night when i was comparing the original with SataDriver and the modded with RaidDriver. i thought the difference in names might affect it but the uuid’s are the same…

per your suggestions, i did just try a couple more things such as flashing the stock “F10f” bios and resetting to optimized defaults (which it does anyways when you flash from within bios, i think). i didn’t try the clear cmos jumper yet though. i did try leaving my pc with psu switched off for several minutes yesterday, though, per the recommendation i saw you make in another post here.

what i noticed is that there is still no intel rst submenu even in the stock bios with csm disabled. the ‘ctrl-I’ legacy mode of course works when csm is enabled. i tried hitting all the function keys to see if it was hidden (F1-F12) but it didn’t come up.

i did see one thing peculiar: if i enabled raid mode, but disabled all storage op roms (both uefi and legacy), the individual drives would show up on the page that listed the ata ports (e.g. samsung 840 …, lite-on dvd etc.). however, if i enabled the uefi storage option rom, no drives would be listed on the ata ports page. just empty ports. so it would appear setting sata to RAID + enabling uefi storage rom is doing at least something, even if it’s not what i want it to do :slight_smile:

i was thinking about maybe setting up the raid array in csm mode, then switching to uefi-only and see if windows 10 installer can see the array. not ideal, but it could work.

also to answer your questions:

1.) since i got my new 960 evo i am using for linux, i wanted to put windows 10 on a 128GB or so raid0 striped across my 2x 840 evo 250gb
2.) yes i am sure, see above where i described how raid + uefi storage option rom makes all the ata ports empty

i attached some screenshots of the bios menus in stock F10f (after changing to RAID and rebooting).

bios_ss.zip (2.4 MB)

@tofurky :
Thanks for your reply and the screenshots of your BIOS options.
Unfortunately I have no idea, where users of a Gigabyte Z77 mainboard can find the “Intel(R) Rapid Storage Technology” EFI RAID Utility.
Maybe a Gigabyte mainboard user with an Intel RAID array can give us a hint.

@Fernando :
ok, let’s see if another gigabyte z77 user can give us a hint, that’d be great. just now i opened a support ticket with gigabyte, i’m hoping they might have an unreleased bios or similar that fixes the issue. i’ll try to update this thread if/when i hear back.

edit: i forgot to mention i dug through the stock bios with AMIBCP 4 looking for any signs of the functionality. i did see the relevant strings/menu items, but i think those only apply to the stock aptio user interface. gigabyte has their own “3d” skin ontop of the normal aptio setup utility so there’s no telling how to make those options appear…

after at first having them tell me i needed to remove my video card etc. and that i hadn’t properly disabled csm, i sent them another link Intel EFI “RaidDriver” and “GopDriver” BIOS Modules and i guess that motivated them to forward the inquiry to their bios specialists.

anyhow, here is the (unfortunate) response i received from gigabyte support:

perhaps someone else can offer a workaround, i’m subscribed to the thread if so.

@tofurky :
Thanks for having posted the reply you got from the Gigabyte Support.
It is hard to believe, that a mainboards manufacturer like Gigabyte
a) has delivered for one of their Z77 Chipset mainboards a BIOS, which doesn’t contain a working EFI module for the on-board Intel RAID Controller and
b) is not willing to correct this mistake.
AFAIK only the Company Gigabyte will be able to solve your problem.