Unlocking everything in Asus H81M-D v1 3602 bios

Hello!

As stated here in my comment ( [Request] Old Microcode for All Core Max Turbo Speed on Haswell (3) ) I’m trying to enable TSX, disable ME, unlock BCLK overlocking, force all cores turbo and unlock hidden features/locked settings.

I’ve read a similar thread here in this very subforum, Lost_N_BIOS helping people. I’m wondering how could I do it?



* I used me_cleaner to edit 3602 bios and disable ME bit and flashed that modded bin bios via /GAN comment (as far as I remember)
* My ME version is 9.1
* I don’t have an SPI Flasher (though I have Team Xecuterr’s JR Programmer for Xbox 360 RGH flashing, don’t know if it could be repurposed)
* I used 32bit exe (not x64 even though I’m on W10 64bit) of my corresponding ME system tools’ (9.1) Flashing folder and dumped the biosreg.bin file as per Lost_N_BIOS’ instructions, here’s the MediaFire link for it: mediafire.com/file/u29sqp895lupnzx/biosreg.bin/file
* When trying to write it back, the error I get is as follows:



* I read his thread about fixing this write protection error but I can already flash bin bioses via AFU’s /GAN command, is it still necessary?
* Now the important part of unlocking the BIOS and BCLK overclocking, in one other thread he posted some instructions as well as HEX address to modify for an ASUS board, but I don’t think all the ASUS boards are the same, so here I’m linking official BIOS for him to look into: https://www.asus.com/us/Motherboards/H81MD/HelpDesk_BIOS/
*I’m also waiting for an answer on the all core turbo sync/TSX in the microcode thread so I can finally get into editing the BIOS.

Thanks to anyone involved.

I dislike AFU, especially if you have to use GAN (Since it’s not made for this BIOS series at all, but MUCH older BIOS, and causes future flashing issues sometimes with other tools, and sometimes it does not flash everything it should)
But, it’s up to you. AFU can be used to flash in unlock BIOS menu usually, and microcode via /B /GAN

Error 280 can be gone around too, if you want to try FPT method of flashing instead, see this guide - [GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash
Alt boot to grub when no boot to EFI on exit page - [Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN (2)

Yes, any hex edit would be specific to that exact BIOS/situation.

See PM, research and then add the rest of the info required that I mentioned in PM.
For the BIOS menu unlock, please zip for me one image of all main pages of your BIOS. Main, Advanced, Boot, Exit etc, just one image so I can see what menus you have visible, if more images are needed later I’ll ask for them

To fix the ME FW - If you have DIP8 socket with the programmer you mentioned, then yes, it may be possible to use on this BIOS, if it has your chip ID in it’s software or if you can find other software that people have found that works with it.
Otherwise you need $2.50 CH341A + $1 U Type Flat IC Extractor to pull the chip safely.

EDIT: LEt’s forget about BCLK and ME for now.
----
Thanks for getting back.

HEre’s a video from ASUS H81M-K, I checked and my D version has the same menus

https://www.youtube.com/watch?v=66Sq6dHm7f0

----

IF things hit the fan I will order the CH341A + SOIC8 test clip w/ cable (I don’t know if my bios chip is soldered or not, if it’s not I think I can use tweezers to pull it out, rather than paying for a U type extractor).



If I need ME for BCLK, I’ll enable it with me_cleaner. I didn’t delete it, I just disabled the bit. Shouldn’t I be able to go back without any hassle? Just running the bios through me_cleaner to enable it back and flash it back. Or, if the BIOS you’d build for me has it enabled? Do I need the flash programmer or FD things etc you mentioned? If yes, I can do without ME/BCLK TBH.


EDIT: I’M leaving this for posterity and information. I don’t need BCLK anymore, people are saying it creates system instability on Haswell.





As for what I need, Currently unlocking any possible hidden options and injecting microcode v7 so I can get all core turbo. And I’m planning the /GAN command as it works, however, if it causes problems I’ll try your GRUB commands method.

Thank you

I need images, so I can keep in folder with BIOS and look at as needed, you can probably F12 screenshot to USB

U Type extractor is $1, and I highly suggest you get one. I know how to get BIOS chip out carefully, and it’s still super risky and often does not go so good.
BIOS Legs are VERY fragile, and it’s super tight right up until it’s almost out, then legs bend to crap and BIOS shots off in funky direction as you curse and wonder how that happened since you were so careful
It can be done though yes, if you are very careful, but I still suggest you order a chip extractor now, it’s only a dollar and then by the time you remember you ordered it or by the time you need it then it will be delivered.
I describe how to do it here, notice my warning at each link
RE:Asrock Extreme9 X79 NVME ME uCode Mod Request (3)
[Help] Bios for z97 extreme6 can run QDE4 es cpu
Adding options in AMI Non-uefi BIOS

You can’t enable ME with ME Cleaner now, you flashed in disabled ME thus you cannot use ME FW update tool to flash in unlocked ME FW, and your FD is locked by default, so your only option to enable ME again is pinmod to unlock FD or via programmer.
ME Cleaner only edits ME FW settings in a file, not in the actual BIOS/ME FW. The flashing in is the hard part now, since you disabled ME FW

If your board has USB Flashback that flashes ME FW each time too, then yes, it may be easy that way, but other than that see above (pain/hassle)

Yes, I can unlock menus for you, and put in microcode you want. Please tell me your CPU or CPUID, so I can find this v7 microcode (doesn’t sound like actual microcode version, but maybe it is)

/GAN method is up to you. You may not even be able to FPT flash now due to you already used /GAN and a AFU meant for BIOS over a decade old and 2-3 BIOS series older than current.
Sometimes, even after disabling the locks you get another error due to use of AFU (with or without GAN), error 204. So AFU may be your only option anyway. This can be used to flash in the menu changes and the microcodes too.

* Edit - found you mentioned your CPU in another thread (i5-4460), this is 306C3 CPUID, so you need v6 microcode as mentioned in this thread (Mainly putting this here for my reference later when I do your edit)
[Request] Old Microcode for All Core Max Turbo Speed on Haswell (2)

I’ve seen a video on all core turbo, and the user used the code v7, video stated that it’s the last code that supported it. I’d very much would like to go with v7 over v6, as it’s one week more recent.

Here are the images attached.

Thank you for your time. It’s very very much appreciated.

191121142225.jpg

191121142241.jpg

191121142306.jpg

191121142315.jpg

191121142323.jpg

191121142329.jpg

191121142337.jpg

191121142354.jpg

What that V7 video used with your same CPUID?? If yes, I see you are correct in older UBU >>
6 Version 6 Date 16-01-2013
7 Version 7 Date 21-01-2013 - Last for non-K overclocking

Please put the images in a zio, thanks

And you are welcome, I enjoy helping

Alright, here’s the zip file.

h81m-d 3602 bios pictures.zip (714 KB)

@tayyar - Thanks, Please wait, I need to ask other user something about his BIOS mod to confirm what actually changed or not in the BIOS he’s already confirmed working.

@raimond - Following the steps you mentioned, with the BIOS you mentioned, in the following thread (post 29) I do not get only 1 x 306C3 left in BIOS. - [Request] Old Microcode for All Core Max Turbo Speed on Haswell (2)
The only reason I used UBU and followed your steps was to see what happens to the anomalous 306C3 microcode in this BIOS that is outside the microcode module itself x2 (306C3 Version 12).
I wanted to see if this was left in place, or removed by UBU edit, and I used your example steps and exact same UBU version, and do not see the outcome you mentioned (only single 306C3 left in BIOS).
The anomalous 306C3 v12 is left in place, and so that leaves one we choose (used v7 in my edit) x2 + rev 12 x2 as well. I can do all this manually, but since you’ve modified with UBU, tested BIOS and confirmed mod outcome already, I need to see what’s going on in the BIOS you are actually using.
Please attach for me the BIOS you are using, I want to check to see what is in there before I make mod for tayyar. And also, please run HWINFO64, and show me an image of the little CPU-z like window, so I can see what microcode is actually in use in your system now.

Would this be helpful to you?

It’s your own post :slight_smile:

RE:CPU Microcode BIOS modding questions/problems (13)

Thanks, but no, that is unrelated to the mod you want (I think). I am asking him those questions because he’s using your exact BIOS and wanting the exact same CPU/Microcode mod for same specific reason, so I want to see what worked for him, how his actual BIOS looks etc.
I can remove or add any I want, or leave others in place as mentioned in the thread you linked, but I want to know what was done in his instance that way I don’t have to make you 4-5 BIOS to try and then end up only the last one working for you
That would be a lot of necessary testing on your end if I sent you a bunch of BIOS, if we can get him to send me what we know works as example.

I assume the anomalous v12 microcode (x2) that I mentioned is still in his BIOS, since UBU didn’t remove it following the exact steps he mentioned, so I wanted to also see what is loaded in real time (HWINFO question), so we will know.

* Edit - Seems similar/nearly same, and we decided to leave in place there, but his inquiry was unrelated to what you want to do, so hopefully we can get BIOS from raimond, then I can inspect and do mod similar manually, since he showed it’s working in the other thread.

@Lost_N_BIOS Unfortunately I was not able to unlock the bios nor was I able to unlock BCLK on my H81M-D, but I was able to make all cores run in max turbo by injecting the older microcode using UBU tool.

Below is a link for CPU-Z validation (ran it with a stock intel cooler, no paste thus the high temp of my E3-1246 v3)
https://valid.x86.fr/m0vi2j

Thanks.

Could you please share your bios?

@Lost_N_BIOS I don’t think we will get a reply back from @raimond

You said it would require labor on my part, and I’m ready to do it TBH.

@tayyar - @raimond replied above your last two replies, look up ^^ Thanks for confirmation raimond I can unlock the BIOS for you guys. But as requested, can you please upload the mod BIOS mod you made, I need to check and confirm some things before I seen tayyar a mod BIOS.

@Lost_N_BIOS

The images you asked of me in the PM.

Thanks

bios pics.zip (3.43 MB)

Thanks, missing Save and Exit page Please grab a screenshot of that for me

* Edit - Also - Quick test needed, this is menu change only. Flash via USB Flashback, and then check in Advanced, do you now see ACPI submenu and if yes, show me contents
http://s000.tinyupload.com/index.php?fil…054551111016973



HEre are the missing pictures minus the ACPI test as I can’t flash that cap file.

My MoBo doesn’t have flashback support and I can’t flash it through UEFI as it states “security” or some error, and I can’t flash it through Windows with Asus bios update utility as it needs Intel ME and I can’t install it, getting fatal error. I’m guessing due to disabled ME bit.

Our best bet is currently stripping it to rom (maybe also disable ME bit, since my current bios is ME disabled? in order to avoid conflicts?) and /GAN’ing it. Would you like me to go that way?

bios pics2.zip (613 KB)

Ohh! Sorry, I didn’t realize this board does not have USB Flashback, then we will use FPT from here on out instead. Hmm, I am not sure if you can use FPT in DOS with ME disabled, please test before I write out a bunch more details
And for now, NO, STOP, DO NOT use AFU - I very much dislike AFU, especially when using OLD AFU that allows /GAN method because that was made for BIOS MUCH older than current BIOS and causes issues with future flashing.
If we have to resort to AFU method, I will link you to a proper guide/method to use instead of old ES AFU DOS/GAN stuff that should never be used on modern BIOS.

You may need to get a flash programmer, but hopefully not. ME Disabled in the issue here, otherwise I would have dropped all the info you needed here to disable BIOS/SMI lock and dump, reflash with FPT without issue.

Lets see outcome of trying to dump BIOS region in DOS with FPT - Since you disable ME FW, you know the version it was that you disabled
Go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a DOS folder. Make a DOS Bootable USB stick, and then copy ALL contents of the DOS folder onto root of your USB (not in folder)
Then boot to DOS and at the command prompt type the following command and send me the created file to modify (if anything happens ) >> FPT.exe -bios -d biosreg.bin

People need to stop disabling ME already, it’s not helping anyone keep their files from prying eyes like they think, that just closed on tiny little possible door (the huge one is still open and can be used by anyone at anytime >> Connected to the internet, or not?)
Disabled MEF W causes far more issues than it’s perceived privacy to anyone.

I got that file through the 32bit app via Windows and uploaded it to mediafire in my initial post, and I couldn’t flash it back via the Windows app, got 208 error or someting. But here’s the one dumped through DOS as you asked.

About ME, mate I just don’t like the idea of Intel running another computer inside my computer. That’s why I disabled it.

dos BIOSREG.zip (4.07 MB)

@tayyar - What is the exact error you get when you try to flash it back?? Try from DOS now, show me image of the error. Since you were able to dump in DOS, and windows (was that before/after ME Disable?), then maybe you can still flash it via FPT.
I doubt you can in windows now, since ME disabled, this is why I asked you to do in DOS because it doesn’t rely on ME drivers, so hoped ME Disabled and usage in DOS might still get us somewhere.
I know, people’s misunderstanding of what ME does, how it’s used etc