Update microcode for msi-H67MA-E45 (B3)

I cant get it to boot after i moded the bios do somone know how to do ?


7678v32.zip (5.96 MB)

@kimballen - How did you update the microcodes that’s failing to work, what method did you use, so I don’t do the same
Since the microcodes are in PEI volume, I would assume UEFITool method would fail and MMTool should be used.
Here, flash via M-Flash - https://ufile.io/xmtaiwap

Thanks works perfectly ! and you are right UEFITool will fail

You don’t know how to update the gop ?

@kimballen - Thanks for quick test and report back!
So, MMTool was used to do that microcode update. I extracted the microcode module directly, edited all microcodes into the BODY one by one via hex, then corrected the size and checksum in header, then inserted new mod microcode module via MMTool Replace tab
You can make that easier on yourself by extracting BODY with UEFItool, do your edits, replace BODY with UEFITool, save, then open in UEFITool and extract the new Entire microcode module AS-IS, then replace that in MMTool
This way, UEFITool fixes the size and checksum bytes in the header for you

Are you booting UEFI mode, AND using onboard graphics? If yes, then GOP can be updated, but if your not booting UEFI mode or using onboard graphics then no point to do that

Also, not much change in possible version, so maybe not worth even messing with >>
Ivy GOP >> 3.0.1015 >> Update to 3.0.1030
Sandy GOP >> 2.0.1018 >> Update to 2.0.1024

You can do those edits yourself with UBU, if you know how to use UBU

I tried but it does not work for me. it doesn’t boot after i moded the bios

@kimballen - Sounds like you didn’t do the mod perfectly then, sometimes it’s tricky and this BIOS is one of those times. Usually you can use the CPU Patch tab in MMTool, then it’s easy.
Ohh, did you mean the microcode edit, you tried yourself and it failed? Or did you mean you did something with UBU and it bricked the BIOS? << IF yes, UBU, what did you do in UBU?

I update GOP in UBU and it bricked the BIOS

@kimballen - If you ONLY updated GOP in UBU, please send me the before BIOS you edited and the mod file, I will check it to see if anything obvious might cause the brick
If not, then the GOP either just is not compatible, or you also needed to update VBT and did not.