Updating some PCI ROMS on a nForce chipset.

Hello!,

I just got an old motherboard in my hands and i would like to play with it a bit trying to update as many PCI ROMS as i can. I’m learning to bios mod, i have already succesfully done it with an AMI (non UEFI) and now it is time to play with a Phoenix BIOS.

The motherboard i got is a Gigabyte GA-73PVM-S2, it has the chipset NVIDIA® GeForce 7100/nForce 630i and RTL 8211B chip for the LAN.

This is the output i get from CBROM:



So basically i would like to update the ROM for the modules 13, 14 and 15, aaand maybe the VGA ROM too (12). Sadly i can’t find any ROMS for it, so if anyone can help me with this would be nice.

I’m not sure if i’m posting on the right section or if i just should write a new reply on the thread “AHCI & RAID ROM Modules” for this matter.

Thanks!

You will find 2 very interesting NVIDIA RAID ROM modules within the start post of >this< thread. Additionally you may look >here< for other NVIDIA PCI ROM modules.
At first step I recommend to concentrate your work on the update of the NVIDIA RAID ROM (No. 13) and AHCI ROM (No. 15) modules.

Good luck!
Fernando

Oh, wow!, don’t know why i missed the Intel AHCI ROM modules, guess i was thinking on ICHR chipsets :/. I’m going to focus first on updating the AHCI Option ROM BIOS since i’m not using the RAID OROM at the moment on that computer.

Thanks!

I’m having problems trying to replace the AHCI ROM



The new PCI ROM size is exactly the same as the old one (16KB).
I also already tried to remove the EPA logo but still the same :/.

@ quetzalin:

Have you tried to remove the AHCI ROM module as first step and then to insert the newer one?

Removing the ROM module and inserting worked but now i have a bigger problem. I can’t flash the BIOS at all. When i run PHLASH16 the bios starts to flash but then i get the next ERROR “Platform Signature Not found in the Interface. PRESS ANY KEY TO REBOOT”. If i press a key the computer reboots but the BIOS doesn’t get flashed.

Is this some kind of checksum error u mention here? :confused:

No, I don’t think so. Please do a Google search for “Platform Signature Not found in the Interface. PRESS ANY KEY TO REBOOT” and you will find a lot of tips.

I was finally able to update the bios… but started to get desperate at some point. I found the problem wasnt the BIOS file, had the same issue with any bios file, even the original ones. It just refuses to flash using PHLASH or even WinPHLASH (tried several versions of both tools, same result).
I had to use the Windows @BIOS tool from gigabyte, and i can’t use Q-FLASH (if you know this tool lets u flash from the bios menu) because the bios version i’m using* (a beta one from gigabyte… sigh) is bugged and the computer hangs during the POST if u have a pendrive connected (and i need the pendrive for the Q-FLASH, or a floppy drive which i don’t have).

I really hate Gigabyte at the moment.

Now i just reverted to the latest non beta bios so i can use Q-FLASH, modded the NV_AHCI OROM in the stable bios version but the AHCI module is gone (doesn’t detect any HDD) so i did something wrong i guess.

I’m done for today, will try more luck yesterday or something!.

*The reason why i was using the beta bios version is because it has the microcode update for my processor, not a big deal since it also works with the latest stable without the microcode (it just doesn’t recognize the name of the processor during the POST).