Using Phoenix Tool for swapping Option ROM


I just registered here, after I had found that this forum has some experts in BIOS modding with much of experience.

I got one Thinkpad T60 and i want to include an Asmedia Option ROM into this BIOS for enabling autoboot with a corestore plus mini PCIe card.
The ASMEDIA option rom for corestore was downloaded from this forum (1b21-0612_v0954.bin)

I have a tool called ‘Phoenix Tool 219’ from mydigitallife. Normally this tool seems to be meant for integrating a SLIC table into the BIOS, but i abused it for my needs like this:

1. I started the Phoenix Tool and pointed it towards the original BIOS file i had read out using ‘Universal BIOS Backup ToolKit’.

2. At this point Phoenix Tool loads the BIOS.rom and saves all components in a directory named DUMP.

3. In this DUMP directory there was a file named ‘OPROM8.rom’. Using an hex editor I could see it contained the Intel-PXE-Boot-Agent. (Copyright (C) 1997-2008, Intel Corporation Initializing Intel(R) Boot Agent GE v1.3.24 PXE 2.1 Build 086 (WfM 2.0).
This file’s size was exactly the same as from the ASMEDIA ROM I want to integrate.
There also was OPROM7.Rom, which contained ‘Intel PXE Base code’ (Intel(R) Boot Agent PXE Base Code (PXE-2.1 build 086))
So I just deleted the original OPROM8.ROm file and replaced it by the ASMEDIA ROM (1b21-0612_v0954.bin), which I renamed to OPROM8.Rom.

4. After replacing this file I checked the ‘No SLIC’ Option in Phoenix Tool’s parameters, so Phoenix Tool wouldn’t ask me for adding a certificate and RW-Everything-Report, what I wouldn’t need.

5. Then I clicked OK and Phoenix Tool continued the automated process, compressing and including the OPROM8.Rom file I had replaced.

6. Phoenix Tool finished this process showing no errors at all, so it seems to have worked fine.

Now I got this modified BIOS file on my hard disk, and I really wonder:
Should I flash this to my BIOS chip?

I mean:
-I abused one fully automated tool that originally had another purpose.
-I manually intervended into the automated process by changing this file before the Tool would recompile the BIOS again.
-I just replaced a file, because it had the same file size and a similar purpose. Similar in the way that both Option ROMs (original and the one I replaced it with) have the purpose for booting from a medium .(Well, not exactly: The original OPROM8 seems to be the part of the PXE BIOS that makes up for the SETUP-Tool, instead of the boot integration I think!)
-I replaced a boot ROM for a network device with that for a mini PCIe device of another vendor.
-I got no idea what I really did there


Is there any reasonable chance this idea might work?
What do you think about what I’ve done here?
Would it be safe to flash this BIOS?
Would I need to check further options in Phoenix Tool for making this work? Like something checksum related or telling Phoenix Tool that I had replaced a file or whatever?
Will this self modded BIOS fry my good old T60?
Or is there a serious chance for this mutant BIOS to actually work?

Thank you for helping :slight_smile:

@ ElMariachi:
Welcome at Win-Raid fORUM1

Are you sure, that you have used the latest version of this tool? I have recently downloaded v2.5.9 of Andyp’s PhoenixTool.

Since I am not an expert regarding this sort of BIOS modding, I cannot answer your questions.
I hope, that CodeRush will read your post and give his comment.


Thank you for welcome:)

Regarding the Phoenix Tool version you probably are right. But I think it won’t make a difference, as the BIOS for my old T60 of course is rather aged now anyway.

I’m nervous especially regarding the connection between OPROM7 and OPROM8, as both seem to be part of BIOS for one feature (network PXE Boot). So what would happen if I just replaced OPROM8 part, without removing or changing OPROM7.

Woudl be great if CodeRush could have a look at it!

Ok, I just repeated the process using Phoenix Tool 2.56 for being a bit more on the safe side :slight_smile:
Also I found an option for manually changing modules, that gives you a waiting time until you have placed your changes, and continues after clicking OK. So there’s a little bit less doubt about my manual intervention into the automated process on my side.

I have been trying to do the very same thing recently, see my thread here:
ThinkPad X201 - replacing Intel PXE Option ROM with ASMedia SATA module

I have flashed various modified images, only one of them bricked my board :wink:
Be sure to prepare a crisis recovery USB-stick so you can restore the original BIOS. Worked quite well for me.

Nevertheless, this approach has not been successful on my X201 so far.


Your thread was the one that made me find this forum through google :slight_smile:

I already created an crisis stick, but it won’t work on my T60, because none of the usual key combinations for forcing the recovery procedure is working for T60. I tried Fn+F, Fn+B. Win+F, Win+B and Fn+ESC, but nothing worked, the notebook always normally boots into windows :frowning:
It seems like Lenovo disabled recovery for this notebook.
I could not find any recovery solution for the T60 besides disassembling and using an SPI programmer.
So I only have one try and if this fails then my T60 is bricked

Did you also try modding the bios just with Phoenix Tool and swapping the file like I did? I found phoenix tool has options for disabling slic and enabling module swap. Maybe the module swap feature does something usefull, besides just recompiling the files for making the modification work?
With your working crisis recovery, you at least have a chance for trying that out with lower risc :slight_smile: There also is an option for replacing files by other files with different size - Maybe this could fix the problem in your case?
I don’t understand in your thread, how you filled the option rom file with zeroes. Wouldn’t that mean overwriting existing data within the file?

In my case I have the chance for just swapping the file without any further modification, because file sizes are exactly equal. Maybe this has a better chance for working. But then again: I only got one chance…

@ ElMariachi and Gex:
Thanks for your interesting contributions.

@ all:
Since the use of Andyp’s Phoenix Tool seems to be the only option for some users to get the Option ROM modules of their mainboard BIOS updated, it would be great, if someone would start a new thread with a short guide about how to do it.
Note: Contrary to My Digital Life I don’t want to offer here any help regarding a SLIC modification.

Well, we still got no valuable results, but I hope that Gex might try the process as I did, using the Phoenix Tools’ features, and flashes his rom as he has a chance for recovery with his notebook.
Im just thinking about buying a Bus Pirate for reading and writing the flash directly.

There’s a misunderstanding about what I said regarding the SLIC Option:
There’s an option for slic injection in this tool and this is enabled by default.
As we don’t intend slic injection here, it’s important to tell someone who doesn’t know the tool, yet to disable the slic injection, because otherwise Phoenix Tool will ask you for some data and files that you neither have nor need, thus making further progress in the tool’s GUI impossible.
By the way I think someone with an genuine OEM Windows Version maybe should reinject his genuine slic during the module exchanging progress, because otherwise his vendor supplied Windows might get deactivated. I don’t know if the “No SLIC” option just ignores all SLIC data or if it replaces even existing SLIC data by clear space. There’s no dedicated option for just ignoring and leaving original SLIC untouched at least.


I just saw, that Gex already did this and he knows the options. I will try contributing in his thread if possible.