[Win10 LTSB] v1607 without NVMe Support?


Under Windows 10 LTSB with a pc intel 11th gen (chipset intel) at the installation the nvme disk is not recognized. I have tried several drivers without success. If anyone has a solution.


Edit by Fernando: Thread title customized and specified

Nothing to do with Windows 10 LTSB… as long as its a bootable x64 UEFI OS image as NVMe protocol doesnt like legacy environment.
Users cant help you more, the information you provided is overwhelming…11Th gen chipset intel…

EDIT: SSD Class 35 seems to be an NVMe drive, OS age is no issue here.
The issue must be configuration on bios, this doesnt mean u need to see the drive itself in bios config, but usually Dell shows it. Upon OS setup, destination drive, no drive show?

EDIT: Well thats new for me… never heard of lack of NVMe support on 1607

EDIT: Theres ur proof from our friend lfb6… NVMe support comes since W8, all W10 have support for it, ty lfb6

The Win10 LTSB version is an old iso (1607)
The PC is a Dell XPS 13 9305 https://www.dell.com/en-us/shop/dell-laptops/xps-13-laptop/spd/xps-13-9305-laptop

EDIT: If I take a recent iso for ex 1903 the disk is well detected at the installation. In the bios the disk is ok (configured in AHCI). With the iso in 1607 the disk is not seen at the installation. Windows asks to load a driver.

Stornvme.sys is well known to 1607?

Here is the stornvme.sys of version 1607

Well, nice to see that you got one, too, but what’s your problem then?

The file comes from a virtual machine. The problem is that I can’t install Win10 LTSB on a Dell XPS 13 9305. During the installation Windows doesn’t detect the nvme disk (the disk is present in the bios) I have to install a driver. I have tried many drivers without success.

Welcome to the Win-RAID Forum!
It seems, that you haven’t chosen the correct BIOS settings to be able to boot off an NVMe SSD. As soon as you install the OS in UEFI mode, you will succeed with the OS installation. Please have a look into >this< guide and follow the instructions within the chapter “Installation of the OS onto the NVMe SSD”.
Your chosen thread title is absolutely misleading, because your problem is nothing to do with a missing NVMe driver, nothing to do with the in-use Win10 Edition and nothing to do the CPU Feneration of your system.
Once you have solved it I will move this discussion into the better matching place.
Good luck!
Dieter (alias Fernando)

The bios is well configured with an iso e.g. 21H2 everything works normally (the bios is well UEFI & AHCI) If you have similar hardware do the test the problem will be the same.

Why must be the 1607 RS1 iso? What is the source of the image? There were 2 releases of the Redstone1 1607 (2016), the later 447 (2017), and later some support for Intel Clover tail chipset (10.0.14393.2214) and who knows…even more, this was before RS2, same result on both images? Get the ESD and integrate updates…

FW for NVME/ RST drivers – FW upgrade is last step

first try only setup - bios
bios setup -try sata controller RAID “RST” but not configured ! - works like AHCI “but sometimes is this better for boot / fix missing storage”

disk verification “GPT table you must have” --yours windows bootable USB SHIFT + F10 – CMD " 22h2 iso or yours version 1607 ,.,.but why ?

**cmd **
**diskpart **
list disk

here exist NVME ? - must be formatted "select disk x ,.,.clean"
,.,.all disk must be GPT “or missing” under UEFI boot “mix MBR + GPT - missing storage”

///select disk carefully !! CLEAN command remove all data on storage !!!
google “diskpart tutorial”

,.,.,.after this restart windows installation ,.try luck :smiley:
this is my fast translation ,.sorry

tool for ISO download - recommended last 22h2

for bootable usb

,.,.drivers - RST or AHCI around 500 series chip “best in RST mode ,.,.but not configured or AHCI when works”
Easyupload.io - Upload files for free and transfer big files easily.

You cannot configure the BIOS by using a Windows ISO file.

So why iso 1607 because it’s an enterprise version LTSB and it’s based on version 1607.
I contacted Microsoft support (I have an enterprise contract)

Your linked Intel RST driver v18.7.1.1003 is a VMD one and doesn’t support NVMe. By the way - why did you link to another Forum, although this driver is available >here<?

Before you are trying to get any Windows OS installed from scratch you should check the HardwareIDs of the Storage Controller, which manages the data transfer to your desired system drive.
By the way: Which is the model and who is the manufacturer of our desired system drive?

The HardwareIDs of the Storage Controller is PCIVEN_144D&DEV_A809 and the nvme disk is a samsung 980 500Go

my upload “original SDI-lite”
contains all.,. AHCI / VMD + normal RST + extensions “check folders inside”
,.some files missing on forum ,.,add this in local database :slight_smile:

None of the Samsung NVMe drivers natively do support the HardwareIDs of the NVMe Controller, which is within the Samsung 980 SSD.
If you want to install Win10/11 onto the Samsung 980, this should not be a problem, because all Win10/11 OS Editions have a generic MS NVMe driver in-the-box.
Preconditions for being able to boot off the NVMe SSD:

  1. The mainboard BIOS must contain an NVMe “DXE Driver” module.
  2. The installation has to be done in UEFI mode.
  3. The target system drive partition has to be formatted by using the GUI-Mode Partition Table (GPT).