Windows 32-Bit OS iNTEL SATA & Gaming Discussions 2000 XP 2003 2009

I always connect the target SATA system drive to the first Intel SATA port named “SATA3_0”.

No, the ASMedia SATA Controller has been set by me to “IDE”. I just use it for my DVD Burner (some Optical Drives to not like any other SATA mode than “IDE”).

Who told you to use this WHQL certified driver, which doesn’t support any Southbridge of a modern Intel Chipset? You have to integrate the “Universal 32bit textmode driver mod+signed by Fernando”, which you can find within the start post of this thread.

No wonder, when you have integrated a driver, which doesn’t support your system at all.

Correct.

Message has been deleted (added by Fernando: it has been deleted by the author).

That should have been no surprise for you. If you connect your target system drive to any ASMedia SATA port, you have to load/integrate an ASMedia AHCI driver and not an Intel one!
The Intel SATA Controller can only manage the Intel SATA ports!

As long as you don’t carefully read and follow my guide (= start post of this thread), you cannot expect any further help from my side.

@XPLives :
Please stop writing posts, which have nothing to to with the topic of this thread and additionally don’t make any sense.
Since we both have exactly the same mainboard model, you asked me how I got XP installed in AHCI mode, and I gave you >here< a detailed answer. Instead of following my guide and inserting the same driver, you have done something totally else and complained about the BSOD you got.
I don’t know anybody (except you), who has ever tried to connect his/her target system drive to a third party SATA Controller (here: ASMedia) instead of using the much better SATA Controller, which belongs to the chipset (here: Intel). Furthermore I don’t have the intention to modify any ASMedia AHCI drivers to give users of the latest Intel Chipset mainboards the option to get XP or Windows 200 installed onta a SATA drive, which is connected to an ASMedia SATA Controller running in AHCI mode.
My last advice for you:
If you want to get XP installed in AHCI mode onto your Z170 system and benefit from the speed you will get, try it the way I succeeded (see the link abbove).
If you should not succeed, don’t bother me with future questions about the reason. Just connect the target drive to any of your on-board ASmedia SATA ports running in IDE mode. This way you don’t need to integrate any storage driver into the XP image.

Good luck!

No problemo Dieter I just read your post so I deleted the previous message. :slight_smile:

I have successfully modified the Asmedia Sata Controller AHCI driver to work on XP install. No worries any more. I was expecting no assistance but I am persistent and managed to get it to work properly on my own. I guess for some reason I thought if somehow you helped that would be great in case I failed something you volunteered might have helped to get it to work. I gave it a shot after my last message and kept at it constantly to see if it were possible before returning here just now to read your new reply in case I gave up. Necessity is the mother of invention as they say and the Asmedia SATA Controller AHCI XP driver is now my baby. No actual blood or sweat but painstaking time and experimentation to finally get it to work.

As for which Sata Controller is better Intel vs Asmedia in XP I don’t know the answer to that and haven’t tested yet to give a performance comparison for you. You could be right the Intel one is superior but as I said the reason why I wanted to get the Asmedia Sata Controller working under XP was due to it being able to have the option to switch to SATA IDE mode for troubleshooting purposes. Previous generation motherboards Intel offered SATA IDE mode. This is no longer true on Skylake. I’m not sure about Haswell as I skipped over that generation when they dropped XP driver support for their Intel HD Graphics. Another reason is Asmedia had more XP drivers available for their products where Intel decided to stop supporting XP earlier in conjunction with Microsoft. I would say they stopped around 2013. Without the SATA IDE mode I wouldn’t have been able to test XP or 2K installs without a proper AHCI driver. Had the Intel SATA Controller on our motherboard included SATA IDE mode I would normally have hooked my hard drive to the Intel Sata port from the start instead of the Asmedia port. This is why my setup was inconsistent this time around again. :frowning:

The last few days when I tested your drivers I didn’t realize your driver was only for the Intel SATA Controller as usual that is the one I used in most situations in the past but when I got this motherboard I didn’t have access to your modified driver so I was unable to get XP setup and that’s why I had chosen to hook it to the Asmedia SATA Controller at the start. I guess the only additional advice I can give to add to the instructions is Step 1) Make sure your motherboard has Intel Sata Controllers and you are connecting your hard drive or SSD to an “Intel” Sata Controller port and not another brand or the AHCI driver will not work. So I ended up trying all your drivers and trying each possible AHCI driver out of desperation to exhaust all possibilities before giving up.

Recently a few days ago I thought I’d give it one more shot and tried your driver although we both eventually realized the reason it didn’t work was I was not on the Intel SATA Controller as the cause which I also had started to assume that is the reason since it didn’t work after multiple attempts after you pointed me to the correct driver file to try. For some reason I assumed your modified driver would work on Asmedia ports which is why I asked an obvious question which you pointed out LOL just to be sure that wasn’t the cause. :slight_smile:

As for your last advice. :slight_smile: Yes I might try your Intel driver when I get a chance to move the hard drive to the Intel Sata port. The computer case is screwed tight so I was lazy not to unscrew and swap ports for the hard drive. But I will most likely test your driver on Windows 2000 on the proper Intel ports when I get a chance. I thought I had tried your driver before in the past on an older generation motherboard and I was unable to get Windows 2000 to work and the reason why could be perhaps I also had it hooked it up an Asmedia Sata port at that time as well without thinking and given up years ago thinking your driver did not work. But seeing people say your driver worked for them I decided to attempt it again thinking maybe the newer version had improved compatibility. At that time my original motherboard had XP drivers and I didn’t want to spend hours or days trying to get Windows 2000 in AHCI mode on it that badly.

You obviously still haven’t read the start post of this thread until now.
Proof: This is the related part of my guide since I wrote it in May 2013:

Not exactly true I think I may have read the guide fully back in 2012-2013 time frame when I set up a Sandy Bridge but didn’t have a Windows 2000 AHCI driver and that was about the last time reading after giving up on Windows 2000 install. Most of the nLite I’ve done before from information on another site way back in 2010 I believe when I was trying to figure out what the BSOD 7B error was for a laptop install of XP that came preinstalled with Windows 7 which at the time I disliked.

Although I have looked over your first page guide a few times recently even before the last posting you made but maybe only the sections that interested me trying to hunt for the right driver as the page is quite in depth and could be shortened down to a condensed version for quick absorption of the important facts and the larger full guide through a link or spoiler.

EDIT by Fernando: The rest of XPLives’s post has been deleted by me, because it had nothing to do with the topic of this thread.

Hi Fernando!
I love your forum, I’ll try to be short, and would appreciate your help, sir! :slight_smile:

I have an:
HP Envy 750-247c, with an Intel 100 Series/C230 Chipset. DeV ID=A102.
(see attached pic)
https://support.hp.com/us-en/document/c04949967
i7-6700 @ 3.40GHz, 24 gigs of ram
Motherboard:
Manufacturer name: Pegatron
HP/Compaq name: Thimphu
SSID: 2B4B
Chipset: Z170
https://support.hp.com/us-en/document/c04790224
Nvidia GTX 745 video (PCI-e)
Creative ZX-r series sound. (PCI-e)
USB mouse/keyboard
2 TB NTFS SATA drive only (I installed)


Goal: get XP SP3 in 32-bit installed

*I made a custom XP install CD following your directions, and N-Lite with the “Universal 32bit Intel RST textmode driver v11.2.0.1006 mod
The textmode driver I integrated was “Intel(R) SATA AHCI Controller DEV_A102 added by Fernando”. (I later also tried the RAID and the PNP)
This CD was run from a USB DVD-R drive. (I’ve tried making a USB install, but it the XP setup never starts… perhaps I need to find a better program to make it?)
In the BIOS, per your instructions, I’ve disabled “fast boot”, turned on all power management (including SATA power management), and enabled Legacy mode.
I am not able to select “IDE/ATA” in the BIOS, only “AHCI” or “RAID” under “SATA EMULATION”.

I get 2 errors during XP setup:

1) At the driver loading stage, if I do not press F7, I get a BSOD (Error code: 0x000000A5) stating that my BIOS is not fully ACPI compliant, and I should reboot and press F7 at the driver prompt stage.

2) If I do press F7, it will first load all the drivers, then say “starting Windows” and then I get a BSOD with stop code 0x0000007B (0xF78DA524).
I googled that code, and its basically a SATA driver issue where windows cannot communicate with any usable HDDs.

3) If I press F5, I only get 2 choices: a) Standard PC with C-Step i486 or b) Other. Either choice gives me the ACPI BSOD from #1 (0x000000A5)

(I also tried x64 w/ the 64-bit driver, received the same errors/failures).

Please help, I will listen and do any steps you recommend.
Thank you very much :slight_smile:

drivers.jpg

ACPI Driver2.jpg

@bilbofett :
Welcome at Win-RAID Forum!

Since you obviously have integrated just the correct driver and the support of just the correct onboard Intel SATA AHCI Controller (and nothing else), this 7B Stop Code indicates, that the XP image, which you had used as source, has not been “clean” (untouched). Where did you get the XP image? Does the XP CD contain a file named WINNT.SIF within the i368 folder?

Regards
Dieter (alias Fernando)

I have several images of XPSP3. All are the same size: 632,640 KB
"WebForPC.Com_Windows_XP_Professional_SP3.ISO"
"pcriver.com_Windows_XP_Pro_SP3_32_bit.ISO"
"en_windows_xp_professional_sp3_Nov_2013_Incl_SATA_Drivers.ISO"

I checked for WINNT.SIF, it is indeed inside the I386 folder.

wintsif.jpg

This verifies, that all your XP ISO files have already been processed and are not original MS ones.
As I have layed down within the start post, the successful integration of any Intel textmode driver according my guide requires a “clean” (=untouched) XP CD as source. Furthermore only owners of a legally purchased Operating System and a valid CD Key can expect any support within this Forum.

Ok, no problem, I’ll buy a legal untouched original copy with a valid legal key.
I didn’t really know they were making them anymore, but that’s ok.
Then I’ll integrate the driver and try again.
I hope it works :slight_smile:

Fernando I have updated my XP installation process posting today after much troubleshooting and information gathering and mod testing.

Thanks to your technique of modifying my posts I have figured out how to modify my posts in a similar fashion.

Some notable things about Highlander X’s issues.

Yes the reason why Highlander X couldn’t install XP was due to him / her trying to use a USB bootable device to install the nLited Fernando SATA AHCI drivers.

This will not work. I tried testing every possible way multiple times with XP SP0 - Non Service Pack, SP1, SP2, and SP3.

I also tried F6 Floppy AHCI driver method.

The only method that works is this.

XP SP0-SP3 all original non Service Pack and Service Pack 1-3 versions work as tested by me on the same motherboard Fernando is using which should mean all other 100 series and 200 series motherboards will also work since I’ve done extensive testing just to narrow down what works and what doesn’t.

You MUST nLite Fernando’s modified SATA AHCI driver that includes your SATA controller’s proper Hardware ID. If you slipstream the wrong SATA AHCI driver for your Hardware ID you will always get the BSOD 7B error no matter what. Using a Hard drive folder installation method also does not work either which is similar to your USB method of putting the nLited folder onto it. Also F6 floppy SATA AHCI driver installation method does not work either. I tried this multiple times to confirm with standard XP SP0, SP1, SP2, and SP3.

You MUST BURN the final XP ISO after using nLite with your SATA AHCI driver matching Hardware ID for your SATA controller. I used ImgBurn which is free. You also must boot up on that burned optical disc as the first priority device. Also once the computer boots and it starts loading the disc a message will pop up on screen to hit a key to boot from the optical disc when asked as it gives you about 5 seconds to do so. If you miss this time frame you will have to reboot the computer and try again. Once it starts loading the optical disc and begins loading the XP setup start tapping the F7 key non stop until you see the XP install screen license agreement which you will have to hit F8 to bypass.

You will need to keep the burned XP nLited optical disc in the drive for at least two reboots. Do not hit a key to load from the optical disc the second time. This time you must let it boot to your hard drive / SSD to continue the XP setup process. Since ACPI does not function it will not automatically reboot so it must be manually done so pay attention to the XP setup screen when it says it is about to reboot or you will think the installation has frozen.

On my dozens and dozens of tests I cannot explain the delays when it is starting the installation and copying the setup files but this may also appear that the setup has crashed or frozen but it hasn’t. I think it took around 13 minutes before it actually started copying the installation files to your hard drive. So you’ll have to be patient here.

During my installation my USB mouse worked perfectly fine. Fernando says he couldn’t use his mouse at all so he gave up completing the installation process. I still don’t know why his USB mouse did not work since I use the same exact motherboard as him. I tried to help him troubleshoot why his USB mouse didn’t work as mine worked fine without any additional USB drivers.

I have successfully installed XP at least a couple dozen times repeatedly on the Z170 to ensure what options truly work or don’t work.

I’m currently working on modifying some hardware devices on this motherboard to see if the XP driver can be ported for Skylake or not.

But if you look at my guide all you really need after getting Fernando’s SATA AHCI driver working to install XP is just a cheap Graphics card with HDMI audio / video that has XP driver support. If your USB mouse does not work in XP try switching to another USB port. Try all the USB 2.0 ports first if you can first before USB 3.0. The USB 3.1 port will absolutely NOT WORK and appear dead. If all USB ports tested with the USB mouse do not work follow my guide under USB card and buy a cheap USB 3.0 card off eBay. I’m currently testing one and it appears working as well as the ethernet card. This is a lot of work to get XP running on Skylake. If you want the easiest way to run XP then get a Z68 or Z77 motherboard as all built in hardware on it has XP drivers and works properly including ACPI. Also during the XP setup process you actually don’t need a mouse to get through the setup.

Just use the TAB key or if you see the underline under the character you can use ALT + “letter” instead. For example if there was a FINISH button instead of tabbing to it you can do ALT+F. The mouse is not necessary to complete the XP setup process.

Hope this helps.

Ok, I have an original, OEM, untouched, physical disc of Windows XP SP3.
The total size is 596 MB (625,061,888 bytes).
I tried installing using the N-Lite driver integration technique, and it still gives me that same BSOD 0x0000007B (0xF78DA524).
I’ve tried changing hard drives, removing ram, removing video and sound cards… it doesn’t make any difference.
It doesn’t seem to be the correct driver for this chipset… although I trust that it is… :frowning:
Please help!


During those 13 mins, what is happening on the screen? Is it pure black? Is there a message? Because a few times I have seen a pure black screen, and it seems like nothing is happening. Maybe I should’ve waited 13 mins?
Otherwise, mine blazes through copying all the drivers, finishes, then says “starting Windows” and waits a few seconds, then I get the BSOD.

Try eBay if you need an official XP disc as they are quite cheap as stand alone.

I have tested original XP SP0, SP1, SP2, and SP3 with nLite of Fernando’s modified SATA AHCI driver and it works as long as you burn the final ISO and boot off the optical disc.

No other method will work or you’ll end up wasting hours upon hours troubleshooting. Methods that don’t work include any USB type of flash, optical drive, hard drive, and Floppy drive installation methods. I almost gave up trying to get it to work but thanks to Fernando’s resistance he actually helped me persist in getting it to work properly for my Asmedia SATA controller as well. But stick to the Intel SATA controller drivers if you want support on this forum. I’m hoping someone on here knows how to hack the BIOS to add SATA IDE mode for the Intel SATA Controller since there is no working Windows 2000 Intel SATA AHCI driver yet.


I don’t understand when I’m pressing F7… I’m so used to doing that at the “F6 Driver request” notice, that that’s when it tries to bypass ACPI.
I press F7 after it says "press any key to boot from CD* but before it starts loading drivers from the CD?
And then after I’m done tapping F7 repeatedly, when it takes me to the license install screen, I press F8?

No there should be no Black screen during the files copying from CD to hard drive / SSD. It should be Blue screen background.

It just looks like it is sitting there doing nothing. So pay attention to the hard drive activity light on your computer chassis. Once it starts copying the files you will see the light start blinking (usually red). There should be two reboots but on Skylake ACPI doesn’t work so it will not automatically reboot after it copies the stage 1 of files but look like it’s stuck on the screen. So you’ll need to hit the reset button or power it off and on manually. That’s why it is better to pay attention during the entire XP installation process so you know what is going on. You must keep the CD in the optical drive so it can read the setup files after it boots to the hard drive / SSD on the reboot.

If you are getting BSOD 7B error this means wrong AHCI SATA driver not matching your Hardware ID. Also make sure you are using a burned nLited SATA AHCI Fernando driver matching your SATA Controller Hardware ID or it will fail no matter what.

BSOD A5 means ACPI error. You have to tap F7 constantly during the XP setup disc loading till it gets to the licensing agreement screen which you hit F8 to bypass after you read it or scroll down. You have to do F7 tapping for at least two reboot stages from what I can recall to avoid BSOD A5 ACPI error. I think upon the 3rd reboot it will be strictly running off the hard drive / SSD and the optical disc is no longer needed in the optical drive. Once it gets into the 3rd reboot stage I don’t think you need to hit F7 anymore and it should continue detecting all your hardware devices and ask you more setup questions.


I’m tapping F7 repeateldy once I see the “press any key to boot from CD” until I see the license agreement screen come on? And then press F8? What happens after I press F8? It loads drivers and then begins Windows setup?
And every time I reboot I have to press F7 when it starts to read from the CD?
Thanks for the help! :slight_smile:

You only need to boot from the CD on the first stage of the setup process. It will copy some files which takes around 40 minutes or so. Then it will try to automatically reboot but it can’t since ACPI doesn’t work so it will look like a blank light blue screen I think. Here you will have to manually reset or power off and then on the computer.

On the second reboot you don’t tap the key to load from the CD but let it elapse 5 seconds so it continues loading from the hard drive / SSD then you tap F7 non stop when you see the screen that says hit F2 / F6 again if necessary. I hit F7 slightly before that pops up. You probably only have to hit F7 once if you time it right but I just repeatedly tap it until it passes the F2 / F6 screen as it takes awhile to load the drivers off the optical disc and I don’t want to hit the BSOD A5 error after all that waiting.

You don’t need to deal with the F7 key if you are on an Z77 or earlier chipset as the ACPI seems to operate fine. I can’t remember if ACPI works properly after the Chipset files are installed or if it naturally works on a clean XP install. But on Skylake ACPI doesn’t work at all so no Sleep Mode or Automatic Shut Down. I might have to do tests on the Z77 to see if Standby, Sleep, and Hibernate work on a clean install or not.

Also if you’re dealing with hard drives larger than 128GB you will need Service Pack 1 or it won’t recognize the entire capacity up to 2.2TB and you can also corrupt your files when it writes anywhere beyond the first 128GB region of the hard drive.

After you get to the license agreement screen you can read it or hit F8 to bypass. Then you’ll have to select a drive and create or select a partition to install XP.

It is better to create a 32GB partition FAT32 partition and format it. You can also choose NTFS if you want a larger partition but I don’t recommend anything larger than 64GB for the OS installation partition.