Z390 Phantom Gaming 4S/ac BIOS CROSSFLASH Resizable BAR

Hello I bought an OEM motherboard at a store it is technically identical to the ASRock Z390 Phantom Gaming 4S, but the version I have is called Z390 Phantom Gaming 4S/ac, and it was pulled out of OEM iBuyPower Systems.

The latest BIOS from iBuyPower is “Z39G4SA_1.21A”, but the latest non-OEM BIOS is “Z39PG4S1.40C (beta)” at ASRock’s website, and it contains the Resizable BAR, AKA “ASRock Clever Access Memory” update for AMD graphics cards.

When I try to flash the 1.40C non-OEM BIOS, the Instant-Flash utility will not detect the file. So I am stuck at the OEM “1.21A” BIOS which does not contain the Resizable-BAR/“Clever Access Memory” update.

Can somebody help me transfer all the good stuff of the 1.40C BIOS into the locked OEM 1.21A?, or Maybe help me “change the identity” of my motherboard so that I can upgrade straight up to 1.40C, or maybe just modify the OEM 1.21A BIOS so that it has the new micro-code and Re-BAR.

If possible however, I’d rather have everything from the 1.40C BIOS including its interface/GUI, so that I have a toggle for Re-BAR and all the the other goodies.

This is purely a software lock. Both motherboards are absolutely identical.
Has anybody else tried messing around with these motherboards for this purpose? Can anybody help me do this mod? I have attached both BIOS files.

Z390 Phantom Gaming 4S(1.40C)ROM.zip (9.8 MB)
Z39G4SA_1.21A.zip (9.7 MB)

Some users had success in cross flashing similar bios in other brands/models motherboards…
You can try programming Asrock bios with a CH341 with a clipper or via the SPI_TPM_J1 header.
The “fusion” of the 2 is usually not possible… my opinion only.
Another option…maybe… replacing the iBuyPower Intel_image region bios, with the Asrock one.
UEFI tool can be used for this.

There’s no certain of success in any of this options.

All this off course has its own RISKS of failure operation and several backups should be made to recover the motherboard.

1 Like

Can anybody verify that this worked? Has anybody tried this (cross-flashing) on this board?

@MeatWar Do you know if all of this software lock stuff is in the BIOS itself? I am not sure how this motherboard ID system works. So for example, if I cross-flash using the clip, then, the motherboard will (in theory) adopt the new ID right?

I dont understand how the motherboard “knows” that a new BIOS update will be compatible or not, and therefore block the upgrade. I assume it is some type of ID number or something.

What about just modding the OEM “1.21A” BIOS with resizable BAR? Can anybody help me with that since this is a request forum?
Are there any generic tutorials for me to DIY it? I am getting a bit lost in the forum here.

I followed the guide “/xCuri0/ReBarUEFI” on Github, and I was able to mod the BIOS but at the moment of attempting to flash it, the “Instant flash utility” will say “secure flash check fail”. It is like it knows it is modified so it wont let me even try to flash it…

I was not expecting this, but I suppose the only way to flash this is with the clip/header unfortunately. I might try later.

try to use intel fpt using the command "fptw64 -f -bios Z39PG4S1.40C " (copy paste the bios file to Win64 on flash programming tool\Win64 folder, then run cmd as admin, then redirect using cd /d Directory to Win64 folder of Flash Programmer Tool (example: cd /d D:\FPT)) to flash it, if you could flash it, reboot to bios and immidiately reflash the bios with normal instant flash.

OR you could try to flash using DOS version of intelfpt, just make a dos drive using a pen drive and rufus, copy paste the contents of DOS folder directly to the DOS pen drive and copy paste the bios you want to flash to the pen drive. DWYOR

Intel FPT for your board is CSME System Tools v12 r38, inside the Flash Programmer Tool folder use the Win64 one: File folder on MEGA

Source: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15)

1 Like

To clarify; the purpose of what you wrote is to provide a means by which to “Force-flash” a BIOS right?

I still have not attempted this yet, so I want to clarify what the intended purpose of this recommendation is. I will look into this as an option thanks.

well i dont really describe it as force flash as it’s (intel fpt) purpose is to flash bios, like flash in any means, wether your bios is incorrect or correct (say a Z590 bios) it would just flash if there is no such lock, if there is a lock like asus did, then you cant flash it, even the bios region itself. so yeah you could say this is a kind of “Force Flash” the chip itself if its possible

my intentions are that you could flash the bios region only of the non OEM bios, then after it flashed and -greset, and you could boot to the bios, just flash the normal non oem bios again through instant flash.

Could this “DOS version” of intel FPT be used to “unbrick” or “rescue” a bricked board too? or not?

Seems a bit confusing of a process, I would need to find a step by step guide otherwise its not worth the risk of doing it incorrectly.

If I try to flash a bios region via windows first, and then I “brick my motherboard” then I wouldn’t notice the “bricking” of it until the moment I restart the computer right? or would the thing just FART in-front of me and just freeze or something? lol? It is just weird I have never flashed BIOS while windows is running lol

I can prepare the DOS FPT drive with the original OEM bios and with the retail bios that has Re-BAR support, and just be prepared for whatever happens after I use this Win64FPT.exe thing.

So the “BIOS Region” is what contains this “Identity” or whatever which tells the motherboard what BIOS update to accept next right? so The logic is that if I change the identity of the board by changing the bios region only, then I can just bypass the instant-flash block, an do a regular reflash? The question, is, then why wouldn’t I just reflash the entire thing, altogether? instead of doing it in two steps ? because windows is running? or what? I am just trying to understand why one method involves two steps and the other one (DOS FPT, only 1 step). I am wondering if my chances of failure are lower in a single step process vs a two step process.

FPT Could be used as long as the board is booting

Step by step you could learn the logic using fptw64 -h for arguments and you would understand how to use it. or read this https://composter.com.ua/documents/System_Tools_User_Guide_for_Intel_Management_Engine.pdf

If you cant flash try this: [GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Yes, you wont brick until next restart, since the bios is flashed and waiting till reboot f
or the next bios to be applied, you could say it flashing bios “on the fly”, the same concept also applies when flashing bios using afuwin in windows or gigabyte efiflash.

you could try to flash your oem/own bios using dos fpt if you want to train/getting know how to use it

Yes, it contains the region for BIOS only, not the ME, Desc, ETC, so u flash the file as what it is. you could see the logic here (not a very good explanation but it’s just how it works), since i flash modded bios using IntelFPT as possible. Keep in mind you cant use Win64 fpt.exe file on DOS, i’ve tried and it wont work, so use the FPT file for separate use. I wont gurantee that FPT would work as in means it would flash, so dont worry if you make a mistake and you know your bios is locked for writing, FPT wont even start a flash, just reading the bios and it would flash IF the bios write is not locked. Why not reflash entire thing? Remember that this is stock bios and probably not initiated yet, it would overwrite the Desc Region, ME Region, and others, you could lose your MAC address too (if it is stored in the bios), since like what i said in the first post, the tool just flashes the file you assign, no matter what bios file you give as long as its same/compatible with your bios chip size. once you flash you musn’t flash again using fpt at the same time (example you flash a.bin, but changed mind, then b.bin you want to flash).

As long as you flash the bios region only, you should be safe. IF you want to back up the bios region, the command is -d -bios biosname.bin or .rom (-d means dump), or if it’s possible to dump entire bios chip then just use the -d argument.

1 Like

Ok cool, I will check this out and try to understand it better before I try this, just to be safe

1 Like

yup better be safe, the win raid gurus here could teach you propperly how to use Intel FPT, im no good at explaining but what i could tell is, -h is for help windows for arguments, -i is for reading the bios chip info, -f is for flash, -d is for dump, and args like -bios is for bios region, -me is for me region, -desc is for desc region, etc.

At the moment I already followed the NVMe Mod guide, in combination with the xCurio guide and I do have a modded OEM BIOS with the Re-BAR dxe module added into it which I call “Z39G4SA1.21R”. Could it be “safer” to flash this modded BIOS region using INTEL FPT than to cross-flash the Retail “Z39PG4S1.40C”?
I used UEFItool to explore the original OEM Z39G4SA1.21A and the Z39PG4S1.40C, and I noticed they both have the same Intel ME region and all of that. Not sure if this means the are all equally "safe to flash using FPT.

I already made a FreeDOS USB disk with FPT.exe in it and I also threw in all the bios files in there.

I drew a diagram of what could be done, there are two approaches.
on the left you see “practice/ReBAR mod” vs "cross-flash).

I dont have a complete picture of where “Greset” command for FPT is needed, or exactly if it is needed at all. I put the Greset command after the flashing of the cross-flash. Can you check the diagram and tell me your thoughts.

1 Like

It should be safe to use the modded bios

also if you do add it, i hope it use MMTOOL rather than Uefitool to avoid pad-file destruction

You could either try flash the original non oem bios if you dare enough. as long as the board layout the same and you could see there is little to no difference in every components, then you’re good to crossflash. last time i crossflash motherboard are using H61M HVGS board using H71M DGS cause the board layout are the same.

@Koekieezz adding ReBarDxe with UEFITool is fine since there’s no pad file at end of DXE driver section. one person had MMTool cause not booting so I think UEFITool is safer for adding ReBarDxe

i am still a bit worried of this
-Greset command, are you sure i need it ? the manual says it has to do with some offsets. i just want to make sure I dont mess things up by using it or that there is no risk associated with it. also does it go after the flashing of the bios region or after restarting?

you could not use that if you want, usually i use it mostly after a full bios region flash, that includes overwriting me region, desc, etc.

yes, like what i’ve said if you could flash bios region only using fpt it would flash the bios region from non OEM Bios you have, just after flash go to bios and see the MB name. if it changed then bios region flashed successfully.

1 Like

I was able to cross-flash successfully. First I flashed my modded bios with the dxe driver for re-bar and then I set the rebar to unlimited and I noticed I lost my video on the screen so then I just went “F-it!” and I cleared the CMOS then did the FPT64.exe command for the 1.40C bios region, and the motherboard booted and I noticed the name did change.
So then I used the AsRock Instant Flash utility to reflash the 1.40C bios and it is working fine.

It used to be called the same thing but with “4S/ac” at the end.

However the interesting thing is that nothing in this BIOS appears to have any kind of toggle for Resizable BAR… LOL? so like… the bios is completely identical to the previous one lol.
I have no new features at all. WTF?
I might have to just mod this one with the DXE driver too and just try that mod lol…?!

1 Like

Since you are able to Flash the Original Counterpart fully now (yeah F OEMs), you could ask asrock support for it XD

OR fully dump your bios or just the bios region, insert rebardxe using UEFITOOL or MMTOOL (or dump the full bios/bios region only dump here if u dont have the tool)

BUT before doing so, why CSM Disabled is no? maybe go back to bios and Disable CSM, and check if Resizable Bar option is there after CSM Disabled? CSM Disabled = board running pure UEFI environment.

Also what are your system specs?

Yes, it was very well hidden, I was about to correct my previous post. I found a video on youtube showing how to enable it.
I had to disable CSM and then the Resizable BAR = “Clever Access Memory” option appears secretly in the chipset options.
But then I also have to enable “ultra fast boot” because sometimes it would hang at boot without it.

It is working perfectly, the cross-flashing worked and all, I just didnt expect it to be so hard to find the option.

I have a newer computer of ryzen AM4 and it was so much easier so It gets a bit confusing jumping from one type of BIOS to another.

I also disabled High Precision Event Timer in the BIOS, apparently it may have been causing major lag in some games for me.

Everything seems stable. I have a 9900K at 5.1Ghz All cores and 4.3 Ghz cache and a sketchy combination of ram that adds up to 48Ghz at 3600 but nothing appears to be giving me any problems so far.

the mod would have worked perfectly too but I would have had to play with different BAR sizes like for 2 hours, and like it was just gonna be a headache, this way it just does whatever it can do and it appears to have a max BAR size of 8 GB which is totally fine to me.

1 Like