15 r3 Dead Alien (corrupted bios ?)

Hello…After numerous searches. I ended up here. From what I’ve read… there is some great help here.

15 R3… Updated Del’ls software (OSD) to switch from optimus to dedicated DGPU (FN+F7 switch). Selected DGPU, computer rebooted and bricked. 2 red, 1 blue error (bad CPU). I know it’s not the CPU as all was working well up until I added Dell’s software and it rebooted and bricked. Will Not Post.

Did the pull battery, drain it w power button down, unplug cmos battery, short the jumper… Nothing. My guess was the OSD software updated a part of my Bios when it tried to switch from optimus to Full time dedicated GPU.

So…trying to figure this out… I got the CH341… Modded it to 3.3v. Read the bios, verified, backed it up.
Starting the search for a new bios (@Lost_N_BIOS posts about a similar situation but all the links are expired)…
Downloaded Dell’s latest …extracted the ROM w/ writeromfile. Converted it to BIN in UEFITool. erased. flashed w CH341a ver 1.18 verified… reboot. nothing it was 12mb… hmm W25Q128 chip is 16mb… so Im pretty sure I’m missing something.

Went on the hunt and found a 16mb 17R4 LA-D751P Wq25128 CLear ME.bin look like the right chip and file size… erased. flashed w CH341a ver 1.18 verified… reboot. nothing. Tried Colibri and detected the exact chip… same process… nothing.

I’ve been reading that I may need parts of my backup to import into a new bin… Don’t know a thing about patching a bios. Have barely figured out how to look at the parts of a bios in UEFITool.

HAve been doing alot of reading … Maybe something to do with Microcodes update and it not see my processor correctly…way deep water for me.

Any suggestions, links , or someone who might want to look at my bios… to save this Alien boat anchor. I know when I’m over my head and I think If I could figure out how to extract whatever part I need and put it in a new bios… I might have a fighting chance…But, again… I’m in deep water and need expert knowledge.