2 bios chips acting as 1?

Hello everyone
I have the Asus prime z590-p I was recently trying to figure the chips type going to manuel I found that there is 2 chips both acting as one ?
It says: 192 MB BIOS (164 MB flash rom +64 MB UEFI AMI BIOS )
how I’am suppose to dump such type of bios ?I tried the ami but it gives error that bios dump is too big to open?
thanks in advance

Flash chips in VSCC table:

EF4018 (Winbond W25Q128)

C84018 (GigaDevice GD25x128)

C22018 (Macronix MX25L128)

EF4017 (Winbond W25Q64)

C84017 (GigaDevice GD25x64)

C22017 (Macronix MX25L64)

z590p

With latest AMI tools: https://www.ami.com/resources/support-other/
Or Intel FPT tool v15
…besides a CH341A spi programmer on direct contact or TPM header conection

Thank for the detailed info
But still a part of the problem isnt solved yet
what should I do with the bios eror too big to read? (yes i used the link yet still get the problem)
Is there is a way to factory reset bios to its old state ? not the settings them selves but the drivers and firmware stored inside ?

Strange…the AMI tool v5 can read and save their own job, then FPT tool as told before.
Modern bios usually dont allow back versions, some motherboard models have this option in settings.
Then all that remains as option is an SPI programmer.