2234-Heci error during initialization

I have an HP Prodesk 600 G1 desktop mini, which is showing this HECI error on startup.
Upon pressing F1 the computer will boot into Windows, but there is no Intel ME functionality.
If I try to configure Intel ME by pressing Ctrl-P at boot up, it does not enter the menu, instead just continues to boot into Windows.
In BIOS the system information shows Intel ME as N/A

I performed the BIOS update again using the latest BIOS version from the HP site (sp96020.exe) which completes successfully but the HECI error is still there.

I downloaded the Intel ME System Tools v9.1 r7 and tried to run FWUpdlcl.exe after booting into DOS using the ME9.1_5M_Production.bin file which is in the ME folder of the firmware update from HP site for that model (SP90243.exe) but that would not run.

I located the Flash Descriptor Override pins on the keyboard, placed a jumper on them, and again booted into DOS to allow the MEInfo.exe to generate an output (run in verbose mode) - see attached MEINFOVE.TXT - this shows the ME File System Corrrupted value as Yes

Whilst in this same mode I ran FPT.exe with the FSTS switch I think to generate the attached FPTDUMPL.TXT file.
I also ran fpt.exe -desc -d FPTDESC.BIN to generate a dump file that is also attached (file renamed to FPTDESC.TXT)

I am not sure where to go from here, any help would be most appreciated. Thanks


FPTDUMPL.TXT (481 Bytes)


Since you can get read/write access to the ME region of the SPI/BIOS chip via the hardware jumper, dump the entire SPI chip via “fptw64 -d spi.bin” and follow [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization in order to generate a clean/repaired “outimage.bin” image which can be flashed back via “fptw64 -f outimage.bin” followed by “fptw64 -greset”. If the problem was at the ME firmware, it should be fixed after the reboot.

I was fighting this exact problem today. I ended up flashing JUST the ME region that I extracted from HP’s BIOS file over mine. I found the jumper. I only flashed the ME region and not the whole SPI. The FIT program would not allow me to open my whole SPI extracted from my own system, but it could open the one from HP fine. I just built it without changing anything in FIT and went into the “int” folder of FIT and took the ME region file. I flashed that over my ME with the fptw64.exe -ME -F yournamehere.bin command. I did have working ME after that, but it would say I was booting in manufacturer ME mode after that. To try to fix that, I tried the fptw64.exe -CLOSEMNF no to take it out of manufacturing mode, but that totally killed it and now I can only run my system with the jumper on. That’s fine though I’ve already ordered a replacement system. What’s funny is I don’t even know why it got corrupted in the first place. Probably just a bad motherboard. It’s really OK and I just bought a dell optiplex 9020 with no CPU or RAM and am just going to swap, those work fine.