A modified IRSTe RAID module for the Rampage V Extreme


Hello @Fernando ,
I don’t know exactly which is the IRSTe RAID ROM/EFI RAID Driver best version, I remember that 4.1 version was flawed. Should I use 4.5 version or later?.

Another thing, I don’t really know if an Intel Xeon Processor is mandatory for use an IRSTe module or if I can use my i7.


Many thanks, and there is no hurry, do it when you want/can, I will wait for you notice.

Hi all,
I’ve been investigating and I’ve found out that in the IRSTe version 4.5 OPROM, in the .bin file, appears two times the string “86 80 26 28”, that could mean the hex code for the DeviceID DEV_2826.

The question is, if I change this string to “86 80 22 28”, am I changing the DeviceID to DEV_2822 making it compatible with the x99 mainboard too?

2826.jpg

You may have to change more “26 28” codes (without “86 80” before) and don’t forget to correct the checksum-8 to “00”.

After having thought again about your idea to get “TRIM in RAID1” support with your X99 system, I doubt, that it will work at all.
Reasons:
1. The “TRIM in RAID1” feature will only work with some specific, usually hidden internal DeviceIDs (DEV_2822 and DEV_2826 are only external and universally usable DeviceIDs).
2. If it would be that easy to get “TRIM in RAID1 support” with DEV_2822 Intel RAID Controllers, Intel’s engineers would have implemented it already a long time ago.



I’ve replaced all the instances of the string “26 28” (a total of 6) and the checksum-8 has changed from “00” to “E8”. If I replace another byte more and insert a “18” hex code in it the checksum returns to “00” but, which byte exactly must I replace?, maybe should I replace one of the characters “.” that matches “00” hex code?, or is there a special checksum byte for this task?



Well, I don’t possess sufficient knowledge to know if this Mod will work or not or why won’t do it, but isn’t this OPROM designed to work with X79/X99 and C600 series chipset?, and doesn’t this OPROM support Trim in almost all types of Raid?

It depends on the BIOS modules. I neither have the required knowledge nor the time for a detailed answer. You can find it out yourself by comparing the original and modded Intel RAID ROM modules, which I am already offering for the public.

The Intel RST RAID ROM modules from v9.5.x.xxxx up were designed for Intel SATA RAID Controllers with the external DeviceID DEV_2822/282A, whereas the Intel RSTe RAID ROM modules v3.x.x.xxxx and v4.x.x.xxxx are exclusively designed for DEV_2826/DEV_2827 RAID Controllers.

No, it doesn’t.

@nsb :
Have you already tried to insert an Intel RSTe RAID ROM of the v4 platform, which had been modified by yourself?
If yes, which result did you get?
If not, are you still interested in doing that?
Meanwhile I have created a test version of the Intel RSTe RAID ROM v4.5.0.1012, which may work with DEV_2822 Intel SATA RAID Controllers, but I don’t know it for sure.

Hello #Fernando,

I have been doing some tests with the modified bios without success:

Firstly I solved the cheksum-8 problem by changing a byte of a string text and thus none of the internal bios commands were altered.

After, I managed to make two versions of modded bios work. Then the system booted up whith the IRSTe 4.5 OPROM without apparent issues. Both modified bios had the string “26 28” changed in 5 and 6 instances respectively.
The problem comes when I try to install the drivers: BSOD, two controllers detected when there should only be one of them… unstable system.

I also tried to modify the file iaStorA.inf of the drivers, changing the lines than contains the string “2826” too : “%PCI\VEN_8086&DEV_2826&SUBSYS_047D1014.DeviceDesc …” , but this didn’t work either.

I managed to force the driver load and there was only once, before the system crashed, when I ran the TrimCheck program and passed the test. I can confirm IRSTe 4.5 OPROM supports trim in Raid 1, but I didn’t get it working in the Rampage V as intended.



How have you modified the OPROM?, can you explain me which were your changes? If you make a diferent modded OPROM version I could prepare the tests again (I only have one SSD, I have to copy the content in another disk to preserve the data and then create a Raid 1 in degraded mode in the SSD, and before, modify and flash the new modded bios).

I fear that this isn’t only a OPROM problem, the drivers also have to be modified to find and configure a DEV_2822 controller.

I changed the DeviceID entries from DEV_2826 to DEV_2822 and corrected the checksum-8 at offset 0x17.

Doesn’t your Intel SATA RAID Controller has the DeviceID DEV_2822? Why didn’t you simply replace the DEV_2826 entry by DEV_2822?



This is exactly what I did : to swap all the DeviceID entries from 2826 to 2822, but the driver didn’t find the controller. I tried to install the driver with this changes and without them, in its original form, but the system didn’t work in a stable manner or simply displayed a BSOD after reboot.

Like with the OPROM, I think the driver is also designed to work with a controller that has the DevideID 2826.

As long as your on-board Intel SATA RAID Controller has the DeviceID DEV_2826, your system needs an Intel RAID ROM and an Intel RAID driver, which both do support DEV_2826.
Haven’t you the option within the BIOS to choose between RST (DEV_2822) and RSTe (DEV_2826)?

I haven't this option in bios, I can't choose between diferent DeviceID's or IRST controllers, but I seem to remember that the previous platform, x79, somehow it can.<br /><br />Thanks for the help, I think I will have to wait (and pray) for Intel wants to do the job. Sincerely, I don't think that, for Intel, this is so difficult to do, and now, I'm sure that is perfectly possible.