A problem with RAM on Windows 10 Pro 64bit

A problem with RAM on Windows 10 Pro 64bit

As the title said. I’m used an Acer Netbook ( Aspire One D270 N2800 ZE7) for quite some time with an unlocked BIOS. Windows 10 Pro 64bit, always the latest version, was working very well and the max possible used RAM of 4GB was also working with 3,93GB usable for Windows. A fatality occurred and the Mainboard of the Netbook was damaged beyond the possibility to get it repaired.

Now, after a long time of waiting, I got a second Hand MB, the same spec! And for sure, I needed to unlock the BIOS again to get it working properly in Windows 10 Pro! Used the old HDD, as well as the old 4GB RAM too and all, was working again, including the activation for Windows 10 Pro.

After I deeply checked all settings again, I found the Windows 10 Pro 64bit was working with 2.93GB usable Memory, even showing that 4GB were available!

Ok, the now used BIOS Unlock was not the exact same as the old one, even I needed to re-download it again because the old one wasn’t found! The Old BIOS needed to get burned using the Recovery mode, which is a bit terrible, while the new one downloaded could be installed using the Insyde Apps for it. Looked at files and found out that 1 file had a different name as in the old BIOS. That was ZE7IA32_110.fd in the New bios, while in the old one it was ZE7IA64_110.fd, I know that because I still had a screenshot from the old to compare. All the other files were exactly the same, and even the file dates and sizes were the same! That file in question contains the BIOS program itself.

So, now my question: Could it be that this New BIOS file named ZE7IA32_110.fd is preventing windows to be able to use all available RAM? And: what I could do to get that 4GB workable in Windows 10 Pro 64bit?

I already looked to find a solution on the Net, but did! Everything I tested, didn’t work!

I would really appreciate any info which helps me. Thanks a lot in advance.

In the meantime, I further tested that RAM problems with different machines as well as with different installed Windows 10 Pro 64bit installations.

Firstly I took the HDD from the Acer Aspire One D270 N2800 out and placed it in another Aspire ONE, the AO 722 with AMD C60 CPU and also 4GB of Ram, and the D270 HDDs Windows 10 Pro 64bit worked well and showed 3.73GB of RAM usable.
Took the HDD from the AO 722 into the D270 worked also well, but RAM showed 2.99GB usable for Windows 10 Pro 64bit!

Further on I tested with an Acer eMachines EM350, which has a Single Core Atom N450 CPU, and 2GB RAM, installed Windows 10 Pro 64bit! I placed the HDD from the EM350 into the D270 and got 2.99GB RAM usable, after that place it into the AO 722 and got 3.73GB RAM usable. The EM 350 could only use a max of 2GB of RAM, just the CPU could work with 64bit OSes!

And just to mention, I use ReviOS 20H2 S1.0 64 bit a Windows 10 Pro homebrew CPU on that low-power Netbooks because it works much better than the full Windows 10 Pro 64BI! For those who may be interested in that Homebrew OS, information and even the download could be found at HTTP://revi.cc ReviOS should be used with Original Microsoft Product Keys for Windows 10 Pro and will also work with Microsoft HWID’s too!

Thanks for reading!

just out of curiosity,what are the bios versions respectively?
AO722 latest bios version is 1.11 (dated 2012/11/13)
AOD270 latest bios version is 1.10 (dated 2013/09/23)
have you tried loading defaults in bios then re-set optimals?
do you see remapping,memory map,on board graphics,igpu…or any similar settings in bios?
have you checked whether you have bad memory modules? have you tried changing their order in slots?
tried using 32bits Windows? or 64bit with Media Creation Tool? maybe custom OS is the culprit here
upgrading ram out of question?
all drivers are up to date?
have you changed any settings previously in Windows? maybe something in msconfig advanced tab?
have you checked if graphics control panel or any similar app reserved ram for itself? or maybe its reserved for graphic card(s) by build,see specs

i dont recommend swapping hdd from device to device nor migration.clean installation is always the better option
you should really use ssd
for 4gb ram and below use Windows 32bits.for more (8 is the sweet spot) use 64bits
i also recommend updating management engine firmware,
Intel (CS)ME, CS(TXE), CS(SPS), GSC, PMC, PCHC & PHY Firmware Repositories

As rule of thumb,keep your OS,apps,bios and drivers updated


Thanks for your answer!

First, of all, all of the machines in my Office having the latest BIOSes installed, most are already Unlocked, special the Netbooks. The settings in all BIOSes are set for optimal performance. All the netbooks having just 1 Memory Slot! The used Memory Modules all in 100% good condition without having any problems!

For my work, I need to use 64bit Windows only, not 32bit! The mainly used ReviOS 20H2 S1.0 is based on the Windows 10 Pro 64bit 20H2 and needs to be activated with an original Product Key or an existing HWID from Microsoft directly. This version of Windows works much better, and faster than the fully installed Windows 10 Pro 64bit, and is therefore much more reliable on Netbooks! The use of CPU Power, which stays on the fully installed MS Windows 10 Pro 64bit 95%of the time at just 100% (!!) is using in ReviOS most of the time just half of the power! Just, that Memory Problem of NOT fully usable Memory is on both OSes the exact same!

Besides that, the use of SSD’s isn’t really recommended on Netbooks! In the AOD270 I use a Samsung SSD 250GB isn’t really faster than the WD 500GB Black Scorpio (7200rpm) in the AO722! Even the speed of the CPU in the AOD270 is 2 x 1.86GHz while in the AO722 is 2 x 1 to 1,36 (with Turbo)GHz!

All drivers are up to date already!

I’ve checked many different settings in Windows and for the Graphics. Nothing is working! And again, except for the AOD270, I didn’t have any of the Memory problems in the other Machines, if they’re having Dual Core CPUs! The Acer eMachines EM350 just has a limit of 2GB of Memory for that N450 CPU set by Intel in the structure of the CPU! For the N2800 (AOD270) that limit is set by Intel to 4.8GB! In the AO722 that Limit is even up to 8GB for the AMD C60 CPU!

The problem of low usable memory is related only to the AOD270, which was working on the old Mainboard with no problems. After changing that old, damaged Mainboard to now One, that problem occurred. In that Old Mainboard, I had an Unlocked BIOS, which was running well with the full amount of Memory (4GB)! Unfortunately, that old unlocked BIOS id also damaged and unusable, the main file ZE7IA64_110.fd is not readable anymore. In the new unlocked BIOS, that file is named ZE7IA32_110.fd, and I do believe that’s why the Memory use is limited in Windows to max ~3GB only!

Unfortunately, Lopst_N_BIOS isn’t online for some time already on this forum, so I could not ask him for help! He’s knowing a lot special about the Insyde BIOSes!

Anyway, thanks a lot again for your answer, and if you have any more ideas, please let me know.

In the meantime, I installed eLive Linux on the AOD270, also as a 64bit version! Running a Memory test in eLive and it shows fully used 4096MB of memory used!

So, what is the problem that any of the checked Windows versions (7,8,8.1, and 10) on that AOD270 only showing 2.99GB or less, usable for Windows?

Any idea? Thanks for any useable information, thanks.

Most likely answer is the person you bought it from installed a 1GB SoDimm in the spare slot. Total 3GB.
Open the case and check…


@Pill_Monster :

Maybe you should check first what the used Hardware (Mainboard) is all about before assuming a correction!

The machine in use is an Acer Aspire One D270 ZE7 with an N2800 Atom CPU and has just ONE Dimm Socket! Tha Dim Socket on that Mainboard could handle RAM Modules up to 4GB! There not any more than just 1 Dimm Socket!

Maybe you should look at the screenshot again - it was taken straight from the Acer Aspire D270 Service Manual.

The column next to Dimm Socket Number clearly shows 2 sockets. That means there are two DIMM slots.

Under Memory Combinations you will see 1024 & 2048 - these are memory configurations available when new.
You purchased the laptop second hand, therefore it is quite possible 2GB was installed when new & the previous owner added another 1GB DIMM making a total of 3GB.
Don’t just assume there is one 4GB module installed.

If there are not two DIMM slots then the documentation is wrong.

@Pill_Monster :

Do you think that the Manual shows the truth while the Mainboard itself (the real existing hardware) shows wrong? And even your own picture, which you posted, just shows 1 (ONE) Memory Slot! With the N2800 Atom CPU, the one I use could use up to 4GB of Memory on a single RAM-Module! There isn’t a second Dimm-Slot at all!

If you closely look at the pictures of the Manual (used your posted Link!) from page 96 to page 104, you will see only ONE (1) Dimm-Slot, the one which is really existing!

The difference between the Atom N2600 and Atom N2800, simply is that you could use on the N2600 up tp 2GB of Memory while on the N2800 up to 4GB of Memory! The max use of Memory is up to 4.88GB according to Intel, see the attached screenshot from Intel Website:

I have that Acer Aspire One D270 ZE7 N2800 for several years and use the 4GB of Memory for the last 2 years already. After the Original Mainboard was broken beyond repair, I looked for a Used MB, because a new one was not available at Acer Service, and got the new one a few weeks ago. In the old one that had a modded BIOS which was let me use the fully 4GB of memory, I couldn’t get back, so I had to use another modded and unlocked the BIOS again, just it didn’t break the 3GB barrier, and I just get 2.66GB usable in Windows 10 Pro 64bit! Unfortunately, I couldn’t modd/unlock BIOSes!

I already tested with eLive Linux, and eLive Linux could use the full 4GB of memory! I just installed ZorinOS Lite 15.3 64bit Linux on the AOD270 and it also uses fully 4GB of Memory. If I take the HDD with Windows 10 Pro 64bit from the AOD270 into an Acer Aspire One AO722 with AMD C60 CPU, it will work with 4GB of memory as well. Using the HDD from the AO722 on the AOD270, which also has Windows 10 Pro 64bit installed, it max uses 2.93GB of Memory!

That said, That there’s maybe one Setting in the unlocked BIOS which still prevents Windows to 10 Pro 64bit run with the full 4GB of memory!