a1 - Error: BIOS does not support ME Entire Firmware update

I made a backup of this Dell Inspiron 5555 laptop BIOS with afuwin /O. I checked bios with UBU. It could open fine & even made an AMD update fine but when I try to flash I get this A1 Error. I would rather have the steak sauce and a successful flash. :slight_smile: How can I make it work? It’s a AMD system, so I am pretty sure there is no Intel ME :wink:

https://downloads.dell.com/FOLDER03905722M/1/5455A12.exe

Also tried grabbing hdr file like https://www.dell.com/community/Laptops-G…te/td-p/5111510 (amiucp method) but it did not make any difference.

Untitled.png

untitled2.png

Untitled3.png

What all boxes are checked in AFUWinGUI before flashing process? You may need to look for advanced options etc. and uncheck ME, although not sure why Dell would have that checked.

HDR and .ROM are same for this BIOS, here is the proper .ROM file, in case it’s different than what you were previously using
https://www.sendspace.com/file/sr2ugf

What updates did you do to the file? Maybe it’s the method of update causing the error? I can do the mod manually if you want, without UBU, so we can test to see if that is the problem or not.
If you want me to do the mod, let me know what all changes you need, and also upload your currently modified file and post here so I can check to see if I see anything out of the ordinary

same error with yours. just took the default options… ME is greyed out. I cannot even flash an unmodified bios. Just gives A1 error.

Untitled.jpg

untitled2.jpg

Thanks for checking and images. I only added rom in case you somehow got something different.

I see in your image, the ME is greyed out, not sure if that means set enabled by default or not available (I assume not available for you to change, and enabled by default, since the ME error shows)

You didn’t give any answers to my questions. But, so these images are now you just trying to flash the stock unmodified BIOS.rom?
If it is not, and this is still trying with mod BIOS, please test with stock un-modified BIOS.rom file, to verify that version of AFUWinGUI is compatible with this BIOS/board.

Also, if error with stock BIOS, try AFUWINx64 from command line in windows, instead of AFUWINx64GUI. You may also want to try the win non-x64 32-bit versions, sometimes this helps even if x64 system

AFUWINx64.EXE BIOS.rom /P /B /K

What is error from above ran at the command line?

It could also be that AFU version is too new, try older versions. 5.06.1 crashes on me if I load your BIOS, so does this version (5.05.04) but that may just be my system, try it and see if it crashes for you too
https://www.tonymacx86.com/threads/fix-u…mi-bios.192035/


Edit - upload your modified BIOS image and I can insert it into the stock flasher, if you think it’s 100% OK mod (If not I’ll check and make sure it all looks OK first.)
This way, should be no error when flashing, since it will be rolled up into the exe as originally designed.

/p /b /n /k0 /k1 /k2 /k5 /k6 /caf /sysext

This is the default line of arguments used by the stock programmer, if that helps you any with the cmd line version

* Edit 2

There is two rom files in that EXE, one is test010 (Project version .10) and other is text021 (project version .21).
In your latest images, I see top section (System info) shows firmware ID test021, but in bottom area you are flashing File ROM ID test010.
This may be part of the issue! I sent you version test010 as well, didn’t realizes there was two roms in there until now. The files are not the same at all, 100’s of differences.

Here is the test021 rom, try this instead, and see if it then matches top and bottom section of AFU once rom is loaded.
https://www.sendspace.com/file/cosyp7

Strange thing I see, all .roms here show Inspiron 5455 as the ID instead of 5555, maybe lazy Dell error?

I did not address questions about flashing a BIOS mod because I abandoned attempts to flash the mod once I realized I cannot flash an unmodified BIOS. It seems clear to me that I need to solve the problem of flashing unmodified BIOS first before attempting any modification. So my goal became to flash an extracted, unmodified BIOS successfully.

I did try command line and it gives the same A1 error. 32 bit version will not even launch successfully.

afuwin 5.05.04 seems to be more helpful. It gives a different error - 4 - Error: ROM file ROMID is not compatible with existing BIOS ROMID - Ah Ha. I believe this is the true error so I tick “Do Not Check ROM ID” option but then I get 18 - Error: Unable to start a Secure Flash session

/p /b /n /k0 /k1 /k2 /k5 /k6 /caf /sysext does not work in afuwin command line - it does not accept all those args & shows help instead.

I want to learn to do this myself so if I need to insert into original exe, can you point me to instructions on how to do that?

all my testing right now is with dumped rom - afuwin /O so I know it is the right rom for this system.

The Dell Community link in OP mentions the 2 roms. My 5555 is AAL12 which i confirmed by looking under memory DIMM as mention there. So I know that is the right BIOS for this system. These BIOS are used for 5455/5555/5755 - https://www.dell.com/support/home/us/en/…?driverid=gj54m

Untitled.png

untitled2.png

@kev - I assumed those commands lines might not all work without using the exe, I only added for you to check and maybe in case they could help. Last two are probably the non-compatible ones for use outside the exe.

That is not the correct rom for your board, did you see what I mentioned on my edit #2? Your system is test021, so you need to use that test021rom, I extracted it from the same EXE you and I both initially extracted the test010 rom from (That’s the rom you get using normal extract method).
The other rom, correct one that matches your system, can only be extracted with the tool that builds the exe packages.

I’m referring to extracting BIOS from the exe above, not your dumped rom (Sorry, I didn’t noticed you said dumped until i wrote all this out, thought you said extracted)

When you flash with the exe, without doing anything else, it would flash in the new test021 rom, not the test010 rom you get from extracting using other methods. Which is explained as you mention in the Dell forum link above.
This has nothing to do with .HDR file, HDR file is the same file as the rom you get from extracting using normal methods (test010). As shown in that page, last post on page one, the R00 file is the test010 rom same as extracting without AMIUCP.
The R01 is the test021 which is the BIOS for your system per the top section of the AFU details window in your images attached here (System info/details)

You should be able to flash stock exe anytime, run it and it will update as usual. Flashing a mod BIOS may either be done possibly by replacing the image in the exe with AMIUCP, or you may need flash programmer CH341A and a SOIC8 jumper cable / test clip.
Flashing using Intel Flash Programming Tool (FPT) may be another option, but I would get a CH341A setup arrived and verfified backup from it all working before flashing anything else.

If your goal right now is to only test stock BIOS, flash that exe But yes, I assume actual goal is mod BIOS, so try a single change, or simple edit, then insert into the exe with AMIUCP, then try flashing with that again.
I would not use dump for that, dump may contain things the BIOS flasher can’t use or doesn’t use, and or don’t know how to deal with since it’s unexpected. I would extract the test021 rom and edit that, then replace the stock test021 with your mod and try the flash.
As I mentioned though, I would wait for programmer and cable to arrive before doing anything further like this, that way you can recover if needed and not have to wait with down system for weeks/months while programmer is in shipping.

To insert or extract from exe, it’s shown on the Dell page you linked. Download AMIUCP and use the replace function. R00 is the wrong rom for your board (test010) and R01 is the correct rom for your board (test021)
Per your first image in post #3 @ system information section, Project version 021 and firmware ID test021 (This is current board info), bottom section shows input rom info, which shows wrong rom thus invalid BIOS ROMID

I ordered the programmers you linked in another post from ebay. Waiting for them to arrive.

Did you get the jumper cable/clip too? Hope so, and hope they arrive soon for you!

Be sure you get a verified backup saved from the programmer before you write anything to the chip, that way you are certain you have a valid copy of your UUID, serial, LAN MAC, etc.
Here’s some software versions for the programmers - https://www.sendspace.com/file/gtcmvd

Yes, ordered both from the ebay links your recommended. Thx for the tools.