Acer 4750G BIOS update corrupted BIOS

I recently updated my Acer 4750G to V2.19 I used the Phoenix UEFI Winflash v1.5.66 to update. After first boot to BIOS which shows succesfully updated to v2.19 but reboot will show me blank screen. While flashing BIOS I backed up BIOS using the Phoenix UEFI Winflash v1.5.66 which gives me about half the size of my BIOS chip. I have to use my CH341A programmer to flash. I am not sure how to use this half size backup file. Should I convert it to the normal size? Which tool should I use?
The BIOS file backed up by Phoenix UEFI Winflash v1.5.66 linked below.

Official Acer V2.19 BIOS
Any help would be appreciated.

@wizbee - what is BIOS chip ID, read it off the chip. Did you try clear CMOS, and then start system? Does anything show on screen at all, ever?
Once you tell me BIOS chip ID, I will tell you what software/version to use to dump the chip, then I will use that and your backup to fix a complete BIOS you will program back to the chip.

Thanks for your reply. I used BIOS you posted last year to make it running. Then I made a FreeDOS boot flashdrive copied files extracted from the official v2.19 zip file(DOS subfolder). I used the phlash command and option according to the FLASH.BAT file inside the DOS subfolder of the v2.19 zip. I flashed the previously backup BIOS file then I flashed the v2.19 ROM file name JE40219.ROM. I am not sure if this is the right way to fix. But it worked. The BIOS chip is Winbond W25Q32BV. Sometimes I got black screen I tried to clear CMOS by short the two pins of CMOS battery slot. I am not sure what is the issue. Please check the official v2.19 BIOS file, to be specific the FLASH.BAT. I see some options it used to flash and KBC offset options also. I don`t know what that means.

Blank screen here means no image shows on LCD and Power LED stays on. I have to long press the power button to shut down. Normally I only have to short press pwrbtn to shut down.

Pflash.exe /cvar /bbl /silent /exit /sv /sd JE40219.ROM
KBC /E 08 AA
KBC /E 00 54
KBC /E 08 11
KBC /E 00 c7

Btw I have failed executing the second line of KBC command. The KBC /E 00 54 command give me read or write error. What does this command do?

@wizbee - Nice to hear you have it working again! What software version did you do the successful write with?

Once running, just run flash.bat and let it update all that by itself automatically. You should not be messing with EC/KBC FW manually

Sounds like ME FW is messed up, what you mention about power issue, or could be due to invalid EC/KBC write etc. Reflash latest stock BIOS again using official stock exe in windows or DOS method (ie flash.bat)
If that does not fix things, dump it with programmer and send to me, I’ll update and clean ME FW to see if that will help. Did you have this issue ever since I fixed BIOS for you before, or only now?
It could also be due to mis-match BIOS and EC FW, since you are now using older BIOS version and some or all of new/old EC FW? Version 2.19? Really, that many updates since last year? I download stock BIOS then and it’s 1.24

I just checked, US and Indonesia site for BIOS on 4750G and neither have 2.13/2.15, and latest is 1.24 as mentioned above (expand, view all and look at the dates)…roduct/3520?b=1

So you may be trying to flash incorrect BIOS, or programmed in wrong BIOS, and certainly are manually trying to flash incorrect and old EC/KBC FW