Acer Aspire 3 A315-21G BIOS.bin

Hi there.
I would need the laptop BIOS.bin file mentioned above.
Acer Aspire 3 A315-21G
Thank you very much!

@mex2020 - What’s going on here? Are you recovering from a bricked BIOS? If yes, dump current chips contents and send to me, I will make a fixed BIOS for you that includes your original serial, UUID and MAC ID etc
Also, please link me to your exact models BIOS download page, thanks - Or confirm this one is correct - https://www.acer.com/ac/en/US/content/su…roduct/7304?b=1

Hello! @Lost_N_BIOS
Thanks for the reply!
yes the laptop you showed me.
The situation is that I want to inject an NVME.ffs file with MMTool but MMtool says it is wrong.
Based on this: [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS
Fault: fault
I have tried several versions of MMTool but each one writes bugs.
Maybe I couldn’t extract the .fd file from the .exe file?
I do not know.
.fd file 9.01Mb

@mex2020 - This is Insyde BIOS, so you can’t use MMTool… But, the main problem you need to solve first is how to flash in the mod BIOS, unless you have a flash programmer? If you have a flash programmer, send me dump of your chip and I will do the NVME mod for you.
.FD from the exe contains several files, you’d have to extract out the 8MB bin from that, but that is not how you should go about doing any of this, because you wont be able to flash mod BIOS with stock BIOS flash tools/method.
Unless you have a modified tool package from someone that you already know can flash in mod BIOS?

Since this is AMD system, the only methods I know that will work are old/risky AFU w/ /GAN method, or flash programmer.

Maybe @airstars can modify the stock Insyde flash tools content for us, so you can flash in mod BIOS?
If he will, here is STOCK modified 8MB bin with NVME mod from BIOS 1.25 - DO NOT FLASH THIS WITH AFU /GAN, you will loose serial, UUID, Windows ket etc, and possibly MAC ID

Never mind! This BIOS already has NVME mod added in stock BIOS @ 5BE3BDF4-53CF-46A3-A6A9-73C34A6E5EE3 (+ many other NVME related modules)
So, this BIOS is already NVME compatible, no mods needed! If you are not already using BIOS 1.25, flash to this using stock method, then you will be NVME compatible

Thank you very much for your help!
Yes I have a CH341A bios programmer.
I installed a 256Mb NVME ssd in the laptop and the windows can’t see it. I read in forums that this laptop does not handle NVME ssd. It has a 1.25 BIOS on it. You should handle this but not see the windows.
I formatted the ssd on another computer and then put it back on the laptop but it still doesn’t see it.
I don’t know what the problem might be but I’ll try samsung ssd tomorrow and I’ll write to you again. Because what I tried was a no name type NVME ssd.

@mex2020 - You’re welcome! Good you have programmer, everyone should have one But, it’s not needed here, stock BIOS is NVME compatible, so no BIOS mod needed.
Show me disk management screen with NVME installed. Have you tested this NVME in other system recently, to be sure it’s good/working? Ohh yes, good, you did this!
How did you initialize the disk, before you formatted it? NVME must be Initialized as GPT, not MBR, so this may be the issue.

Here is how to make NVME RAW again, so you can initialize as GPT, then format (Or, if you are trying to install windows to it, leave RAW and point the installer to the RAW ME)
Use diskpart in windows from OS (Direct from any CMD Prompt), or from installer ISO (press Shift + F10 on the first setup screen where you pick language)
Remove all other drives, so only the NVME is there, and any other disk you will recognize by size/name etc - so you don’t accidentally wipe wrong things.

At CMD Prompt >>

>> Diskpart
>> List disk << Here, identify by size, and then note the number which disk you will be wiping to raw here (If in windows, this #'s will match what you see the drives shown as in Disk Management) - Be sure you do not select your USB or main OS drive if in OS
>> Select Disk # << here, replace # with NVME # you want to wipe to raw.
>> Clean
>> Exit

Is there more than one place in laptop that you can install NVME? If yes, try other slot, maybe you are not using one it will work with?
Show me where you read this in other forums.

I found it here: here
Although as I see it in A315-41. Mine and A315-21g :smiley: I didn’t watch well :smiley:
I’ll do the diskpart formatting tomorrow.
by the way, you’re right because I formatted it in NTFS and MBR with windows installer on another computer.
I’ll try GPT tomorrow and write to you.
Thanks again for your help!

Yes, that is not same model. But, I checked it’s BIOS, and that one is also NVME compatible by default (at least with BIOS 1.18), and third from last comment by user says this at your link as well (Acer tech came to his house, said he could install 512GB NVME)
See image below, this is your stock BIOS side by side, so I could show both main NVME modules at same time + NVME Unicode/ASCII search too

NVME.png



Yes, MBR will not work with NVME, it has to be GPT - You’re welcome!
If it ends up not working, then we can try modifying the BIOS, swap out that NVMEExpress body with the mod NVME module, but the way it looks you should not have to do this.
Also, I forgot to mention, BIOS needs to be in UEFI mode, or at least storage rom needs to be set to UEFI mode or UEFI+Legacy

Hello.@Lost_N_BIOS
I tried diskpart today but it doesn’t seem that way either.
Picture: diskpart
What is there diskpart is a sata3 crucial 250gb ssd. But nvme is nowhere.

I put a samsun SM951 NVME ssd in it GPT formatted but I don’t see it either.

Should I send you the original bios and rewrite it?

Original Bios: 1.25

With CH341A saved bios from laptop: bios

@mex2020 - Sounds like this port may not be wired for NVME then, and may only support SATA M2 drives, not actual PCIE NVME’s. Did you try both slots, if there is two?
Not sure why they’d have NVME modules in the BIOS if system is not compatible. I can make you a mod BIOS to try, but sounds like this is not a properly configured slot for NVME
That SM951 may need Samsung module in BIOS before it would work? @Fernando could maybe confirm if that would be required or not. And for that model, I think there is AHCI variant, and a PCIE NVME variant?

What is your BIOS chip ID, and what software/version did you use to create the above dump? Just in case write back fails, so I can advise you what may be best to use
Here is four mod BIOS, any may brick, so be ready for recovery just in case - http://s000.tinyupload.com/index.php?fil…641218016686833
#1 - I replaced the body of NVMEExpress with the mod one we all use for NVME Mod BIOS
#2 - I removed the stock NVMEExpress module and inserted usual NVME Mod
#1-2a - Similar to #1-2, but done with another tool/method (PhoenixTool 2.73, Structure mod method only)

@Lost_N_BIOS :
The NVMe and AHCI variants of Samsung’s SM951 SSDs have different model numbers.
So the easiest way to find it out is to look at the exact model number. If the 3rd character of the PIN code starting with “MZ” is a “V”, it is an NVMe SSD, whereas it is a “H” on the AHCI variant.
Look here (upper SSD: AHCI, lower SSD: NVMe):

_MG_2809_678x452.jpg

The SM951 is the nvme. (SAMSUNG MZVPV128HDGM-00000) It’s on my desktop PC and I put it from there for testing.
But he doesn’t see it. I also thought that only SATA M.2 is what the acer 3 handles. But unfortunately I don’t have an ssd to try.
I unzipped the acer exe file with 7z and it contained this ZAS.fd.
Thank you very much for the modified bios files. I’m testing and writing today!
----------------------

Yes. The “V” indicates the nvme. What I tried on the laptop is the MZVPV128HDGM-00000.
Thanks for the reply!
----------------------

Hello.
I tried all 4 bios and it doesn’t work.
I think it only handles sata M.2 ssd.
Thanks for all your help.

@Fernando - Thanks! Do you think mod BIOS with Samsung would help here, or not?
I don’t see why there is several NVME modules in this BIOS (NVMEExpress and some legacy one) if BIOS is not native compatible with NVME!?!?

@mex2020 - You’re welcome, sorry to hear none of the BIOS worked for NVME Yes, it may be this port only works with SATA/AHCI type M2 drives?
So all four BIOS were bootable and OK, just no change in working with NVME, correct?

@Lost_N_BIOS :
The additional insertion of the Samsung M.2 AHCI EFI BIOS module will only help, if

  • a) the related M.2 SSD and
  • b) the related on-board M.2 slot
do support the AHCI protocol.

Thanks @Fernando - Yes, I think that is the ONLY protocol this M2 port supports
I guess waste of time to insert and test, since his M2 Samsung is NVME

@Lost_N_BIOS
Bios 1 and 1a did not give a picture. The screen is not turned on.
The other two bios worked normally but didn’t see nvme ssd.

Hola man espero que estes bien, tengo un problema con una bios Acer Aspire 3 A314-21 lo que paso es que estaba navegando en la bios porque tenia el problema que el ventilador no se apagaba junto con la laptop y quise revisar la bios, cuando de un momento a otro la bios se pego y reinicie la laptop pero esta ya no me daba imagen, me gustaria terminar de intentar montando nuevamente la bios pero no logro encontrar la original ¿De casualidad no me podrias ayudar?

Forum is ENGLISH language, the refereed user is no longer active forum member and dont need to post everywhere.

EDIT: You should correctly identify the motherboard and full laptop model, you’re probably need a CH341A SPI programmer.
Also should search for Acer laptop bios recover procedures, usually by USB blind operation, before trying SPI programmer
I need bios for Acer Aspire 3 A315-21G-962Y - Badcaps Forums

1 Like

thanks man, i really need help