acer aspire v5-571p 6815 bios password lockout

I’ve been struggling with my laptop for about 5 hours now.

It was working fine with Windows 8 and I wanted to reinstall the laptop to Windows 7 due to virus.

But pressing F2 didn’t get me access to Bios. I noticed that some Acer Aspire V5’s can’t access Bios as it’s hidden/locked so I was surfing webs to find solution and I stumbled upon this

“The Accepted Solution #1” says download the unpacked bios image then run it through the command prompt. Which I did and F2 did get me to Bios but I faced a really big problem. It’s asking for Bios password… I have never setup Bios password to begin with…

I can’t get past the Password/Unlock Key bios screen… I have tried disassembling the motherboard to pull out cmos battery for 5 minutes and didn’t work(I broke my screen doing this). I also tried shorting the password gap(G2201) and this didn’t work neither…

When I try to load OS normally it says "Operation System not found"

I’m stuck and I have no idea what to do… I’d appreciate help!!

Nvm, contact acer support I’d say.