Acer Aspire V5-591G Unlocking Hidden Tabs/Options in UEFI BIOS (InsydeH20) & Basic Learning Guide Of Disassembler!

!Greetings Dear Sir/Madam/Members/Administration_Team!-

Let me sorry for disturbing in first…


If possible please, then I need some advices/tips/hints and help maybe in case of unlocking “Aspire V5-591G BIOS ver.1.15”, Advanced/Power hidden menus and TPM settings locked menu!

In short…what I have done actually…and what I was tried now…

Yes,I have e-eprom programmer…

Yes I was successfully unpacked the bios firmware from main update executable…

And Then the bios main fd bin file loaded successfully without errors in UEFITool program…

In search menu of “UEFITool” was found GUID FE3542FE-C1D3-4EF8-657C-8048606FF670 …

Extracted (Section_PE32_image_DriverSampleDxe_SetupUtility_body.efi) …

With “IRFExtractor” extracted from (Section_PE32_image_DriverSampleDxe_SetupUtility_body.efi) file String Packages…

But there I’m actually stuck now…I don’t give it up,this is not about that…but I’m stuck…and I’m afraid that I’m on wrong way…So I was decided to make this topic instead of suffering

a lot without proper “boot kick/tips/hints”…

So…Now My problem is the assembler…I was able to load successfully file “Section_PE32_image_DriverSampleDxe_SetupUtility_body.efi” in IDA Pro…

But after that lost in machine codes…

Cannot figure out the next right step…somehow it’s not getting together logically…

Studied more materials publicly accessible from “donovan6000”…but I feel that there is missing data in that howtos or it is not a proper howto for my actual bios…

I think, it’s Just really a “quick guide” without proper details…

I understand that not every things are publicly accessible for some not possible discuss reason,but every of us know maybe why…nevermind…

I was understand that people must learn to handle data on discrete level…and respect others bloody hard work…

Assembler isn’t an easy job…take more years to learn it properly…

Some Guides Which Ones Examined For Getting to the proper way with all this unlocking stuff…

BIOS Modding: Introduction and Preparations…n-settings.html…power-tabs.html…g-settings.html…ead-8837-3.html…rse-engineering…n-settings.html…y-changing.html

[Acer V3-571G] How to unlock this BIOS (Advanced settings menu)? version 2.21

Acer VX5-591G Unlock Advanced Tab Bios (Insydeh20 rev. 5.0 bios)

Complete 8086 instruction set for IDA or Binary Ninja…


640a2aafb656ceaaec0dc6c21eda0f12 *

6c14b55a0833cb6c08b8296080d4c48a *BIOS_EXE.ZIP

692785ab04450518c6ec608e3006a025 *BIOS_FD_BIN.ZIP

Excuse Me For Grammatical Fouls!

Appreciate Any Crumbles of Tips,Hints and Help!


Have God Blessed Nice Day!

God Blessing To All!

Bye! (399 KB)














@_Ur1el - Hey! You’ve put some nice informational links there for others, appreciate the research and sharing of info there

Is this like the VX5-591G system you linked, same one or not, that I already showed how to unlock? Was that thread title a typo and it’s same BIOS/system here you have as that thread? Talking about the thread below
Acer VX5-591G Unlock Advanced Tab Bios (Insydeh20 rev. 5.0 bios)

If it’s same system, you can flash by FPT if you want, but you have to disable FPRR and BIOS Lock first via grub/setup_var. Or, if it’s easy for you, you can just send me dump, or dump BIOS yourself, then mod.
Do you want to know how to unlock, or do you want it done for you? For either, I need to know which of the above is your BIOS dump? And, please link me to this stock BIOS from Lenovo, the download page not the direct link

Yes, donovan6000 guide about this is a great start, but it does not cover all BIOS exactly, and not all bypassed menus look same in assembly, so you have to do it often on lots of BIOS before it starts to become easier to spot.
Still, some BIOS are terribly tricky, and I can never figure out I hate insyde BIOS

Also, about your IDA image, it’s much easier to view what’s going on if you use the flow view (usually hit spacebar at tab your on, but some areas may not show this)
This link shows IDA flow view like I’m referring to, I think donovan6000 main menu unlock guide shows that view too -…ead-8837-3.html

ONce you link me to stock BIOS, and tell me which file if any above is your dump, I will look at this for you and let you know what edits need made, and show you before/after in IDA so you can see how it looks
I’d use your setup above, and show you now, but I’d rather wait so I can get stock BIOS and put that with unlock info once I look into a proper folder so I can keep on my end for others later.


Thank You So Much For Your Fast Reaction!

!Unfortunatelly “VX5-591G” NOT THE SAME modell like “V5-591G”!

Acer Aspire VX5-591G Support Site…roduct/7094?b=1

…please just see the differences…

Acer Aspire V5-591G Support Site…roduct/6456?b=1

This is why I started this topic with new try unlock guide for this different modell…

But unfortunatelly stuck with assembler process…

And Yes,My goal is to unlock as I writed it in my previous post,Advanced and Power Hidden Menues and Greyed TPM options ENABLE/DISABLE posibility…

And at final round, write here down the step by step complette how been unlocked assembler/hex editing-flashing guide…etc…if its possible…

The Stock BIOS Unmodified Executable is atached in my previous post with checksum under "BIOS_EXE.ZIP"

But if You like and wish then I can link here again over the support site with download link to compare it with my atachment for been 100% sure to success…

Download Page For Stock BIOS Acer Aspire V5-591G >…roduct/6456?b=1

The (BIOS DUMP FD BINARI FILE) atached in my previous post under name (BIOS_FD_BIN.ZIP)

Thank You So Much For Your Time,Effort,Patience With me!

God Bless!


You’re welcome! It’s OK it’s not same model, and good to know it’s not, I was a little confused and thought maybe it was typo on other thread.
Hopefully I can find the lock for you, I can’t always, but lets hope it’s similar/same!

Any grayed out settings you can undo right now, in menus you can already see. that can be done by using the linked info you provided, or if you still are unsure I can show you a few examples of how to do that which I’ve posted around here.
Actually, here it’s this one you linked, towards end of post shows about ungray settings -…n-settings.html
Or, here, I’ve explained different ways (only use the “move end if” method, if you have flash programmer and are ready to recover, sometimes that breaks BIOS). I usually use the last method shown there, when some variable is used to control the suppress/gray.
Gigabyte Aero 15 OLED BIOS Unlocking and Modding Issue

Checking BIOS now, thanks for links and file clarifications.

*Edit - @_Ur1el - Sorry, I tried to find, but sadly Insyde has beat me again! . You’ll have to ask for unlock at forum, provide them dump and ask for unlock Dudu2002 will probably do for you
If you do get one unlocked, please send me a copy, in PM if you want, then I will inspect, find the locks, and then show you how/where etc.

Sorry if you get another tag’d PM about this, I accidentally deleted my reply, so had to add it back


If anyone is looking how to get into advanced menus on this laptop - you can actually access it without flashing/modding the bios.

Here’s how-to:

Get into the BIOS
Shutdown the laptop by holding the power key for few secs
Hold TAB and FN keys simultaneously (while laptop is turned off)
Press the power button
Release TAB and FN keys
Tap F2 to get into BIOS

That’s it. Two extra menus are now available.
Tested on 1.15 - newest BIOS available on Acer website
Sometimes it needs two tries to get it to work but eventually it will show the right thing.
Have fun!

@akrestix - Yes, that works on some models, other models have other hotkey/combos (sometimes)
What model do you have, and what type of BIOS (AMI, Insyde etc)?


Mine unit is V5-591G-53FA (based on Insyde 5.0), BIOS is flashed to the newest version from Acer website for this model (v1.15).

Hopefully this works on other models (eg. V5-591G-XXX), BIOS update exe has only one .FD file, so it looks like other variants use same BIOS.
But if this key combination is flashed in mainboard EC chip, it can vary between units. (Can’t find any mention of EC version anywhere), hope that Acer did not bother releasing new EC firmware version on units made after releasing X batch of laptops or key combination is only saved in BIOS. (Mine was made on 2016/03/01, so quite late for skylake gen, i guess)

Let’s see if anyone can confirm/deny that this method works on other units too.