Acer C22-860 R01-A4 CAP image from Acer does not flash

Tried this with Windows 10 SOP and EFI SOP failed as unable to select USB thumbdrive in boot menu.

Download is official from Acer Spectre & Meltdown Vulnerabilities webpage…vulnerabilities

Board is on R01-A3 with Intel MEI updated with that same download. Get error 10 - unable to load driver for AFUWIN64 in Flash.bat

Anyone tried this or know of problems with AFUWIN64.EXE (Googled it but found nothing)?

Cannot attach file as >6MB but on that linked page if you expand the Desktop section.

You may need to run batch as Admin?

For the USB issue, not sure how win10 or EFI affects things, most of the time for BIOS update via USB it must be on a FAT32 formatted drive and EFI boot may not allow FAT32 USB, may need to be GPT formatted.
Reading the PDF on that, did you key in your specific USB Location (fs5: in their example, surely different in your case)?

It’s always a driver issue, I am able to run the afuwinx64 from that download on my system, but sometimes I can’t older or newer versions, and sometimes I can/can’t the 32bit version either. Hard to narrow down, but that answer always is find a working version of AFUwin for your particular setup, or use AFUDOS instead (Suggested)

Here, try this newer version of AFUwinx64. Make copy of your current “Win” folder to keep original. Then copy/paste these two files in replacing the stock ones, then try batch again.

If you continue to have issues, just use AFUDos, I would do that anyway. Here is AFUDOS (Latest version, public download from full package on their site, same for above download all public on their site)

Make DOS bootable USB using this guide - <Request> Flagship X470 Gaming 7 Wifi Motherboard BIOS Fix
Copy AFUDOS.exe to the USB, along with R01-A4.CAP file from the rom folder
Here is the command to use >> afuwinx64 R01-A4.cap /P /B /N
If that gives error at capsule or security run this command >> afuwinx64 R01-A4.cap /CAPSULE /P /B /N

If you end up doing the above, you will still need to update the Intel ME included in that package. You can do this from windows, from command prompt that contains the files (Copy MEFW.bin to WIN folder, back out and select WIN folder hold shift and right click, choose open command window here)
Then run this command >> FWUpdLcl64.exe -F MEFW.bin -allowsv

Yep, tried as Admin, same error or fails to load CMD window (just briefly flashes on screen before exiting)

Drive is FAT32, did not get past Boot Selection as only Windows Boot Manager was offered.

Thanks for the d/l links, I will be sure to try those.

The silly thing is the MEI flash worked when the .bat ran first time!

Will post back, could be a few days though. I have also requested feedback from Acer regarding the issue so will update.

Did you try open command window from folder location, then run batch file (So it will stay open?)

Ohh, so you didn’t try new version afuwinx64 I posted above? If not, yes please try when you have time, and open command prompt at the batch file folder location then run batch, that way window stays open and you can see what’s going on, even if driver error. I can run your winguix64 here, but not other versions, so I think it’s something to do with OS or other drivers, not sure, I always have to try several until I can find one that works. DOS Is suggested though, much safer, less risk of a bad BIOS flash.

Since ME was updated, you wont have to worry about running that again

Opening the CMD window at the batch file location was the answer!

Did not try the newer file version. Have asked Acer to update the flash SOP documentation.

Many thanks!

(Still did not contain latest uCode;0x84 instead of 0x8E)

Glad you were able to finally get it! Maybe you can update/mod your BIOS with latest ucode and reflash?

Thanks. Image is Aptio V and using uCode replace function gives ‘Incompatible Filesize’ error.

This is using options 5,C,U on UBU 1.7rc7; haven’t updated from repositories in a while.

Edit: Tried updated UBU 1.7rc12.3; options 5,C,M same error.

Link me to BIOS you are using, and I will do for you. You want very latest ucode correct? For all ucodes, or only certain ones? I can do all if you want, might as well

@Lost_N_BIOS Thank you, it is an AIO system, unlikely to ever have a CPU replacement or upgrade.…

So basically, just the i3-7100U CPU ID 806E9 from 0x84 to 0x8E please.

You’re welcome! OK, I will do just the one microcode then, if you ever do upgrade CPU later you can always make new BIOS again.

You must have either been using wrong MMTool, or had wrong microcode or something? I use MMtool 5.02 Patched (only for compatibility with Aptio IV), and downloaded microcode from Github repo, deleted old version, inserted new, no issues.
Probably you were using old version of MMTool in the UBU folder? I didn’t use UBU, but MMTool directly, but I assume if wrong version in UBU folder you’d get the error you mention, unless using a different microcode than I used.

Right click download button, save as or open in new tab.
Popups/ads here get people sometimes, no need to enter credit card info or join anything etc!

@Lost_N_BIOS I used the wrong version of MMTool; it’s clear I have read the instructions too quickly and just assumed the higher version was good if patched.

Haven’t read up on the use of MMTool outside of UBU, so maybe that’s something I should do.

I used the highest version too, I assume same version you used (5.02.0024). Patched or unpatched does not matter in this situation

Did it flash OK?