Acer E5 571G 51DS Bios Unlock

Hello… @Lost_N_BIOS

I have been following this post and turns out I have identical laptop with @mhmt2
I want to unlock all d features. I can both dump and write from windows environment.

I have attached the screenshot of the cmd

Here is a link to my dumped bios:

My laptop Model Name: E5-571 Z5WAH
I would really appreciate if you could help me with a modded bios to flash…
Thanks in advance.

Screenshot (1).png

@solomonenakele - please edit your posts when you need to add more thoughts and no one else has replied yet, thanks
How do you have identical laptop with different model? 571 and 571G are not same, so I may not be able to unlock your BIOS, I will check.
Thanks for letting me know which your BIOS ID is, but since you have dump provided I don’t need anyway
Do you want this exact old version BIOS you posted unlocked, or do you want to update to 1.33 first and then send me new dump?

I just unlocked latest BIOS 1.33 for this model here, for your reference and anyone else later too (Since unlock was never confirmed in this thread by the OP) Don’t use that BIOS, only linking for confirmation of unlock OK
Microcode Update of Insyde UEFI BIOSes

Can you tell @winactive how you removed the locks so you were able to FPT flash, thanks
Or, maybe it’s only possible for you since you are on old BIOS and you didn’t have to do anything special?

I really didn’t do anything special, it just sorta worked, so I’m guessing its because am using an older bios…

that said, i would still want to stick with this my old bios…

I want this exact old version BIOS I posted unlocked

@solomonenakele - thanks, I suspected it may be due to older/different version BIOS, thanks. Sorry Winactive, I figured it was that
I checked, and this BIOS is only 1.32, so not really old compared to 1.33, but I didn’t compare dates so may be older than version seems to indicate. And, as I mentioned before, this is not same model, his is the A5WAB BIOS, so that must be the reason the security locks differ.

Here is your exact dump unlocked -

@Lost_N_BIOS bro… you’re awesome…!
It works…!

I have attached two screenshot.

on the cmd screen shot, you will notice the error 280.

so, actually, i ran into the 280 error, i tried the same command about 12 times but nothing changed… until figured something out… So now, i found a workaround for it…!

turns out the locks aren’t so locked after all…

there is a method to the lock madness, but it doesn’t involve any programing its just

I don’t know if it’s just my laptop or maybe its specific to my model or something, buh… it’s what worked for me.

Screenshot (2).png


So this is what I did.
*Restart ur pc
1. Open Command Prompt
2. Dump ur Bios with command "FPTw.exe -bios -d biosreg.bin"
3. Send it to @Lost_N_BIOS (awesome bro.) to unlock for you…
4. Flash it with command "FPTw.exe -bios -f name-of-modded-bios-file.bin"
That’s it… It ought to work at this point.
But if you run into 280 error like I did… try the following.
1. input the flash command on cmd (“FPTw.exe -bios -f name-of-modded-bios-file.bin”), but don’t press enter yet.
2. put your pc to sleep(not shutdown or hibernate) for 5mins or more.
3. when you wake your pc, the first thing you do is press enter on the cmd and it will flash successfully…!

This method sounds too easy and less techie buh, it was how i got past the 280 error

note my bios version is 1.32, windows10 1903 (may 2019 update) intel core i3, 12gb ram. am on secure boot uefi

If you run into any problems with “audio device not found” just restore default in bios and it should fix that problem.

Pls for anyone to try this… do let us know if it worked for you or not…

Special Thanks to @Lost_N_BIOS for unlocking the 1.32 bios… It works…!

@solomonenakele - thanks for quick report back on this, and you’re welcome!! Great to see it all unlocked, only two bytes to edit to unlock it all

Error 280 is SMI/SMM lock, this guide gets you around that - [GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash
Alt boot to grub when no boot to EFI on exit page - [Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN (2)

I know BIOS lock is enabled by default, but if I knew you had this issue I would have modified that also in the mod BIOS I sent you, so next time around it would already be unlocked.
Sorry I didn’t think to check since you said no issues previously flashing

And yes, some BIOS have the S3 security sleep bug, thanks for posting that here for others! And thank you for the how-to guide for others as well


For those of interested in learning how a bios unlock is perform do you mind if you could please explain how it’s done?

Thank you

@davidm71 - for many Insyde unlock, this guide will help get you there -…power-tabs.html
I hate Insyde BIOS, so it’s not my usual thing and I can’t easily write out a guide or anything like that. If you are familiar with IDA I can show you were the edits are done in the IDA flow charts, but once you find this it’s only a two byte edit in hex on the setup module body (one for each menu, to not bypass/lock them)

Here’s the actual edit done on the BIOS above
00000000000014A9: D5 >> Change to >> 00
00000000000014DD: A1 >> Change to >> 00

Thanks for the link. Going to print it to pdf so not lost in time. Wondering though if you know of a guide for standard AMI UEFI style bios structures? Presume just use AMIBCP?


@davidm71 - You’re welcome. It doesn’t work on all Insyde, but it helps with plenty. There’s a few good python scripts and methods for Insyde editing at links below too.
Some of the files you’ll want, you need to go forward/backward on the guide to get the best python files to use with the methods mentioned (or let me know I’ll send you if you cant find them)…efi-boot.23762/…aks-done.27730/…393606/page-23

As for AMI, I’m not sure what you mean there? But generally, no, I’ve not found any good modification info for AMI, that bit you see in my guide on Tonfang is best modding info I know for Aptio V,
Aptio IV can be similar to that method a little bit sometimes, but usually it’s more setup module edits or AMITSE/SetupData modifications (AMIBCP)

I meant in regards to non-insyde type bios files. My interest in this topic is purely academic. Want to learn. I appreciate the links you have provided and will check them out! Will also PM you later… Thank you.

Yeah, not too much good info out there in once place or in any guides that I’ve seen for AMI If you find some on modern AMI let me know, I like to learn BIOS mods/methods too, thanks!
Rebelshaven is a good source for old AMI info, but it’s hard to find good links to archives of many pages there now.

I will return the favor if I find anything. Thanks.

@Lost_N_BIOS -You’re Welcome Bro…

Hello… @Lost_N_BIOS

I have the same problem too, after updating my bios I was asked to enter a password, which I don’t know. I have an identical laptop with @mhmt2
Please, can you help me, I want to unlock my bios too

link to my dumped bios:

Model name : E5-571G
Product name: Z5WAH
Thank you in advance…

@shino246 - I don’t know how to remove BIOS passwords, and that is not what mhmt2 made this thread about, if you need help with password removal you’ll have to ask at forum.

If you get error # or code on screen, you can try sites like these too

@Lost_N_BIOS - Thank you for taking the time to answer me.

But what I don’t understand is that my Bios didn’t have a password before, it’s after updating it that I get this message.

See the images below :

Hi, my english is bad but everyone please help me

I want unlock my bios

Acer E5-571 Z5WAH

My bios model Insydeh20 v3.7

My laptop bios:…CP1&LC=en&OS=BC _ga = 2.153602168.11048773.1585470315-329559381.1585470315

Mainboard Model: Acer EA50_HB
BIOS Version: 1.32

Thank you so much
Have a good day

@shino246 - what BIOS did you flash? Sounds like you maybe flashed someone’s BIOS that has password on it? You can try this password and see if it lets you in to then blank out current pass
Insyde H2O BIOS (Acer, HP) - 31758401

@minhquang47 - I can and have unlocked your BIOS, but you need flash programmer to dump BIOS and send to me, then I edit and you program back.
You need CH341A + SOIC8 test clip with cable, if you need linked examples of these items let me know.