[GUIDE] Acer E5 571G 52B7 Bios Unlock Advanced Tab

Hi everyone, I’m here to say that a i’m glad to make this unlock just following the guides in this forum and I’ll show how to do it.

* The credit goes for them: @Lost_N_BIOS , @pohd , @solomonenakele

My Setup:
- Notebook Acer E5 571G 52b7
- intel i5 4210U
- MotherBoard: EA50_HB
- BIOS: Insyde Corp. 3.7, System V1.32*

Disclaimer:
* I’m not a expert/professional in this area, just a curious who does done tutorials in the right way.
* This tutorial is intend for this notebook only (Acer E5 571G 52B7) but my guess it works in all “Acer E5 571G xxxx” versions and I’ll will show you why later.
* Do this at you own risk, modding the Bios can brick you notebook !!
* If the links doesn’t work just google the softwares.
* Download and Install the latest version BIOS from the Acer website.




Q: Why I wanted unlocking the Advanced tab on BIOS?
A: To make my eGPU setup works by disabling the dedicated GPU on the notebook! which actually works

Q: Do I need some external tool like CH341A programmer?
A: No need if you follow this tuto right, but if you reach brick, you will!


Tutorial

0- Tools/Softwares: https://www.sendspace.com/file/11umup


1- Overview:
Basically what you’ll do is: dump your BIOS, edit 2 values, rewrite you bios and pray when you reboot.

2- Dumping your BIOS:
- Software: Intel ME System tools package V10.0 r6.
- Unzip, and inside you will find several folders. Go into the Flash Programming Tool folder, inside there select the Win32*(or 64) folder, hold shift and press right click, then choose “Open command window here”.
In the command window type the following command.

FPTw64.exe -bios -d biosreg.bin

- The “biosreg.bin” is created, make a backup!


3- Editing “biosreg.bin”:
- Software: Phoenixtool273 or UEFITool_0.28.0

- Using this Quote as a guide:



- Unzip phoenixtool273.zip, open PhoenixTool.exe:
- In Original BIOS, choose your biosreg.bin
- Click on Structure:
- follow/find this tree:
.File Volume
…DXE Core
…Compressed Section
…Raw Section
… File Volume
… DXE Driver {xxx} - Setup Utility
…GUID
…PE32+ image Section *(line)
- Click on the line and hit Extract, check if it was created a file “xxx.MOD” on your win32/64 Flash Programming Tool Folder
- DON’T CLOSE THE PROGRAM.
- Install and open a Hex Editor (HxD).
- Open “xxx.MOD” on the HxD.
- !!! Now is hardest part, because for me the line on the Quoted message from @lost_N_BIOS just don’t matched, but I used a near value line as a ref.

000014A9(quoted message);000014A0 D5 >> Change to >> 00
000014DD(quoted message);000014E0 A1 >> Change to >> 00

! But why I knew it was 14A0 and 14E0? because this lines have the corresponding D5 and A1 values!!!
! Thats why I guess this lines is commum on the Acer E5-571G-xxxx versions
! yeah I’know, very Macgyver, just follow the rest tuto.
- in HxD, save the file.
- In PhoenixTool hit Replace on PE32+ image section, and choose xxx.MOD file already changed in the HxD.
- Save Changes, close Phoenix.
- Now your “biosreg.bin” are unlocked.

4- Rewriting the BIOS.
- Go to Flash Flash Programming Tool Folder.
- open cmd(admin) in this folder again.
- Do the Code:
!!! This code will rewrite your BIOS, the also called, The Brick part !!!

FPTw64.exe -bios -f biosreg.bin

- If appeared a 280 error, just to this quoted guide:


- yeah another Macgyver move, but the thing is that worked for me.
- wait for the code works rewriting your BIOS, after finished close the CMD and reboot or shut your system.
- Startup pressing F2 to acess BIOS.
- That is it, Advanced Tab or black screen.

5- Final Conclusions:

- It’s worked well for me and that’s why I made this tutorial, maybe will help someone, but cannot go really good for you and if happens to brick your notebook you are warned.
- If you are making a eGPU setup, DON’T disable Internal Graphics.
- Leave a comment if it’s worked.

Thanks, it works even in Russia! Да, я русский. Спасибо что воспользовался переводчиком или выучил русский язык. Модель ноутбука совпадает с вашей. Осталось только придумать как бы доработать ноут.

Hey man!
I just made an account to thank you! I have been looking everywhere online to see if I can enable the advanced settings…

Thanks to your tutorial, I have finally enabled those settings.
Thanks a lot for writing this tutorial !