Acer E5 571G 51DS Bios Unlock

I finally succeeded realy realy i learned.
really did but it was difficult.


I gave you simple direct way to do it Thanks for file I will now check and modify it for you.

While you wait, and so I know if I need to give you directions to unclock, please test writing back to BIOS that same file you dumped using command below
FPTw.exe -bios -f biosreg.bin

If you get error 368 cannot write to BIOS space, you will need to follow my guide here to unlock, you only need to pay attention to step #6 onward. - [GUIDE] Grub Fix Intel FPT Error 368 - BIOS Lock Asus/Other Mod BIOS Flash
If your BIOS does not have launch to EFI shell on the exit screen you will have to use this generic boot to USB grub method >> [Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN (2)
Here is the variable you need to use at grub >> 0x4AB

Once at grub prompt you will type the following, this will disable BIOS Lock and you will not get error 368 anymore in FPT >>
Setup_Var 0x4AB 0x0

I got the following error

I expected that, different error number though, but that’s OK. Do as mentioned above, show me an image of the grub screen after you enter command, then try again.

I can’t find the code you gave here.


I never gave that code/GUID? Please read again what I wrote above, I already gave you the variable you need to use, you do not need to open UEFITool for anything.
And, in the guide, I do not specify anyone to use that GUID, I said "Find "Setup Module" In this instance, the GUID is" That changes for all BIOS, and even for that particular board it may not be same GUID between BIOS versions.
Sorry for any confusion there, I assumed you seeing me say start at step #6 and here is your variable to use would send you on your way to grub pretty quickly.

okey understand you

Did you get it yet? Hope so, if you haven’t started again yet, good luck, I’m sure you will get it!

well, What should I do now? to turn on the bios advanced.

should I wait for you to give the unlocked bios file or should I do it myself?

I didn’t get that point.

Do it yourself? Calm down Flashing and modifying BIOS is not something you rush through or rush to do quickly, please be patient. I have BIOS ready, but it will not help you until you are done with things I mentioned first, otherwise you cannot flash it.
Flashing mod BIOS is not easy on your system, due to Intel protections, unless you can show me some other package someone else already modified Intel flash tools, dll’s, ini, and sys files from the stock packaged exe for your same board/BIOS.

Also, you may need to flash a few BIOS, so get used to process, if I need to unlock more items in next 2-3 mod for you.
I cannot tell what you can see and what you cannot, and I can’t blindly enabled everything or it will break, so may take a few mod BIOS.

We are still at this step, did you get the grub command entered yet (Setup_Var 0x4AB 0x0)? If yes, now try to write back your backup again using command below
FPTw.exe -bios -f biosreg.bin

If any errors, show me command entered and error, stop there and do not proceed.

okey i will try everything you say.

have a good day.

Yes, these steps need completed before you can flash modified BIOS

1. grub command entered yet >> Setup_Var 0x4AB 0x0 (How to, info is posted in post #22)

2. Then write back your backup again using command below
FPTw.exe -bios -f biosreg.bin

‘’ Error 280: Failed to disable write protection for the BIOS space !. After writing, I need to enter the code on the command screen.

sorry english is not very good.

You have to do grub command before you can use FPT to write to BIOS region >> Setup_Var 0x4AB 0x0 (How to, info is posted in post #22) Did you do that first?
I’m not sure what you mean by “After writing, I need to enter the code on the command screen”?

Hello… @Lost_N_BIOS

I have been following this post and turns out I have identical laptop with @mhmt2
I want to unlock all d features. I can both dump and write from windows environment.

I have attached the screenshot of the cmd

Here is a link to my dumped bios:

My laptop Model Name: E5-571 Z5WAH
I would really appreciate if you could help me with a modded bios to flash…
Thanks in advance.

Screenshot (1).png

@solomonenakele - please edit your posts when you need to add more thoughts and no one else has replied yet, thanks
How do you have identical laptop with different model? 571 and 571G are not same, so I may not be able to unlock your BIOS, I will check.
Thanks for letting me know which your BIOS ID is, but since you have dump provided I don’t need anyway
Do you want this exact old version BIOS you posted unlocked, or do you want to update to 1.33 first and then send me new dump?

I just unlocked latest BIOS 1.33 for this model here, for your reference and anyone else later too (Since unlock was never confirmed in this thread by the OP) Don’t use that BIOS, only linking for confirmation of unlock OK
Microcode Update of Insyde UEFI BIOSes

Can you tell @winactive how you removed the locks so you were able to FPT flash, thanks
Or, maybe it’s only possible for you since you are on old BIOS and you didn’t have to do anything special?

I really didn’t do anything special, it just sorta worked, so I’m guessing its because am using an older bios…

that said, i would still want to stick with this my old bios…

I want this exact old version BIOS I posted unlocked

@solomonenakele - thanks, I suspected it may be due to older/different version BIOS, thanks. Sorry Winactive, I figured it was that
I checked, and this BIOS is only 1.32, so not really old compared to 1.33, but I didn’t compare dates so may be older than version seems to indicate. And, as I mentioned before, this is not same model, his is the A5WAB BIOS, so that must be the reason the security locks differ.

Here is your exact dump unlocked -

@Lost_N_BIOS bro… you’re awesome…!
It works…!

I have attached two screenshot.

on the cmd screen shot, you will notice the error 280.

so, actually, i ran into the 280 error, i tried the same command about 12 times but nothing changed… until figured something out… So now, i found a workaround for it…!

turns out the locks aren’t so locked after all…

there is a method to the lock madness, but it doesn’t involve any programing its just

I don’t know if it’s just my laptop or maybe its specific to my model or something, buh… it’s what worked for me.

Screenshot (2).png