Acer F5-572G laptop doesn't wake up from sleep mode on Windows 10

Hello all,

I’m absolutely new here and after 3 days of ineffective research of my problem I found this forum and decided to write here as I see only here I could get help. :slight_smile:

Recently my laptop stopped to react when I’m trying to wake it up from sleep mode when it’s plugged. When I use it on battery power there is no such an issue, it wakes up without any problem. I started searching for where the problem comes from and I’ve noticed some critical system errors and warnings in the Event Viewer which I will post below with my system configuration.

Since I’m working on a project I need my laptop to work properly and it’s a big annoyance and discomfort to force restart it every time I go to the kitchen for 10 minutes and the laptop goes to sleep mode and I don’t have a chance to wake it up.

I have already tried every advice I could find in the web coming across the forums - reinstalled all my drivers (including Intel Graphic Driver and Nvidia, Chipset, Inte I/O drivers), was playing with power options, tried to turn off IRST’s Link Power Management option without any effect.

My system conf.:












I really hope you could help me to resolve the problem.
Thank you in advance!

Edit: Forgot to mention that I flashed my BIOS to the latest version from the updates suggested on the Acer’s website product’s support drivers section. I didn’t have this problem before, also it hasn’t appear before I installed these updates for my BIOS. I bought this laptop this winter and as I remember I noticed this problem only once for the whole period till now. I’m confused to assume if the problem comes from the BIOS updates or some driver conflicts.

I installed all these BIOS updates from the official Acer’s website:


From MEInfo and MEManuf got following:



The problem does not look like it is ME related. Probably the latest BIOS update caused it. I suggest you contact Acer support.

How do you think is it safe to downgrade my BIOS to the oldest version provided on the Acer’s website and monitor the situation for a while before I write them?

Did you try disabling Fast Startup option in Power Options (accessible in Power Options > Change what lid button does…) ?

To downgrade try if there is an option in BIOS, otherwise use Acer’s utility etc. I don’t recommend anything else in case the EC also needs to update/downgrade. Try resetting BIOS settings. If these don’t help, I suggest Acer support and hopefully they’ll be helpful.