ADATA SX6000PNP on a PCIe NVMe adapter

I have a problem with the ADATA SX6000PNP disk on a PCIe M.2 Delock 89455 adapter or another Chinese for 2 dollars.
I did tests on 3 different models of this disk.
When I did tests on other disks extracted from Dell laptops like WD PC SN520 or Hynix BC501 everything works fine.

The problem is manifested in the fact that once in a few times the BIOS does not turn on, only the fans spin, no BIOS squeak and no P.O.S.T BIOS view
Any ideas why this is happening? I have rewritten the BIOS twice and nothing helps, maybe I put the module wrong, but when the BIOS gets up, the Windows system loads correctly.

The motherboard is Gigabyte GA-X79S-UP5-WIFI rev 1.0.

I set up a separate topic, previously reported about the SX8200 disk and this is it SX6000PNP
Guys, any idea? @Vincent12 @Fernando

@pako :
If you want, that anybody shall check the integrity of your recently flashed BIOS, you should post links to the original and your modded BIOS (as *.ZIP or *.RAR archives).

Below is the link to the original F4 BIOS, as you can add the NVMe module to this bios. I don’t think I’m doing something wrong because it’s a simple instruction but it’s worth checking out.…

Thx for the link.
Could you also attach the modded BIOS?
Sry to say, afaik Fernando doesn’t mod BIOS for others, he told, but he checks edited firmwares from people, if they are modded correctly.
(The reason behind this is, when more or less everyone would ask him to do it, and he did it, then noone/only few people would use his guide, and when he’s not in the mood at some time, occasionally some people affected for this time, would be jealous he didn’t do it for them, as he had done for others, sometimes, so to avoid enviosness, possibe disputes, and it would be more time consusing for him, and results less energy to help where he can/want).

Could you also attach the modded BIOS? Thx

Sure, I’m adding two BIOS versions.…iew?usp=sharing

@pako :
Here are the results of my check:
1. Your modded F4 BIOS seems to be correctly modded, but why did you insert the "small" variant, although there was enough space for the normal NvmExpressDxe_4 module?
2. Regarding the F5 BIOS I got a slightly different result than yours. I inserted the uncompressed NvmExpressDxe_4.ffs module by using the AMI Aptio IV MMTool v4.50. Which module variant and which BIOS tool did you use?

It seems to me that now I have the F5 BIOS uploaded, previously I had the F4 version full and small on all the same thing happened. As you can see the files were compiled a few months ago, I came back to enable NVMe now.
The computer was at work so I will upload a new BIOS after the weekend.
Below the new BIOS prepared in MMTool I used UEFITool_v0.26.0 before
The BIOS will read the new file without any problem? Fortunately, the motherboard has dualBIOS :slight_smile:…iew?usp=sharing

@pako :
This modded F4 BIOS is ok (absolutely identical with the mine).

I will test this version after the weekend and let me know.
Is there any difference in the modification of this bios in mmtool and uefitool?

@pako :
I just have compared the hex code of the F4 BIOSes, which had been modified by me with the MMTool and the latest UEFITool. They are identical.

After changing the BIOS still the same.
I did a test with an NVME disk attached and no BIOS modification and the same problem.
The idea why? With an empty adapter is OK.
I tested on PCI X4 and X8.
Maybe the C606 chipset problem?

@Lost_N_BIOS -N here is the answer to your question

@pako - sorry, not sure what question of mine your above posts answers. To me, both disks same, same brand, same issue, different size and variant is all, this should have been all same topic to me. Then maybe, only maybe, I wouldn’t be lost

Did you test all four PCIE slots? With all other drives removed from the board? Move your graphics card too, so you can test in first slot. Also, test with another graphics card if you can, in case some odd conflict
Did you test this NVME drive + adapter on other boards, and it’s OK there?

You may have to contact Gigabyte directly, they can and will test with that exact NVME drive (probably not same adapter, but similar cheap one probably, this shouldn’t matter though)

When you mentioned F5 beta, you do mean F5f correct? If yes, OK, if not, download that one and try (it’s last beta)
Also, always be sure you are starting in BIOS by loading optimized defaults, then reboot back to BIOS and make any other changes you need.

I’ve probably checked everything on this board, swapping PCI slots, disconnecting all necessary things, replacing GPU, RAM, and power supply.
Still the same. The disk adapter runs without problems on other computers.
I found the POST diagnostic card PI0049B from If the computer does not turn on it throws error 94 or 96 every time and it hangs.
An explanation of errors in the attachment, but it doesn’t tell me anything, maybe you have an idea?

In all other respects, the computer is working properly.…iew?usp=sharing…iew?usp=sharing

I guess I will buy a different disk model and see if it will be the same, but I don’t want another broken disk :frowning:
I wonder the disk with the Phison E12 controller

94 Final Processor and Chipset initialization
95 program daylight saving, update keyboard LED & typematic rate and default Numlock setting
96 build MP table, build & update ESCD, set CMOS century to 20h or 19h, load CMOSD time into DOS timer tick, build MSIRQ routing table

As I mentioned, contact Gigabyte directly in email, they will have your exact NVME drive and will be able to test it with this exact board, and then fix a BIOS for you

Did you try with Windows 8 setting set to other OS and Win8, along with with CSM enabled and disabled for both Win8 options (So, four possible configurations to test with these two settings)

Also, I would set this >> Other PCI Device ROM Priority << To Legacy and try as well (with the above mentioned 4 possible settings configurations)

I would also disable Marvell controller while you test >> Peripherals >> Marvell SATA Controller Configuration >> GSATA Controller << Disable

Updating all 6 RST related BIOS Modules may help as well? I checked F4 BIOS, and it has the following
EFI Intel RST for SATA -
OROM Intel RST for SATA -
EFI Intel RSTe for SATA -
EFI Intel RSTe for SCU -
OROM Intel RSTe for SATA -
OROM Intel RSTe for SCU -

@Fernando - is any of the above known to need to be updated for NVME functions ever?

I would be very surprised, if the update of any Intel RST/RSTe BIOS module would have an impact on the function of a non-Intel NVMe Controller.

Yes, I guess this would be true, but I wasn’t 100% sure

No changes in the BIOS help, tested on the original BIOS F4 and F5.
Success is 3 correct boot but the fourth time error 94/96.
I don’t know if this is normal but in the case of Windows8 I can not turn off CSM. After setting disable automatically the option will be enabled.

We will not think of anything anymore?
So I’ll buy a WD SN520 drive that works correctly on this board.
Evidently this set cannot work properly.

Windows8 setting would automatically do that if you have secure boot disabled, or one of the other things I mentioned set to Legacy

Some setting I assume, sorry I can’t test this myself here and help you to figure it out. I could buy one of those NVME no problem, and already have the SX8200 one, but I can’t afford to buy one of these X79 boards (even if they were still selling for $200 which they are not)

Please email Gigabyte and have them test X79S-UP5 + SX6000 and separate test with SX8200, they will do it and send you image of testing results, or a fixed BIOS with images of success once they sort it out.

I bought the PNY XLR8 CS3030 drive, everything is O.K for 30 computer turns on :slight_smile:
Evidently that combination did not like.
Today I will put the system on a new disk but on a converted BIOS, it will boot from another disk without any problems.
Thank you guys for help, I hope I won’t have to add anything to this topic :slight_smile:

I’m not convinced that Gigabyte will take care of my problem … So I will sell the disk and buy the SX8200pro for testing.