ADATA XPG SX6000 NVMe SSD Not Reaching Full Speed

Hi guys,
Recently i updated my Asus Gl504GW with and ADATA XPG SX6000 NVMe SSD
and running some benchmarks test my write speed gets only 750 MB/s , supposed to run at 1500MB/s
I tried the same ssd on a Desktop , and the wrinting speeds are getting 1500 MB/s,
the same happens to read speed, aways at half of full speed (see screenshot atacched)
So the problem is not the SSD.
There is any driver or config that i can try to make it works at full speed on My GL504GW?

ADATA SX6000PNP_1024GB_1GB-20200829-1646.png

@chadalu :
Welcome to the Win-RAID Forum!
Which OS and which NVMe driver are you running? Did you test any other NVMe driver? Did you read the start post of >this< thread and followed the NVMe related advices?
By the way - we don’t like it, when
a) the thread title contains only capital letters and
b) the post is full of unneeded blank lines (takes too much space).
Dieter (alias Fernando)

Sorry for capital letters and blank spaces, already fixed it
Im running Windows 10, and using the generic 10.0.19041.1 that comes with windows
It is a fresh install of windows 10, i ill look up to driver on the thread that you give to me , and report you back
(ill take some time , it is a lot to read)


1- Notebook only have 1 Port
2- SSD firmware on latest version
3- Notebook Bios on latest Version
4- Brand New SSD
5- Fresh windows Install
6- Instalet latest Intel RST
7- SSD detected as solid drive state
8.1-Updated my AHCI controler driver, it is a intel 300 series (didnt know, just discovered) - speed didnt change after this, still half
8.2- Update my default controller nvme express, using the samsung one with certified (installed sucefully) but speed still the same
9- Enable both options on write caching
10 - Disabled LPM
11- Notebook on High Perfomance

No sucess, still slow

I had a similar issue where mine wasn’t hitting the benchmark numbers unless it was on a separate slot and not as C drive. Hope you fix yours