Adata XPG SX8200 NVMe, Windows 7 64bit and S.M.A.R.T.

I’ve been wondering about this myself.

I’m using an Asrock z370 extreme4 with the same NVMe drive, the Adata XPG SX8200NP and w7. I slipstreamed in the MS driver during install and it’s showing up under the Adata device in my device manager is a Microsoft driver dated 2006 (ver 6.1.7601.19133).

Of course, ADATA has no driver available and using their SSD toolbox, the model, firmware number, or firmware version does not display, It shows a warning for the drive health, and the temperature reading is 65263c. But at least the TRIM command works within the tool.

There has to be something out there that will work newer than 2006…

@Lioninstreet :
Welcome to the Win-RAID Forum!

1. If you want to know the driver, which manages the function and speed of your NVMe drive, you should not look into the “Disk Drives”, but into the “Storage Controller” section of the Device Manager, do a right click onto the listed NVMe Controller and choose the options “Properties” > “Driver” > “Driver Details”.
2. You should not believe the MS driver dates shown by the Device Manager. The Device Management doesn’t check the date of the real driver (= *.SYS file), but just reads the date, which has been written into the associated textfile named *.INF. The *.INF files of all MS in-box drivers contain the misleading date 06/21/2006, no matter when the real driver (= *.SYS file) has been compiled.

Regards
Dieter (alias Fernando)

@Fernando :
Thanks for the welcome and the PM. IMHO, yours is the best resourse on the web for this kind of thing

My storage controller does show a standard NVM Express controller v6.1.7061.23403 is installed. Can you direct me to where it is stored in w7 so I can possibly find out what it really is

@Lioninstreet :
All drivers (=*.sys files) are stored within the C:\Windows\System32\drivers subfolder.
The name of the generic MS NVMe driver is stornvme.sys.

Found it dated 3/25/16. At least it’s only a few years old instead of 12. I figured something was wrong since NVMe was just a glimmer in someone’s eye back in 2006…

Looking forward to see how this plays out.

The MS NVMe driver has the same age as your currently running OS.

Any chance the w10 x64 driver is compatible? I checked it on a w10 system I have and it’s dated 6/5/18 (v10.0.17134.81)

Compatible with what? The MS in-box drivers can only be used with the stock OS.

compatible with w7 x64?

Today I was able to do the announced TRIM tests.
Test machine: Xiaomi Air 13.3 notebook
Test NVMe SSD: 256 GB Samsung PM061 NVMe SSD
OS: Win10 x64 v1809

Tested NVMe drivers:
1. Generic MS Win10 v1809 in-box NVMe driver
2. Samsung NVMe driver v3.0.0.1802 WHQL
3. Generic OFA driver v1.5.0.0 mod+signed by me
4. Generic Intel RST NVMe driver v16.7.1.1012 WHQL

Results: All tested NVMe drivers do support TRIM.

Proof:

Trim check result MS stornvme.png

Trim check result Samsung NVMe v3.0.0.1802.png


[[File:Trim check result OFA NVMe v1.5.0.0 mod+signed.png|none|auto]]

Trim check result Intel NVMe v16.7.1.1012.png

Trim check result OFA NVMe v1.5.0.0 mod+signed.png

Hello folks. I just registered after desperately trying to find a resolution to my issues with the same ADATA drive that I just purchased.

Like @Lioninstreet , the ADATA SSD Toolbox displays a ridiculous 65263 celsius temperature. My SMART details are also all empty. I’ve tried updating the firmware through the toolbox, but it just takes me to the main ADATA website which doesn’t host firmware or drivers for this drive(???).

I’m running Windows 10. The NVME driver listed in Storage Controller is 10.0.17763.1.

I’m at a lost for how to fix this if it’s indeed a software issue. I’d very much appreciate help.

@Arsenic13

After sending them numerous screen shots and log files, I was told the following by ADATA:

After consulting with our engineering department, we have been informed that the SSD Toolbox will not display disk information of the SX8200 properly in a Windows 7 environment due to the lack of a native NVMe driver. Unfortunately, we have also been informed that the SSD Toolbox will not be updated for such. It is suggested to upgrade to Windows 10 and install the native NVMe driver in order for the disk information to be displayed correctly.

They are cutting corners by using the native w10 drivers instead of creating their own. Same situation for motherboard drivers, the OE’s are depreciating out w6.1 already so they don’t have to spend the R&D $$ to keep them up to date. What ticks me off is with the newer chipsets, for the most part they have pulled them down from their sites too… (don’t get me started).

You might have better luck getting an answer out of them since your not running a OS that’s EOL…

If you do I’d sure like to know what they told you.

@Lioninstreet

That sucks. What did you end up doing?

I’m waiting to hear back from them now. I asked Amazon for a replacement but if it’s a software issue then this might continue. I’ll need a solution.

I’m baffled that their app doesn’t actually link to any firmware updates.

It appears I’m stuck with what I get as long as I use w6.1

Their earlier versions of the tool don’t support the SX8200, I tried that too. Seems like that’s the compromise with Adata instead of ponying up the extra coin with $amsung.

You have no other issues with the drive, though, right? It’s just the ability to read its SMART info and temp?

Hey Fernando,

Thanks for the TRIM tests you made.

If you have time please do the same tests but under Windows 7 64bit - because there is a driver problem with TRIM support and/or displaying SMART attributes. In my previous posts I repeatedly reminded that I use Windows 7 64bit.

Kind regards,

@yac :
All my systems are running Win10 v1809, so following your request would mean, that I have to do a fresh install of Win7 onto an NVMe SSD just to find out, whether TRIM is supported or not (I don’t have any doubt, that it is supported).
I am spending each day a lot of my leisure time trying to help Win-RAID Forum members to solve their problems, but I am not willing to do that,
Why don’t you do the related TRIM test yourself? It is very easy and the related TrimCheck tool is offered >here<.

I already made the tests. See post #11 (observations on the bottom)

Kind regards,

Some years ago with help from this great website I got my Intel 750 series NVME drive working as the boot drive on my Z77 chipset board. I’ve upgraded the MB to an Asrock Z270m Pro 4 and the Intel 750 works great on this board. I’m still using Windows 7 due to old software I can’t upgrade for W10.

I recently purchased an Adata XPG SX8200 Pro to add in the m.2 slot. The bios shows both the Intel and Adata as NVME drives so both are recognized. The problem is that in device manager the Adata drive is shown as a “PCIe device” and shows the dreaded “!” next to it. Under properties it indicates that Windows could not load a driver for this hardware. Under storage controllers there is only the Intel 750 controller and no MS or other NVME drivers. Do I simply need to update the driver for this device to one of the files mentioned above? Where can I get them?

Anything else I should consider? Note that the Adata web site is no help for drivers or guidance and that this “pro” version was released just a few months ago.

Thanks.

Update:

On another web site I found the Microsoft hotfixes for Windows 7 and NVME drives. I installed both of those fixes and W7 then recognized the new drive, I was able to clone the Intel 750 to the Adata XPG SX8200 Pro and it’s my new boot drive.

Although the Intel 750 is a NVME drive and was working in my W7 machine, I still needed the MS hotfixes to get the Adata ssd working.

Hope my experience helps someone because the Adata web site and its “toolbox” software are both duds. On the positive side, the Crystal Disk readings on the Adata XPG SX8200 Pro are right up there with the Samsung 970 Pro which sells for far more money.