Adata XPG SX8200 NVMe, Windows 7 64bit and S.M.A.R.T.

Hello :slight_smile:

I bought this drive today and installed Windows 7 Ultimate 64bit.
Then I installed Crystaldiskinfo to check SMART info about it and… it does not recognize this drive. Adata SSD Toolbox, too. And others, HWinfo, AIDA… too.

NVMe SMART capability not supported in Windows7? Drive works and boots ok, I checked TRIM, too. Special drivers needed? I tried Windows 10 PE - it shows SMART data! Will it work in Windows 8.1?

Thanks for any info!

MB: MSI B250 PC MATE, CPU I5 7500

Kind regards!

@yac :
Welcome to the Win-RAID Forum!

Contrary to Win8.1 and Win10 the old OS Win7 has no in-box NVMe driver.

Yes, Win7 needs the NVMe driver, which can be integrated by using the related MS NVMe Hotfix for Win7. You can get it >here<.

Dieter (alias Fernando)

I integrated this hotfix driver to Windows ISO before installation so setup could recognize NVMe device and install on it. So it’s there but SMART data not showing… - not full support.

Anybody with Windows 7 and NVMe? Can you read your drive SMART status?

Kind regards,

Now you are installed, update driver to better Intel drivers

Intel NVMe drivers are only for Intel controller based NVMe drives. I tried and it doesn’t install. ADATA has Silicon Motion controller.

The “Smartmontools” from v6.5 up do support NVMe SSDs, but maybe not while running Win7 with the old MS NVMe Hotfix driver. For details look >here<.
If the latest smartmontools shouldn’t work for you while running the generic MS NVMe driver and you really need the S.M.A.R.T. values, I recommend to try another generic NVMe driver (OFA or Intel RST). If you are interested, please send me a PM.

Sorry, I assumed Intel storage drivers in general would install and be better than MS drivers, but I don’t have NVME so was wrong I see

@Lost_N_BIOS :
You were not absolutely wrong.
The v16 platform Intel RST drivers contain a generic NVMe driver, but they natively only support Win8.1 and Win10. Furthermore the installation has to be forced by using the “Have Disk” option (the related INF file is iaStorAC.inf).

Thanks Fernando, I’m a little behind on SSD tech! So, in Win8-10, does that offer better performance in general vs the MS driver?

No, according to my just published benchmark comparison test results (look >here<), the generic Intel NVMe drivers of the RST v16 platform are not the best choice, if the user wants the best possible NVMe Controller performance.

Hello again.

I did some testing today with OFA NVMe driver 1.5 and MS native NVMe driver on Windows 7 Ultimate 64bit. Testmode on, driver signing disabled.

CPU: i5-7500
System disk: Samsung 850 EVO SATA SSD
Tested disk: ADATA XPG SX8200 NVMe SSD

Here are the restults:

MS native NVMe Windows 7 64bit driver:

OFA NVMe 1.5 Windows 64 bit driver

OFA NVMe 1.5 Windows 64bit driver compiled by Schtrom (from forum)

Schtrom’s driver performed the best.

Other observations:

1. I was able to read ADATA’s SMART status on OFA NVMe drivers only.
2. TRIM on ADATA’s SSD is working on MS NVMe native driver only.
3. When using OFA NVMe drivers, ADATA device is configured as removable (usb quick remove icon on bottom bar) - maybe that’s why TRIM not working?

@Fernando I found mistake in driver that you send me (file ofvnme.inf, Line 88 - nvme_inst should be ofnvme_inst) after correcting this, driver installs but is not signed. Maybe unsigned drivers cause TRIM to not work?

Anybody knows other reason why TRIM on OFA driver is not working?

Kind regards,

According to my experience the OFA NVMe drivers v1.5.0.0 do support TRIM,

Yes, but it doesnt support TRIM, because it has been designed for Windows Server 2003!

You are right.
Meanwhie I have corrected this mistake. >Here< is the download link. Please test it again.

No matter I use your driver, Schtrom’s driver or OFA vanilla driver - TRIM does not work on NVMe drive.

Even your driver is signed, I must leave testmode-on and driver-signing-off options enabled - otherwise Windows has problem with boot and recovery is starting.

There is something strange with this OFA 1.5 Driver for Windows 7 64bit. I think it’s support is not complete.

What about NVMe drive configured as removable? - I think it shouldn’t be. Maybe here is a glitch. I tried some registry hacks but no luck.

Kind regards,

Maybe you can disable hot-swap for this drive in your BIOS?

How did you check it?
According to my experiences TRIM works fine with all OFA NVMe v1.5.0.0 drivers after having run the Win10 in-box “Optimizer”, whereas the Optimizer is not even available while running Schtrom’s modified OFA NVMe drivers v1.5.1200.0 (the SSD has been detected by Win10 as being a HDD!).

Not such option in my BIOS. I think it’s driver related, because when I use MS Standard NVMe driver - no safe removable icon in tray.

I use trimcheck-0.7-win64.exe to check if TRIM is working properly. It works on all connected SATA SSDs, but not on NVMe drive.

@yac :
The Trimcheck tool is not able to detect a very low TRIM activity.
That is why I recommend to trigger TRIM before starting the trimcheck tool. You can do it either by running the MS “Optimizer” or by using the related option of Anvil’s “Storage Utilities”.

TRIM should work automatically after deleting files, no need to trigger it… and it works like that on my SATA SSDs, but not on NVMe… when using OFA driver.

Why on MS Standard NVMe driver TRIM works ok on NVMe drive (after about half a minute data filled with zeroes - checked with trimcheck)? - this is the question.

@yac :
When I will have the required time and equipment, I will do some TRIM support tests with different NVMe Controllers and NVMe drivers.