Add Kabylake Support to Gigabyte Z370N


I have an Gigabyte Z370N which is only compatible to Coffee Lake CPU’s but I also want, that it Supports Kabylake CPU’s. I have dumped the BIOS via an CH341A Programmer, but when I open it via the Intel Flash Image Tool, then I get this Error Message “Component Section: Inalid Flash read frequency -6!”.
I don’t know, if the BIOS is now fully dumped or if something is locked there. I used the Intel Flash Image Tool, maybe this is maybe to old for the new Boards.
If I open the Original Gigabyte BIOS then I have the same error. When I try to Dump the BIOS via the ftpw64.exe then I get the Message that it can be run on the current platform. I have installed Windows 10 x64 on this PC.

Maybe someone can help me with this? I have uploaded my dumped BIOS which I made with the CH341A Programmer.


Update 2:
I have now modified the spi.bin to ME FW because in an other Thread I have read, that I need to downgrade to ME FW 11.6 to get the Kabylake Support. I have uploaded two screenshots with the Original spi.bin and one with the modified one. Can you please check, if my modified Image is correct, becasue, I don’t want to brick my board.

Update 1:
I used now the Intel CSME Tools V11 r12 and I could now dump the BIOS without any Errors with the command fptw64.exe -d spi.bin. Then I think nothing is locked on this board. I could open the spi.bin without any Errors now with the Intel Flash Image Tool.

Thank you.




outimage.rar (5.94 MB)

spi.rar (5.92 MB)

Looks good to me except one thing with ME, but that may not be avoidable, or maybe you missed it if manually doing the ME settings transfer? This controls Intel LAN, it’s located at “Networking & Connectivity” section in FIT, 4th setting down in that section
I compared and output differed at GbePCIePortSelect - one has setting of 4 (outimage) and one has setting of 5 (SPI)

Other than that, if your CPUID for desired kabylake CPU is 506E8 then you should be good, provided your vBIOS transfer/update mod was done properly.

Thanks for the hint to Change the GbePCIePortSelect. I have flashed it first with Port 4 and then I only had one LAN Card instead of two. After I have changed it to Port 5 then both were displayed again.

I tried to start an Kabylake i5 7400 CPU but when I try to start, it runs for an second and it turns itself off. When I boot with the Coffee Lake CPU again, then everything starts correctly. Did I do anything wrong there?

I have uploaded my modded BIOS which I have dumped via fptw.exe and and Screenshot from the ME Analyzer.

spi_mod.rar (5.96 MB)


Downgrade ME FW to or lower ( before Apr 2017)
Switch SKU to B250
And try again.

Thanks. I have changed the ME FW to and switched to the SKU B250. I could now boot succesfully with an Intel G4560.

Thanks @dsanke you saved the day!